Zen Cart Logo
Forums / Installing on a Windows Server / Error when trying to go to Admin, v154 on PHP 5.2

Error when trying to go to Admin, v154 on PHP 5.2

Views: 7,780

Results 1 to 20 of 28
2 Feb 2016, 3:25 AM
#1
wcsur avatar

wcsur

New Zenner

Join Date:
Mar 2014
Location:
Washington state
Posts:
59
Plugin Contributions:
0

Error when trying to go to Admin, v154 on PHP 5.2

New install Windows 8.1 FTP upload ran zc_install php 5.2.* SQL 5.1
Web site works fine just 404 error when trying to access admin side to set up store.
I have error log, but there old and related to when I couldn't access the database which hosting company fixed.
Don't know where to look to check to see it address is correct.

Nothing has been changed in any files.

include configure.php

<?php /** * @package Configuration Settings circa 1.5.4 * @copyright Copyright 2003-2014 Zen Cart Development Team * @copyright Portions Copyright 2003 osCommerce * @license <http://www.zen-cart.com/license/2_0.txt> GNU Public License V2.0 * File Built by zc_install on 2016-01-31 10:38:41 */ /*************** NOTE: This file is similar, but DIFFERENT from the "admin" version of configure.php. ***********/ /*************** The 2 files should be kept separate and not used to overwrite each other. ***********/ // Define the webserver and path parameters // HTTP_SERVER is your Main webserver: eg-http://www.your_domain.com // HTTPS_SERVER is your Secure webserver: eg-https://www.your_domain.com define('HTTP_SERVER', 'http://thedreamweaver.netau.net'); define('HTTPS_SERVER', 'https://thedreamweaver.netau.net'); // Use secure webserver for checkout procedure? define('ENABLE_SSL', 'false'); // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes! // * DIR_WS_* = Webserver directories (virtual/URL) // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder) define('DIR_WS_CATALOG', '/thedreamweaver/zen-cart-v1.5.4-12302014/'); define('DIR_WS_HTTPS_CATALOG', '/thedreamweaver/zen-cart-v1.5.4-12302014/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/'); define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/'); define('DIR_WS_PHPBB', '/'); // * DIR_FS_* = Filesystem directories (local/physical) //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/ define('DIR_FS_CATALOG', '/home/a5719373/public_html/thedreamweaver/zen-cart-v1.5.4-12302014/'); //the following path is a COMPLETE path to the /logs/ folder eg: /var/www/vhost/accountname/public_html/store/logs ... and no trailing slash define('DIR_FS_LOGS', '/home/a5719373/public_html/thedreamweaver/zen-cart-v1.5.4-12302014/logs'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/'); define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS); define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/'); // define our database connection define('DB_TYPE', 'mysql'); define('DB_PREFIX', ''); define('DB_CHARSET', 'utf8'); define('DB_SERVER', 'mysql7.000########################'); define('DB_SERVER_USERNAME', 'a5719373_Night'); define('DB_SERVER_PASSWORD', 'xxxxxxxx'); define('DB_DATABASE', 'a5719373_Dreams'); // The next 2 "defines" are for SQL cache support. // For SQL_CACHE_METHOD, you can select from: none, database, or file // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder // ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash define('SQL_CACHE_METHOD', 'none'); define('DIR_FS_SQL_CACHE', '/home/a5719373/public_html/thedreamweaver/zen-cart-v1.5.4-12302014/cache'); // EOF admin includes configure.php <?php /** * @package Configuration Settings circa 1.5.4 * @copyright Copyright 2003-2014 Zen Cart Development Team * @copyright Portions Copyright 2003 osCommerce * @license <http://www.zen-cart.com/license/2_0.txt> GNU Public License V2.0 * File Built by zc_install on 2016-01-31 10:38:41 */ /*************** NOTE: This file is similar, but DIFFERENT from the "store" version of configure.php. ***********/ /*************** The 2 files should be kept separate and not used to overwrite each other. ***********/ /** * WE RECOMMEND THAT YOU USE SSL PROTECTION FOR YOUR ENTIRE ADMIN: * To do that, make sure you use a "https:" URL for BOTH the HTTP_SERVER and HTTPS_SERVER entries: */ define('HTTP_SERVER', 'http://thedreamweaver.netau.net'); define('HTTPS_SERVER', 'https://thedreamweaver.netau.net'); define('HTTP_CATALOG_SERVER', 'http://thedreamweaver.netau.net'); define('HTTPS_CATALOG_SERVER', 'https://thedreamweaver.netau.net'); // secure webserver for admin? Valid choices are 'true' or 'false' (including quotes). define('ENABLE_SSL_ADMIN', 'false'); // secure webserver for storefront? Valid choices are 'true' or 'false' (including quotes). define('ENABLE_SSL_CATALOG', 'false'); define('DIR_WS_ADMIN', preg_replace('#^' . str_replace('-', '\-', zen_parse_url(HTTP_SERVER, '/path')) . '#', '', dirname($_SERVER['SCRIPT_NAME'])) . '/'); define('DIR_WS_CATALOG', '/thedreamweaver/zen-cart-v1.5.4-12302014/'); define('DIR_WS_HTTPS_ADMIN', preg_replace('#^' . str_replace('-', '\-', zen_parse_url(HTTPS_SERVER, '/path')) . '#', '', dirname($_SERVER['SCRIPT_NAME'])) . '/'); define('DIR_WS_HTTPS_CATALOG', '/thedreamweaver/zen-cart-v1.5.4-12302014/'); // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes! // * DIR_WS_* = Webserver directories (virtual/URL) // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder) define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_CATALOG_IMAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'images/'); define('DIR_WS_CATALOG_TEMPLATE', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/templates/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_CATALOG_LANGUAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/languages/'); // * DIR_FS_* = Filesystem directories (local/physical) define('DIR_FS_ADMIN', preg_replace('#.includes$#', '', realpath(dirname(__FILE__) . '/../') . '/')); //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/ define('DIR_FS_CATALOG', '/home/a5719373/public_html/thedreamweaver/zen-cart-v1.5.4-12302014/'); //the following path is a COMPLETE path to the /logs/ folder eg: /var/www/vhost/accountname/public_html/store/logs ... and no trailing slash define('DIR_FS_LOGS', '/home/a5719373/public_html/thedreamweaver/zen-cart-v1.5.4-12302014/logs'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_CATALOG_TEMPLATES', DIR_FS_CATALOG . 'includes/templates/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); // define our database connection define('DB_TYPE', 'mysql'); define('DB_PREFIX', ''); define('DB_CHARSET', 'utf8'); define('DB_SERVER', 'mysql7.000########################'); define('DB_SERVER_USERNAME', 'a5719373_Night'); define('DB_SERVER_PASSWORD', xxxxxxxxxx'); define('DB_DATABASE', 'a5719373_Dreams'); // The next 2 "defines" are for SQL cache support. // For SQL_CACHE_METHOD, you can select from: none, database, or file // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder // ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash define('SQL_CACHE_METHOD', 'none'); define('DIR_FS_SQL_CACHE', '/home/a5719373/public_html/thedreamweaver/zen-cart-v1.5.4-12302014/cache'); // Define the webserver and path parameters // Main webserver: eg-http://www.your_domain.com - // HTTP_SERVER is your Main webserver: eg-http://www.your_domain.com // HTTPS_SERVER is your Secure webserver: eg-https://www.your_domain.com // HTTP_CATALOG_SERVER is your Main webserver: eg-http://www.your_domain.com // HTTPS_CATALOG_SERVER is your Secure webserver: eg-https://www.your_domain.com /* * URLs for your site will be built via: * HTTP_SERVER plus DIR_WS_ADMIN or * HTTPS_SERVER plus DIR_WS_HTTPS_ADMIN or * HTTP_SERVER plus DIR_WS_CATALOG or * HTTPS_SERVER plus DIR_WS_HTTPS_CATALOG * ...depending on your system configuration settings */ // EOF
2 Feb 2016, 8:13 AM
#2
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Error when trying to go to Admin, v154 on PHP 5.2

wcsur:

Web site works fine just 404 error when trying to access admin side to set up store.

Welcome to the wonderful world of GoDaddy ;-)

wcsur:

I have error log, but there old

Delete them. They are of no further use and will make it difficult to see any new error logs.

wcsur:

Nothing has been changed in any files.

If it HAD been working, and it now isn't, then something has changed.

wcsur:

/*************** NOTE: This file is similar, but DIFFERENT from the "admin" version of configure.php.

OK, so if the front end of the site is working fine, then this file is almost certain to contain correct and valid data. Whatever you do, don't mess with it.

wcsur:

define('HTTP_SERVER', 'http://thedreamweaver.netau.net');

.netau.net? Seriously? Was this a freeby? ;-)

I initally thought that this was possibly the cause of your problem - figuring it should be .net.au
However it appears like a legitimate domain.

wcsur:

WS_CATALOG', '/thedreamweaver/zen-cart-v1.5.4-12302014/');

Nothing inherently wrong here, but do you really want to be 'stuck' with this folder name?

OK, so I've just reviewed both of the config files, and nothing really stood out as being amiss - the naming conventions are a little weird, but nothing that should cause any problems.

My next step was to verify that the problem was only with the admin side of things - but I can't even get to the store front. I am being greeted with

Your website is up and running!

Website thedreamweaver.netau.net has been successfully installed on server.
Please delete file "default.php" from public_html folder and upload your website by using FTP or web based File Manager.

What this is telling ME is that you haven't yet deleted the file "default.php", and it is this file that is being displayed. DELETE IT.

It is pointless doing anything else until this has been done. The site/page won't load while this file exists.

Next thing I noted was that this 'default.php' file is actually showing you/us the actual URL needed to access your website - and it ISN'T what you have defined in either of your configure files.

In your configure files you have
WS_CATALOG', '/thedreamweaver/zen-cart-v1.5.4-12302014/');

According to the data provided by 'default.php' this SHOULD (probably) be
WS_CATALOG', '/thedreamweaver/thedreamweaver/');

I think it goes without saying that this being the case, you will need to change all references of ' zen-cart-v1.5.4-12302014' to '/thedreamweaver/

This is about as far as I'm willing to go at the moment - These may or may not be the only problems (things you need to resolve), but it is a good start. Take care of these and see what happens.

Cheers
RodG


2 Feb 2016, 8:48 AM
#3
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Error when trying to go to Admin, v154 on PHP 5.2

Update: The correct URL for your Zencart store is actually

http://thedreamweaver.netau.net/thedreamweaver/zen-cart-v1.5.4-12302014/

IOW, it appears that your configure files are correct after all. (your 'old' store led me astray).

I've no way to determine what the URL for your admin should be, so I can't perform any further testing, but if you enter it correctly (it will be whatever you renamed it too during the install) there isn't any reason that I can see as to why you would be getting the 404 (not found) error.

Hopefully someone else can be a little more helpful than I have.

Cheers
RodG

2 Feb 2016, 10:37 AM
#4
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Error when trying to go to Admin, v154 on PHP 5.2

One thing that came to mind about why there might be a 404 error. When trying to access the admin folder was insensitivity to case sensitivity. If the admin folder name has capital letters in it then unlike the domain name, they must be entered the same. So a folder named TEST is different than a folder named test...

Basically that the attempted entry of the admin folder is incorrect as compared to the actual admin folder name... Not something that "should" be fully addressed. In a public setting as that would defeat the security by "hiding" the admin foldername...

2 Feb 2016, 3:30 PM
#6
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Error when trying to go to Admin, v154 on PHP 5.2

This will get you to store front till I can get it changed
Not a ZenCart storefront???

2 Feb 2016, 3:57 PM
#7
wcsur avatar

wcsur

New Zenner

Join Date:
Mar 2014
Location:
Washington state
Posts:
59
Plugin Contributions:
0

Re: Error when trying to go to Admin, v154 on PHP 5.2

Can't find default.php Originally, there was 2 thedreamweaver folders and I deleted one. May have deleted the wrong one. Is there an easy way to correct this or would it be simpler to reinstall zencart?

2 Feb 2016, 3:58 PM
#8
wcsur avatar

wcsur

New Zenner

Join Date:
Mar 2014
Location:
Washington state
Posts:
59
Plugin Contributions:
0

Re: Error when trying to go to Admin, v154 on PHP 5.2

Not yet it isn't, no working on the files but can't access the admin side.

2 Feb 2016, 3:59 PM
#9
wcsur avatar

wcsur

New Zenner

Join Date:
Mar 2014
Location:
Washington state
Posts:
59
Plugin Contributions:
0

Re: Error when trying to go to Admin, v154 on PHP 5.2

kobra:

Not a ZenCart storefront???

Not yet it isn't, no working on the files but can't access the admin side.

2 Feb 2016, 4:30 PM
#11
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Error when trying to go to Admin, v154 on PHP 5.2

wcsur:

Can't find default.php Originally, there was 2 thedreamweaver folders and I deleted one. May have deleted the wrong one. Is there an easy way to correct this or would it be simpler to reinstall zencart?

While it looks like something was done to put up/out the ZC store, the above would likely be addressed through your host and restoration of previous backups that are automatically made. (Your host offers this, yes?)

2 Feb 2016, 4:33 PM
#12
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Error when trying to go to Admin, v154 on PHP 5.2

wcsur:

Not yet it isn't, no working on the files but can't access the admin side.

This message is on your store front and is part of why you can't access the admin at this time:

SECURITY WARNING: Installation directory exists at: /home/xxxxxxx/public_html/thedreamweaver/zen-cart-v1.5.4-12302014/zc_install. Please remove this directory for security reasons.

2 Feb 2016, 5:01 PM
#13
wcsur avatar

wcsur

New Zenner

Join Date:
Mar 2014
Location:
Washington state
Posts:
59
Plugin Contributions:
0

Re: Error when trying to go to Admin, v154 on PHP 5.2

mc12345678:

This message is on your store front and is part of why you can't access the admin at this time:

Renamed the folder, dont want to delete it yet in case I want to reinstall but still give me that error when trying to go to admin.

2 Feb 2016, 5:03 PM
#14
wcsur avatar

wcsur

New Zenner

Join Date:
Mar 2014
Location:
Washington state
Posts:
59
Plugin Contributions:
0

Re: Error when trying to go to Admin, v154 on PHP 5.2

mc12345678:

While it looks like something was done to put up/out the ZC store, the above would likely be addressed through your host and restoration of previous backups that are automatically made. (Your host offers this, yes?)

Yes they do nut no backups yet, not running.

2 Feb 2016, 5:05 PM
#15
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Error when trying to go to Admin, v154 on PHP 5.2

wcsur:

Renamed the folder, dont want to delete it yet in case I want to reinstall but still give me that error when trying to go to admin.

What specific error are you now getting when attempting to access the admin?

2 Feb 2016, 5:11 PM
#16
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Error when trying to go to Admin, v154 on PHP 5.2

wcsur:

Renamed the folder, dont want to delete it yet in case I want to reinstall but still give me that error when trying to go to admin.

Fyi, in (some) times past after running zc_install one or more modifications are made to the contents and in order to run again (especially as suggested elsewhere in this forum) the directory is to be uploaded anew... Feel free to indicate that I'm wrong about the need to upload again. I've tried reusing on one or more upgrades to try the rename process only to require reupload during one or more of those upgrades...

2 Feb 2016, 5:15 PM
#17
wcsur avatar

wcsur

New Zenner

Join Date:
Mar 2014
Location:
Washington state
Posts:
59
Plugin Contributions:
0

Re: Error when trying to go to Admin, v154 on PHP 5.2

mc12345678:

Fyi, in (some) times past after running zc_install one or more modifications are made to the contents and in order to run again (especially as suggested elsewhere in this forum) the directory is to be uploaded anew... Feel free to indicate that I'm wrong about the need to upload again. I've tried reusing on one or more upgrades to try the rename process only to require reupload during one or more of those upgrades...

Basically file not found 404 error. I think at this point a reload may solve all my problems.

2 Feb 2016, 5:35 PM
#18
wcsur avatar

wcsur

New Zenner

Join Date:
Mar 2014
Location:
Washington state
Posts:
59
Plugin Contributions:
0

Re: Error when trying to go to Admin, v154 on PHP 5.2

What would be best, the zencart folder first with the dreamerweaver site inside or does it matter?

2 Feb 2016, 6:24 PM
#19
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Error when trying to go to Admin, v154 on PHP 5.2

wcsur:

What would be best, the zencart folder first with the dreamerweaver site inside or does it matter?

Not sure I understand the question. Maybe I don't understand the operating environment of the setup...

2 Feb 2016, 7:30 PM
#20
wcsur avatar

wcsur

New Zenner

Join Date:
Mar 2014
Location:
Washington state
Posts:
59
Plugin Contributions:
0

Re: Error when trying to go to Admin, v154 on PHP 5.2

OK started over. Deleted zencart and uploaded it back. Install went great. The 2 config files were changed to 644 and 444. Install file renamed for now and admin folder renamed. Before renaming it, I got a 500 error, after renaming it, I get redirected back to my host.

admin\includes\config:

<?php /** * @package Configuration Settings circa 1.5.4 * @copyright Copyright 2003-2014 Zen Cart Development Team * @copyright Portions Copyright 2003 osCommerce * @license <http://www.zen-cart.com/license/2_0.txt> GNU Public License V2.0 * File Built by zc_install on 2016-02-02 01:23:19 */ /*************** NOTE: This file is similar, but DIFFERENT from the "store" version of configure.php. ***********/ /*************** The 2 files should be kept separate and not used to overwrite each other. ***********/ /** * WE RECOMMEND THAT YOU USE SSL PROTECTION FOR YOUR ENTIRE ADMIN: * To do that, make sure you use a "https:" URL for BOTH the HTTP_SERVER and HTTPS_SERVER entries: */ define('HTTP_SERVER', 'http://thedreamweaver.netau.net'); define('HTTPS_SERVER', 'https://thedreamweaver.netau.net'); define('HTTP_CATALOG_SERVER', 'http://thedreamweaver.netau.net'); define('HTTPS_CATALOG_SERVER', 'https://thedreamweaver.netau.net'); // secure webserver for admin? Valid choices are 'true' or 'false' (including quotes). define('ENABLE_SSL_ADMIN', 'false'); // secure webserver for storefront? Valid choices are 'true' or 'false' (including quotes). define('ENABLE_SSL_CATALOG', 'false'); define('DIR_WS_ADMIN', preg_replace('#^' . str_replace('-', '\-', zen_parse_url(HTTP_SERVER, '/path')) . '#', '', dirname($_SERVER['SCRIPT_NAME'])) . '/'); define('DIR_WS_CATALOG', '/zen-cart/'); define('DIR_WS_HTTPS_ADMIN', preg_replace('#^' . str_replace('-', '\-', zen_parse_url(HTTPS_SERVER, '/path')) . '#', '', dirname($_SERVER['SCRIPT_NAME'])) . '/'); define('DIR_WS_HTTPS_CATALOG', '/zen-cart/'); // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes! // * DIR_WS_* = Webserver directories (virtual/URL) // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder) define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_CATALOG_IMAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'images/'); define('DIR_WS_CATALOG_TEMPLATE', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/templates/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_CATALOG_LANGUAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/languages/'); // * DIR_FS_* = Filesystem directories (local/physical) define('DIR_FS_ADMIN', preg_replace('#.includes$#', '', realpath(dirname(__FILE__) . '/../') . '/')); //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/ define('DIR_FS_CATALOG', '/home/a5719373/public_html/zen-cart/'); //the following path is a COMPLETE path to the /logs/ folder eg: /var/www/vhost/accountname/public_html/store/logs ... and no trailing slash define('DIR_FS_LOGS', '/home/a5719373/public_html/zen-cart/logs'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_CATALOG_TEMPLATES', DIR_FS_CATALOG . 'includes/templates/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); // define our database connection define('DB_TYPE', 'mysql'); define('DB_PREFIX', ''); define('DB_CHARSET', 'utf8'); define('DB_SERVER', 'mysql7.000########################'); define('DB_SERVER_USERNAME', 'a5719373_Night'); define('DB_SERVER_PASSWORD', 'xxxxxxxx'); define('DB_DATABASE', 'a5719373_Dreams'); // The next 2 "defines" are for SQL cache support. // For SQL_CACHE_METHOD, you can select from: none, database, or file // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder // ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash define('SQL_CACHE_METHOD', 'none'); define('DIR_FS_SQL_CACHE', '/home/a5719373/public_html/zen-cart/cache'); // Define the webserver and path parameters // Main webserver: eg-http://www.your_domain.com - // HTTP_SERVER is your Main webserver: eg-http://www.your_domain.com // HTTPS_SERVER is your Secure webserver: eg-https://www.your_domain.com // HTTP_CATALOG_SERVER is your Main webserver: eg-http://www.your_domain.com // HTTPS_CATALOG_SERVER is your Secure webserver: eg-https://www.your_domain.com /* * URLs for your site will be built via: * HTTP_SERVER plus DIR_WS_ADMIN or * HTTPS_SERVER plus DIR_WS_HTTPS_ADMIN or * HTTP_SERVER plus DIR_WS_CATALOG or * HTTPS_SERVER plus DIR_WS_HTTPS_CATALOG * ...depending on your system configuration settings */ // EOF includes\config: <?php /** * @package Configuration Settings circa 1.5.4 * @copyright Copyright 2003-2014 Zen Cart Development Team * @copyright Portions Copyright 2003 osCommerce * @license <http://www.zen-cart.com/license/2_0.txt> GNU Public License V2.0 * File Built by zc_install on 2016-02-02 01:23:19 */ /*************** NOTE: This file is similar, but DIFFERENT from the "admin" version of configure.php. ***********/ /*************** The 2 files should be kept separate and not used to overwrite each other. ***********/ // Define the webserver and path parameters // HTTP_SERVER is your Main webserver: eg-http://www.your_domain.com // HTTPS_SERVER is your Secure webserver: eg-https://www.your_domain.com define('HTTP_SERVER', 'http://thedreamweaver.netau.net'); define('HTTPS_SERVER', 'https://thedreamweaver.netau.net'); // Use secure webserver for checkout procedure? define('ENABLE_SSL', 'false'); // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes! // * DIR_WS_* = Webserver directories (virtual/URL) // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder) define('DIR_WS_CATALOG', '/zen-cart/'); define('DIR_WS_HTTPS_CATALOG', '/zen-cart/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/'); define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/'); define('DIR_WS_PHPBB', '/'); // * DIR_FS_* = Filesystem directories (local/physical) //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/ define('DIR_FS_CATALOG', '/home/a5719373/public_html/zen-cart/'); //the following path is a COMPLETE path to the /logs/ folder eg: /var/www/vhost/accountname/public_html/store/logs ... and no trailing slash define('DIR_FS_LOGS', '/home/a5719373/public_html/zen-cart/logs'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/'); define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS); define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/'); // define our database connection define('DB_TYPE', 'mysql'); define('DB_PREFIX', ''); define('DB_CHARSET', 'utf8'); define('DB_SERVER', 'mysql7.000########################'); define('DB_SERVER_USERNAME', 'a5719373_Night'); define('DB_SERVER_PASSWORD', 'xxxxxxxxx'); define('DB_DATABASE', 'a5719373_Dreams'); // The next 2 "defines" are for SQL cache support. // For SQL_CACHE_METHOD, you can select from: none, database, or file // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder // ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash define('SQL_CACHE_METHOD', 'none'); define('DIR_FS_SQL_CACHE', '/home/a5719373/public_html/zen-cart/cache'); // EOF And won't go straight to the store front. I don't know what do do next!