Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Installation stalls on email input

Installation stalls on email input

Views: 1,872

Results 1 to 16 of 16
19 Mar 2016, 10:43 PM
#1
cobaltcat avatar

cobaltcat

New Zenner

Join Date:
Mar 2012
Posts:
14
Plugin Contributions:
0

Installation stalls on email input

Installing 1.5.5. At the Admin Setup page. I input the Admin Superuser email address, but when I click the continue button, it tells me I need to "use the required format." There's nothing wrong with the address. I've tried using three different addresses, still not accepting it.

19 Mar 2016, 11:01 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Installation stalls on email input

Given that you've used "3 different addresses", I'm assuming they don't all contain strange characters, etc. SO, that sounds like something's interfering with the javascript validator.
And, while I'd definitely like to find out exactly what's causing it, if you're just wanting to "get started" and jump to the Admin, you can do that and use the default admin username of "Admin" and password of "admin". It'll ask you to reset that password, and then you can go to the Admins menu and change/set the username/email manually there. You'll also want to manually set the 10 notifications email addresses in the Admin->Configuration->Email Options screen.

If you're interested in troubleshooting further, I'd like to see some screenshots, and perhaps even have the URL to that page to do some live debug research with it from my own browser. You could send that via forum Private Message.
I'd also like to know which browser you're using when you're seeing this.

20 Mar 2016, 12:33 AM
#3
cobaltcat avatar

cobaltcat

New Zenner

Join Date:
Mar 2012
Posts:
14
Plugin Contributions:
0

Re: Installation stalls on email input

That's correct, the emails do not contain any odd characters, they are legit email addresses.

This is happening during the install process, so I can't get by it. I've tried using Firefox, Safari, Chrome & Opera. In all but Opera, I can't get past the first install screen, the Continue button doesn't work.

Here is a screen shot in Opera, showing the error message.
Attachment 16129

20 Mar 2016, 1:47 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Installation stalls on email input

Odd. I can't trigger either of those problems on any of those same browsers.

2 suggestions:

  1. Given that you say you're having other problems with multiple browsers, it makes me wonder if perhaps the zc_install folder didn't fully upload properly and perhaps some files are missing/damaged.
    Could you re-upload the whole folder and test again, including the "first page problem in other browsers".

  2. You could also try editing zc_install/includes/templates/common/tpl_main_page.php ... on line 66 is the email pattern. Take that line out (don't just comment it out), and see if it properly falls back to another validation pattern.

What's particularly interesting about the message you're seeing, is that the phrase "Please use the required format" doesn't exist anywhere in Zen Cart or any of the javascript libraries it uses.

20 Mar 2016, 3:07 AM
#5
cobaltcat avatar

cobaltcat

New Zenner

Join Date:
Mar 2012
Posts:
14
Plugin Contributions:
0

Re: Installation stalls on email input

I deleted that folder and re-uploaded it, but it didn't make any difference. Same with editing the tpl_main_page.php file, no joy. I may just have to wait til my cPanel offers the latest version and install it from there. Thanks for the help, everyone!

20 Mar 2016, 3:16 AM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Installation stalls on email input

Very unusual.

You could carry on by logging into your Admin, as I described in my first post above. I'd be curious if you experience any other anomalies when doing that.

20 Mar 2016, 8:34 PM
#7
cobaltcat avatar

cobaltcat

New Zenner

Join Date:
Mar 2012
Posts:
14
Plugin Contributions:
0

Re: Installation stalls on email input

Can't get to the admin. If I go to http://sarmssource.com/admin/ , I get:
ERROR 0071: There appears to be a problem with the database. Maintenance is required.

I tried the install on my tablet, too. Couldn't get past the second screen, the continue button doesn't work.

20 Mar 2016, 9:27 PM
#8
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Installation stalls on email input

In your zc_install I'm seeing that the ajax/javascript calls to the server are failing ... specifically, they're resulting in generic "500 Error" responses, which means the server is unhappy with something it's encountering ... whether that's PHP errors, or the server's security tools are disagreeing with the permission-level you've set on files, etc.

If you made the configure.php files to be "777", try changing those to "755" instead, because sometimes 777 triggers that generic "500" response.

Additionally, check the webserver's Apache error_log (via your hosting control panel) to see what the cause of the 500 error is.

20 Mar 2016, 9:42 PM
#9
cobaltcat avatar

cobaltcat

New Zenner

Join Date:
Mar 2012
Posts:
14
Plugin Contributions:
0

Re: Installation stalls on email input

I deleted all files on the server, downloaded a new zip file, uploaded all new files, changed permissions as in the instructions with the exception on the configure.php files, which I set to 755. Still no joy.

The error logs show this:
client denied by server configuration: /home/srss2950/public_html/includes/filenames.php

filenames.php is set to 644.

20 Mar 2016, 9:46 PM
#10
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Installation stalls on email input

  1. The "client denied" to "filenames.php" is actually very intentional. That's how zc_install tests whether .htaccess properly blocks unauthorized access to files under the /includes/ folder. So, that particular error is completely expected.

  2. But, on "page 2" (System Setup), the Continue button only "works" via an Ajax call which verifies the data entered on-screen. If you tell your browser to display Console Errors you'll see the "Error 500" while trying to call the ajax file for the systemsetup page. You'll want to look for that filename in your Apache error logs.

20 Mar 2016, 9:58 PM
#11
cobaltcat avatar

cobaltcat

New Zenner

Join Date:
Mar 2012
Posts:
14
Plugin Contributions:
0

Re: Installation stalls on email input

The console only shows one error:

ReferenceError: mediaWiki is not defined
<anonymous> wikibits.js:243

20 Mar 2016, 10:05 PM
#12
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Installation stalls on email input

That must be caused by a plugin you've got installed in your browser. But it shouldn't have any impact on Zen Cart.

Here's what I see when I click Continue on your zc_install after first checking the box for license agreement and leaving the rest of the fields alone:

Attachment 16135

20 Mar 2016, 10:12 PM
#13
cobaltcat avatar

cobaltcat

New Zenner

Join Date:
Mar 2012
Posts:
14
Plugin Contributions:
0

Re: Installation stalls on email input

What do you think that means? The file is there, it has content. I deleted it and re-uploaded it, just in case. Permissions set to 644.

20 Mar 2016, 10:17 PM
#14
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Installation stalls on email input

The "error 500" is completely generic. The only way to find out exactly what's causing it is to look at the server's logs, wherever PHP is configured to store them.
If the error is occurring before Zen Cart can intercept the location (to the /logs/ folder) then the errors will be in wherever PHP is set to put them ... sometimes that's in the Apache error_log. Sometimes it's in a PHP error-logging location (unfortunately often in a place that only your hosting company can access).

20 Mar 2016, 10:24 PM
#15
cobaltcat avatar

cobaltcat

New Zenner

Join Date:
Mar 2012
Posts:
14
Plugin Contributions:
0

Re: Installation stalls on email input

OK, I figured it out. When I first started the install, it warned me about the PHP version (5.4), so I set it to 5.5. On a hunch, I set it back to 5.4 (native) and the install went through.

Thanks for all the help!

20 Mar 2016, 10:46 PM
#16
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Installation stalls on email input

That must mean your server's PHP 5.5 configuration has some security settings that are quite different from the PHP 5.4 settings are. Just something to keep in mind for future when you do want to change to the newer PHP version.