Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Can't run ZC 1.5.5 installation

Can't run ZC 1.5.5 installation

Views: 1,679

Results 1 to 12 of 12
30 Apr 2016, 8:55 PM
#1
laki avatar

laki

New Zenner

Join Date:
Aug 2013
Location:
Montenegro
Posts:
72
Plugin Contributions:
0

Can't run ZC 1.5.5 installation

Hi,

I can't run ZC 1.5.5 installation and this makes me confused since I've done the same installation successfully on another domain recently.

What I did step by step: I unpacked and uploaded ZC 1.5.5 to my server, rename both dist-configure.php files to configure.php and set up the correct permissions. Previously i created database with username and password to be used for this installation. When I run the installation i see the next error:

**Warning: require(/home4/rootfolder/public_html/mynewzen/zc_install/includes/classes/class.zcConfigureFileReader.php): failed to open stream: No such file or directory in /home4/rootfolder/public_html/mynewzen/zc_install/includes/application_top.php on line 55

Fatal error: require(): Failed opening required '/home4/rootfolder/public_html/mynewzen/zc_install/includes/classes/class.zcConfigureFileReader.php' (include_path='.:/opt/php54/lib/php') in /home4/rootfolder/public_html/mynewzen/zc_install/includes/application_top.php on line 55**

Let's say that the folder name where new ZC was uploaded is "mynewzen". It's a subdomain where I'm trying to set up new ZC site. I run installation typing: main-domain.com/mynewzen/zc_install and I've experienced the error above.

I performed a new ZC 1.5.5 installation on the same server a month ago and I didn't experienced this issue.

Thanks for support!

30 Apr 2016, 10:39 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Can't run ZC 1.5.5 installation

"No such file or directory" means some or several of the files didn't get uploaded. Re-upload your zc_install folder and all subfolders.

30 Apr 2016, 11:30 PM
#3
laki avatar

laki

New Zenner

Join Date:
Aug 2013
Location:
Montenegro
Posts:
72
Plugin Contributions:
0

Re: Can't run ZC 1.5.5 installation

I did it and all files are on the server but still see the same error.

1 May 2016, 12:29 AM
#4
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Can't run ZC 1.5.5 installation

Let's say that the folder name where new ZC was uploaded is "mynewzen". It's a subdomain where I'm trying to set up new ZC site. I run installation typing: main-domain.com/mynewzen/zc_install and I've experienced the error above.
Might be because this is a "Subdomain" that you need to access it as such - not sure but try accessing it as

mynewzen.main-domain.com/zc_install

1 May 2016, 9:25 AM
#5
laki avatar

laki

New Zenner

Join Date:
Aug 2013
Location:
Montenegro
Posts:
72
Plugin Contributions:
0

Re: Can't run ZC 1.5.5 installation

Yes, I've tried both options - mynewzen.main-domain.com/zc_install and main-domain.com/mynewzen/zc_install - but the same error occurs. Really tricky for me because I'm pretty sure that all file has been uploaded to the server.
I'll be searching for the solution and let you know if I solved this but would appreciate if someone shares an idea in the meantime :))

Thanks!

1 May 2016, 10:21 AM
#6
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Can't run ZC 1.5.5 installation

Are you still getting the debug log with file not found error?
If so, using ftp - check the files looking for any that might be "0" bytes

1 May 2016, 1:29 PM
#7
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Can't run ZC 1.5.5 installation

Why was dist-configure.php renamed to configure.php? Installation from a vanilla version of ZC will create the applicable file, also, by renaming (not copying) the file, you now have lost a file that could be used as a reference when other trouble hits.

1 May 2016, 5:54 PM
#8
laki avatar

laki

New Zenner

Join Date:
Aug 2013
Location:
Montenegro
Posts:
72
Plugin Contributions:
0

Re: Can't run ZC 1.5.5 installation

I renamed dist-configure.php to configure.php following the instructions for the installation (https://www.zen-cart.com/content.php?147-how-do-i-install-zen-cart).
I've recently completed successfully another ZC 1.5.5 installation in the same way.

1 May 2016, 8:19 PM
#9
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Can't run ZC 1.5.5 installation

Laki:

I renamed dist-configure.php to configure.php following the instructions for the installation (https://www.zen-cart.com/content.php?147-how-do-i-install-zen-cart).
I've recently completed successfully another ZC 1.5.5 installation in the same way.

OK, I just usually allow ZC to autogenerate the file(s) rather than to go through the "effort" of renaming the files.

It does seem that based on the error message that one or more files is actually missing or incompletely uploaded. Hopefully you have gone back to either validate the file(s), or uploaded them again. Validation should include opening the file(s) and reviewing the contents to ensure equivalent to the original file(s).

1 May 2016, 11:00 PM
#10
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Can't run ZC 1.5.5 installation

Not stated nor asked, but was the unpacking of files to a blank directory or was there a ZC store there already?

2 May 2016, 3:33 AM
#11
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Can't run ZC 1.5.5 installation

Laki:

I renamed dist-configure.php to configure.php following the instructions for the installation (https://www.zen-cart.com/content.php?147-how-do-i-install-zen-cart).
I've recently completed successfully another ZC 1.5.5 installation in the same way.

mc12345678:

Why was dist-configure.php renamed to configure.php? Installation from a vanilla version of ZC will create the applicable file, also, by renaming (not copying) the file, you now have lost a file that could be used as a reference when other trouble hits.
The instructions tell the person installing to do the rename, because many webservers require the file to "already exist" in order to be able to gain sufficient permissions to write. And, if the server requires higher permissions in order for PHP to write then those must be granted manually and so the file must be present in order to grant those permissions to the file.

But, if your server has relaxed security such that PHP can create and delete files without modifying any permissions, then zc_install can indeed create those files directly, without you needing to create them first or rename from dist-configure first.

2 May 2016, 3:36 PM
#12
laki avatar

laki

New Zenner

Join Date:
Aug 2013
Location:
Montenegro
Posts:
72
Plugin Contributions:
0

Re: Can't run ZC 1.5.5 installation

I somehow solved this problem. Obviously something were missing and it prevented the installation from running. I downloaded Zen Cart again on another computer and this time I used this option "Click here if you prefer an HTTPS download" insted of going to https://sourceforge.net/projects/zencart/files/

I don't know if this helped or I just was lucky this time to download it properly but this installation was performed smoothly.

Also, thank you for the explanation about renaming of configure.php files.

Best,
Laki