Zen Cart Logo
Forums / Upgrading to 1.5.x / admin page won't show

admin page won't show

Views: 1,256

Results 1 to 4 of 4
2 Jun 2016, 7:41 AM
#1
darkangel avatar

darkangel

Totally Zenned

Join Date:
Oct 2007
Location:
Emporia, Kansas
Posts:
1,729
Plugin Contributions:
0

admin page won't show

clean install of brand new store...tried 3 times already

  1. letting the installer name admin folder then when done used link to access admin--white page. I then emptied out DB and reinstalled it AFTER I named admin folder myself.

no errors during installation, front end comes up but still no admin, just white page. Error log in log folder claims that the folders in the admin/includes do not appear to be there. I have verified they are on server with ftp, c-panel and by uploading them manually one at a time...LOL

still no admin page.

I have emptied out the DB again leaving only the tables without info in them. I will reupload the files fresh to ensure EVERYTHING is in there.

Is there something else I should see about?

This is in an error_log in root folder of domain

[code[[02-Jun-2016 02:25:18 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module
Module compiled with module API=20100525
PHP compiled with module API=20131226
These options need to match
in Unknown on line 0
[02-Jun-2016 02:25:18 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module
Module compiled with module API=20100525
PHP compiled with module API=20131226
These options need to match
in Unknown on line 0[/code]

from Log folder:

[02-Jun-2016 02:27:41 America/Chicago] Request URI: /admin/, IP address: my IP
#1  include() called at [path/admin/includes/initsystem.php:26]
#2  require(path/admin/includes/initsystem.php) called at [path/admin/includes/application_top.php:167]
#3  require(path/admin/includes/application_top.php) called at [path/admin/index.php:10]

[02-Jun-2016 02:27:41 America/Chicago] PHP Warning:  include(includes/auto_loaders/config.core.php): failed to open stream: No such file or directory in path/admin/includes/initsystem.php on line 26
[02-Jun-2016 02:27:41 America/Chicago] Request URI: /admin/, IP address: my IP
#1  include() called at [path/admin/includes/initsystem.php:26]
#2  require(path/admin/includes/initsystem.php) called at [path/admin/includes/application_top.php:167]
#3  require(path/admin/includes/application_top.php) called at [path/admin/index.php:10]

[02-Jun-2016 02:27:41 America/Chicago] PHP Warning:  include(): Failed opening 'includes/auto_loaders/config.core.php' for inclusion (include_path='.:/opt/php54/lib/php') in path/admin/includes/initsystem.php on line 26
[02-Jun-2016 02:27:41 America/Chicago] Request URI: /admin/, IP address: my IP
#1  dir() called at [path/admin/includes/initsystem.php:27]
#2  require(path/admin/includes/initsystem.php) called at [path/admin/includes/application_top.php:167]
#3  require(path/admin/includes/application_top.php) called at [path/admin/index.php:10]

[02-Jun-2016 02:27:41 America/Chicago] PHP Warning:  dir(includes/auto_loaders): failed to open dir: No such file or directory in path/admin/includes/initsystem.php on line 27
[02-Jun-2016 02:27:41 America/Chicago] PHP Fatal error:  Call to undefined function zen_get_languages() in path/admin/index.php on line 12
2 Jun 2016, 10:24 AM
#2
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: admin page won't show

How is your site referenced? Is it by a domain name or by ip address?

Messages appear to indicate some sort of background setup issue. What version of ZC was previously working under this setup? Are you able to select a higher version of PHP than 5.4? (thinking that since there was a potential compile issue with the associated software, that perhaps a newer version would not have the same issues.)

2 Jun 2016, 10:58 AM
#3
darkangel avatar

darkangel

Totally Zenned

Join Date:
Oct 2007
Location:
Emporia, Kansas
Posts:
1,729
Plugin Contributions:
0

Re: admin page won't show

mc12345678:

How is your site referenced? Is it by a domain name or by ip address?

Messages appear to indicate some sort of background setup issue. What version of ZC was previously working under this setup?

None this is a totally fresh clean install

Are you able to select a higher version of PHP than 5.4? (thinking that since there was a potential compile issue with the associated software, that perhaps a newer version would not have the same issues.)

no unfortunately I think it is a shared server, I can create the php.ini file and will look later when I get up to see for sure but I don't think c-panel will let me set higher PHP.

This is on Hostgator and I have another store I installed on this host---version 1.5.4 of Zen with no problems.

2 Jun 2016, 1:32 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: admin page won't show

DarkAngel:

This is in an error_log in root folder of domain

[code[[02-Jun-2016 02:25:18 America/Chicago] PHP Warning: PHP Startup: imagick: Unable to initialize module
Module compiled with module API=20100525
PHP compiled with module API=20131226
These options need to match
in Unknown on line 0
[02-Jun-2016 02:25:18 America/Chicago] PHP Warning: PHP Startup: SourceGuardian: Unable to initialize module
Module compiled with module API=20100525
PHP compiled with module API=20131226
These options need to match
in Unknown on line 0[/code]Those are misconfigurations in your php.ini. Work with your hosting company to fix those. They are not caused by Zen Cart.
And they're also not likely the cause of a blank page.

DarkAngel:

[02-Jun-2016 02:27:41 America/Chicago] PHP Warning: include(includes/auto_loaders/config.core.php): failed to open stream: No such file or directory in path/admin/includes/initsystem.php on line 26
[02-Jun-2016 02:27:41 America/Chicago] PHP Warning: dir(includes/auto_loaders): failed to open dir: No such file or directory in path/admin/includes/initsystem.php on line 27

Those are all telling you that a number of files under the admin folder are missing...
... particularly:
/admin/includes/auto_loaders folder is missing, or has its permissions-level set so low that PHP isn't allowed to access it.
(NOTE: while the error messages say "(includes/auto_loaders)", they're referring to "admin/includes/auto_loaders" because it's an admin file calling them (as shown in the rest of the error message)

> **DarkAngel:**
>
> ```
[02-Jun-2016 02:27:41 America/Chicago] PHP Fatal error:  Call to undefined function zen_get_languages() in path/admin/index.php on line 12
```That's telling you that the file that contains the zen_get_languages() function wasn't loaded either ... perhaps because the file is missing? In v155 it's /admin/includes/functions/general.php