Thanks. I found the cause, but not the solution. Here is what had happened. dreamhost has an option to let me redirect https://www.store.com to store.com or store.com to https://www.store.com or do no redirect. I wanted (perhaps mistakenly) to redirect store.com to https://www.store.com. Which, after making the change, worked for the catalog. no problem. admin page worked for a while, the would get that redirect error. I changed the option back to the do nothing setting. admin page seems to be working fine now.
I would like to understand what I should have done to get the redirect working correctly. guidance on proper configuration is much appreciated.
to recap the settings. dreamhost was set to direct store.com to https://www.store.com.
The configure files have the following details.
store.com/includes/configure.php has the following (i added the spaces to the store name)
define('HTTP_SERVER', 'https://www. a l l e y s t a m p .com');
define('HTTPS_SERVER', 'https://www. a l l e y s t a m p .com');
// Use secure webserver for checkout procedure?
define('ENABLE_SSL', 'true');
// NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
// * DIR_WS_* = Webserver directories (virtual/URL)
// these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
define('DIR_WS_CATALOG', '/');
define('DIR_WS_HTTPS_CATALOG', '/');
The admin/includes/configure.php file has these settings: (again I added spaces to store name)
define('HTTP_SERVER', 'https://www. a l l e y s t a m p .com');
define('HTTPS_SERVER', 'https://www. a l l e y s t a m p .com');
define('HTTP_CATALOG_SERVER', 'https://www. a l l e y s t a m p .com');
define('HTTPS_CATALOG_SERVER', 'https://www. a l l e y s t a m p .com');
// Use secure webserver for catalog module and/or admin areas?
define('ENABLE_SSL_CATALOG', 'true');
define('ENABLE_SSL_ADMIN', 'true');
// NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
// * DIR_WS_* = Webserver directories (virtual/URL)
// these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
define('DIR_WS_ADMIN', '/Admin/');
define('DIR_WS_CATALOG', '/');
define('DIR_WS_HTTPS_ADMIN', '/Admin/');
define('DIR_WS_HTTPS_CATALOG', '/');
The .htaccess file is most likely the culprit. when I reset the dreamhost setting, that file wasn't updated and regular pages errorred out. :( I commented the redirect code and product pages are showing again.
This is what I commented out. (spaces in the store name are added by me)
#### Require SSL (https://)
#RewriteEngine On
#RewriteCond %{SERVER_PORT} !^443$
#RewriteRule ^(.*)$ https://(www\.)?a l l e y s t a m p .com/$1 [R=permanent]
#SSLOptions +StrictRequire
#SSLRequireSSL
#SSLRequire %{HTTP_HOST} eq "a l l e y s t a m p.com" #or www.a l l e y s t a m p.com
#ErrorDocument 403 https://www.a l l e y s t a m p.com
#### end ssl ##
This is the rest of the file.
#
<Files .htaccess>
order allow,deny
deny from all
</Files>
## deny *everything*
##<FilesMatch ".*">
## Order Allow,Deny
## Deny from all
##</FilesMatch>
#
## but now allow just *certain* necessary files:
<FilesMatch ".*\.(zip|ZIP|gzip|pdf|PDF|mp3|MP3|swf|SWF|wma|WMA|wmv|WMV|wav|epub)$">
Order Allow,Deny
Allow from all
</FilesMatch>
#
ErrorDocument 401 "</p><p><strong>Sorry, the document you requested could not be found.</strong></p>"
ErrorDocument 403 "</p><p><strong>Sorry, the document you requested could not be found.</strong></p>"
ErrorDocument 404 "</p><p><strong>Sorry, the document you requested could not be found.</strong></p>"
ErrorDocument 500 "</p><p><strong>Hey sorry. There was an internal server error...</strong></p>"
##<IfModule mod_headers.c>
## <FilesMatch ".*\.(zip|ZIP|pdf|PDF|mp3|MP3|swf|SWF|wma|WMA|wmv|WMV|wav|epub)$">
## # tell all downloads to automatically be treated as "save as" instead of launching in an application directly
## # ALERT: ForceType requires Apache2 or later. If using older version of Apache, it will need mod_mime installed. Or just comment out the ForceType line below
## # (to disable, just comment the next 2 lines by adding a '#' at the beginning of each):
## ForceType application/octet-stream
## Header set Content-Disposition attachment
## </FilesMatch>
##</IfModule>
#
### Hotlinking
#RewriteEngine On
#RewriteCond %{HTTP_REFERER} !^$
#RewriteCond %{HTTP_REFERER} !^http://(www\.)?a l l e y s t a m p.com/.*$ [NC]
#RewriteRule \.(gif|jpg)$ http://www.a l l e y s t a m p.com/hotlink.gif [R,L]
#RewriteEngine On
#RewriteCond %{HTTP_REFERER} !^$
#RewriteCond %{HTTP_REFERER} !^https://(www\.)?a l l e y s t a m p.com/.*$ [NC]
#RewriteRule \.(gif|jpg)$ https://www.a l l e y s t a m p.com/hotlink.gif [R,L]
###
IndexIgnore */*