Zen Cart Logo
Forums / Templates, Stylesheets, Page Layout / Suddenly Front end blank. Admin fine.

Suddenly Front end blank. Admin fine.

Views: 15,173

Results 1 to 20 of 78
7 Jul 2016, 2:01 AM
#1
nepherael avatar

nepherael

New Zenner

Join Date:
Jul 2016
Posts:
29
Plugin Contributions:
0

Suddenly Front end blank. Admin fine.

Hello,

I have been pulling my hair out for 36 hours straight trying to fix this for a client.

Their website went down yesterday with no explanation. No changes no nothing.

There are no sales occurring on this site. It is used as a catalog of sorts for customers.

Issue experienced: admin side loads fine, full access. Front end will not load in any way. Just a blank page with blank header and body.

It is hosted at godaddy. The original developer had most of the site in a subfolder with a bunch of "target redirects" in the root. I could not edit, copy, or otherwise mess with them so I deleted all of them and recreated the URL redirects with godaddy's interface. That doesn't seem to be the issue.

I've seen this happen in other threads while surfing around but mostly to the admin side so I don't know what to do. I've looked through the includes/configure.php file as well as the configure in the admin side. All values are what they are supposed to be

Summary of actual changes made: upgraded php 5.2 to 5.3 on the Godaddy server side (the admin server info recognized the change) and deleted those weird redirects and reinstated them with the Godaddy interface. I've made many other changes and then reverted back when they didn't fix the issue.

I am happy to provide any information to help me figure this out. The only thing I found remotely similar was someone who had the same issue and rebuilt the site and replaced 3 database tables. She couldn't figure out the exact culprit but that some database table had been corrupted in some way.

I debated moving the site to the root folder and following that process but the redirects I set are working fine and I'm being directed to all the correct pages. They just won't load.

I repeat no edits or revisions of any sort were applied before this site refused to load. There are NO error logs of any kind (and I've added all the show error stuff and still do not receive error messages).

Any help would be GREATLY appreciated. I thought about upgrading to 1.5.5 but I don't know of that will mess up the template or create MORE issues on top of this error so I am avoiding that for now.

7 Jul 2016, 3:26 AM
#2
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Suddenly Front end blank. Admin fine.

Nepherael:

Their website went down yesterday with no explanation. No changes no nothing.

something changed, else you wouldn't be having a problem.

Nepherael:

It is hosted at godaddy. The original developer had most of the site in a subfolder with a bunch of "target redirects" in the root. I could not edit, copy, or otherwise mess with them so I deleted all of them and recreated the URL redirects with godaddy's interface. That doesn't seem to be the issue.

A correctly installed Zencart doesn't need redirects. Try removing them completely (I'm assuming the redirects are in the .htaccess file in the root folder of the store).

Nepherael:

I've seen this happen in other threads while surfing around but mostly to the admin side so I don't know what to do.

First things 1st -- check the log files.

Nepherael:

I've looked through the includes/configure.php file as well as the configure in the admin side. All values are what they are supposed to be

We don't know that, and we have been led astray many times when people tell us that everything is as they are supposed to be, even though this may not be the case.

Nepherael:

Summary of actual changes made: upgraded php 5.2 to 5.3

Was this before the problem started, or after? - old versions of zencart don't play nicely with the later versions of PHP.

Nepherael:

on the Godaddy server side (the admin server info recognized the change) and deleted those weird redirects and reinstated them with the Godaddy interface. I've made many other changes and then reverted back when they didn't fix the issue.

Have you checked the log files?

Nepherael:

I am happy to provide any information to help me figure this out. The only thing I found remotely similar was someone who had the same issue and rebuilt the site and replaced 3 database tables. She couldn't figure out the exact culprit but that some database table had been corrupted in some way.

Blank screens can be caused by any number of things - Each case needs to be treated on their own merits.
This may help.....
https://www.zen-cart.com/content.php?124-blank-page

Nepherael:

I debated moving the site to the root folder and following that process but the redirects I set are working fine and I'm being directed to all the correct pages. They just won't load.

This will only complicate matters - you'll end up with the original problem, plus any new problems associated with the move,

Nepherael:

I repeat no edits or revisions of any sort were applied before this site refused to load.

Something changed.

Nepherael:

There are NO error logs of any kind (and I've added all the show error stuff and still do not receive error messages).

We've heard this before too. What version of Zencart are you using, and which folder(s) did you look at for the error logs? (older versions placed them in the /cache/ folder, newer versions place them in the /logs/ folder.

Nepherael:

Any help would be GREATLY appreciated. I thought about upgrading to 1.5.5 but I don't know of that will mess up the template or create MORE issues on top of this error so I am avoiding that for now.

Again, all this will (probably) do is compound the problem - On the other hand, if the problem is due to a PHP upgrade, this may also be the solution you are seeking. Personally, I wouldn't risk it, it would be easier to "prove the point" first by downgrading to the older PHP and then deciding whether to upgrade (which you should anyway if you are still using a V1.3.x) - but only after proving that this is the cause.

Sorry I can't give any definitive answers, there are too many possibilities that can cause the same symptoms.

If using zen 1.3.8 this debug tool may help
https://www.zen-cart.com/downloads.php?do=file&id=606

Cheers
RodG

7 Jul 2016, 11:54 AM
#3
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Suddenly Front end blank. Admin fine.

When reviewing the actions of the link RodG provided, be sure to also consider the advanced problem solving area at the bottom of that FAQ after the other methods do not resolve the issue.

7 Jul 2016, 11:54 AM
#4
nepherael avatar

nepherael

New Zenner

Join Date:
Jul 2016
Posts:
29
Plugin Contributions:
0

Re: Suddenly Front end blank. Admin fine.

Something changed yes but I believe it was a server side change with Godaddy causing php not to load. Problem is, it's not something they are fessing up to and it could be as simple as a security change but it's not like I can reverse it so I have to fix it on my end. I am currently the only one with admin access to this site and the hosting able to make any changes and I haven't been near it in months.

There are no errors thrown. Not in the Zen logs (yes I looked in both folders), not in the server logs, not even when I put all the php error reporting on. Because PHP won't load at all.

I believe you that redirects are not required but it has functioned for years with the redirects so something about the way it was built requires them. When I took the redirects out it could not find the Zencart files. I just got the Zen page saying "this website coming soon. You didn't upload it right". The configure.php files have the values for the sub directory but that doesn't matter because Godaddy does not allow subdirectory installs of the primary domain (a fight I've had with them multiple times) so I have to have the redirects because the main URL will always point to the root directory without it anyway.

The 2 changes I made were after the website went down. PHP 5.3 cannot be downgraded to 5.2 at this point.

I am on Zen 1.5.1

7 Jul 2016, 12:04 PM
#5
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Suddenly Front end blank. Admin fine.

Say that PHP won't load at all. If you put a file in your store's root named as you desire (pick something obscure) ending with .php with the following content, and see the results.

<?php echo phpinfo(); 

Then try to access that file by going to site/folder/filename.php

Once that is complete and data collected about the php version and related information, remove that file from the server.

7 Jul 2016, 12:23 PM
#6
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,100
Plugin Contributions:
56

Re: Suddenly Front end blank. Admin fine.

For some additional data-gathering, you can edit the file /includes/application_top.php, finding this line:

define('DEBUG_AUTOLOAD', false);

and changing that to read

define('DEBUG_AUTOLOAD', [B]true[/B]);

That will cause the auto-load status to be displayed for each item processed. There might be a missing class-file or some other obscure issue and that display will aid in that determination.

Remember to turn that back to false (no quotes) when you're finished.

7 Jul 2016, 12:34 PM
#7
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Suddenly Front end blank. Admin fine.

Nepherael:

The 2 changes I made were after the website went down. PHP 5.3 cannot be downgraded to 5.2 at this point.

I am on Zen 1.5.1

So, it probably not PHP compatibility related...

  • Zen Cart v1.5.1 is compatible with PHP 5.2.14 thru PHP 5.3.x.

unless perhaps the site has some old modules installed.

Please follow mc1-8s and lat9s suggestions. They may help providefurther clues.

One other suggestion. Im a little concerned about the lack of anything in the log folders, so, load the admin configure php file into a text editor (make a backup first) ... remove the semi colon from any one line in the file, resave it, then try to log into the admin. The site should crash. Now recheck the log files. If there is still nothing there check the folder permissions, etc, etc, to figure out why nothing is being logged. Once youve solved that mystery you will probably start seeing the logs from the store front errors. Sometimes the total absence of error logs is a clue in its own right.

Cheers
Rod

7 Jul 2016, 12:58 PM
#8
nepherael avatar

nepherael

New Zenner

Join Date:
Jul 2016
Posts:
29
Plugin Contributions:
0

Re: Suddenly Front end blank. Admin fine.

RodG:

So, it probably not PHP compatibility related...

  • Zen Cart v1.5.1 is compatible with PHP 5.2.14 thru PHP 5.3.x.

unless perhaps the site has some old modules installed.

Please follow mc1-8s and lat9s suggestions. They may help providefurther clues.

One other suggestion. Im a little concerned about the lack of anything in the log folders, so, load the admin configure php file into a text editor (make a backup first) ... remove the semi colon from any one line in the file, resave it, then try to log into the admin. The site should crash. Now recheck the log files. If there is still nothing there check the folder permissions, etc, etc, to figure out why nothing is being logged. Once youve solved that mystery you will probably start seeing the logs from the store front errors. Sometimes the total absence of error logs is a clue in its own right.

Cheers
Rod

It works if I do something like that. I changed the database password and generated an error log for that but that is the only log file that has generated since I started this venture. Server logs and Zen logs.

I will try the debugging code.

If it's possible to get a fresh install but keep all the original files to keep the layout and site information that would be preferable but that is something that would be quite involved because I didn't build it the first time around. I'm almost willing to pay someone to fix it at this point because this is such an obscure issue

Here is the closest issue I can find to mine (i.e. front end blank not admin blank). I cannot do her solution because I can't just rebuild the site and transfer database tables. The site I'm working on went blank without a php upgrade too so I didn't do the same thing that caused her error

https://www.zen-cart.com/showthread.php?211753-After-upgrade-to-PHP-5-4-site-displays-a-blank-page/page4

7 Jul 2016, 1:02 PM
#9
nepherael avatar

nepherael

New Zenner

Join Date:
Jul 2016
Posts:
29
Plugin Contributions:
0

Re: Suddenly Front end blank. Admin fine.

lat9:

For some additional data-gathering, you can edit the file /includes/application_top.php, finding this line:

define('DEBUG_AUTOLOAD', false);

> and changing that to read
> ```
define('DEBUG_AUTOLOAD', [B]true[/B]);

That will cause the auto-load status to be displayed for each item processed. There might be a missing class-file or some other obscure issue and that display will aid in that determination.

Remember to turn that back to false (no quotes) when you're finished.

Nothing output. Blank white page. blank header, blank body. Nothing loads but admin side works fine.

7 Jul 2016, 1:06 PM
#10
nepherael avatar

nepherael

New Zenner

Join Date:
Jul 2016
Posts:
29
Plugin Contributions:
0

Re: Suddenly Front end blank. Admin fine.

mc12345678:

Say that PHP won't load at all. If you put a file in your store's root named as you desire (pick something obscure) ending with .php with the following content, and see the results.

<?php echo phpinfo(); ``` > > Then try to access that file by going to site/folder/filename.php > > Once that is complete and data collected about the php version and related information, remove that file from the server. I've got a huge list of the same stuff I can see on the admin side of the site when I click the info page. PHP version and all the tables that I can get if I go to "version" in the admin of the site. It's quite a large list. Should I paste it here somewhere?
7 Jul 2016, 1:09 PM
#11
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,100
Plugin Contributions:
56

Re: Suddenly Front end blank. Admin fine.

Since you say that the admin is working, I'd focus on the differences (especially in the DIR_FS_CATALOG definition) between the files /YOUR_ADMIN/includes/configure.php and /includes/configure.php.

If you could post the contents of those files (minus the database configuration items) within the "Code" tags (i.e. the **# **in the menu-bar when you're writing your post), perhaps one of us can see the difference that's causing your whitescreen issue.

7 Jul 2016, 1:16 PM
#12
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Suddenly Front end blank. Admin fine.

Nepherael:

I've got a huge list of the same stuff I can see on the admin side of the site when I click the info page. PHP version and all the tables that I can get if I go to "version" in the admin of the site.

It's quite a large list. Should I paste it here somewhere?

I would say not necessary at the moment. Result does identify a few things though. 1) php is loading at the catalog level, 2) loading of the site when using the url to include the foldername is loading. In addition to lat9's suggestion of providing the configure.php files (though if I remember correctly the last time I applied the constant she referenced to a site with a poorly written configure.php file at least some results were obtained, not nothing), providing the .htaccess file at the root of the domain with any reference to the admin directory obscured (admin) may be of benefit, though another test that could be performed is attempting to goto yoursite/the_php_info_file.php and see that you get redirected to the sub-folder and the phpinfo file from above. (may require regenerating the file if it was removed as suggested).

7 Jul 2016, 1:17 PM
#13
nepherael avatar

nepherael

New Zenner

Join Date:
Jul 2016
Posts:
29
Plugin Contributions:
0

Re: Suddenly Front end blank. Admin fine.

lat9:

Since you say that the admin is working, I'd focus on the differences (especially in the DIR_FS_CATALOG definition) between the files /YOUR_ADMIN/includes/configure.php and /includes/configure.php.

If you could post the contents of those files (minus the database configuration items) within the "Code" tags (i.e. the **# **in the menu-bar when you're writing your post), perhaps one of us can see the difference that's causing your whitescreen issue.

Here we go. Also, there are no transactions on this website. It is used as a catalag. I checked the php info and it says there are no "additional modules" installed either. I've been looking through these configure files but I haven't been able to find any issues.

The site is contained in the directory "new" on the server. Godaddy does not allow subdirectory installs of the primary domain on the account so it required redirects from the root to point to the subdirectory. Everything still points to where it is supposed to.

Admin/includes/configure.php

  define('HTTP_SERVER', 'http://lightsforholidays.com');
  define('HTTPS_SERVER', 'https://lightsforholidays.com');
  define('HTTP_CATALOG_SERVER', 'http://lightsforholidays.com');
  define('HTTPS_CATALOG_SERVER', 'https://lightsforholidays.com');

  // secure webserver for admin?  Valid choices are 'true' or 'false' (including quotes).
  define('ENABLE_SSL_ADMIN', 'false');

  // secure webserver for storefront?  Valid choices are 'true' or 'false' (including quotes).
  define('ENABLE_SSL_CATALOG', 'false');

// NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
// * DIR_WS_* = Webserver directories (virtual/URL)
  // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
  $t1 = parse_url(HTTP_SERVER);$p1 = $t1['path'];$t2 = parse_url(HTTPS_SERVER);$p2 = $t2['path'];

  define('DIR_WS_ADMIN', preg_replace('#^' . str_replace('-', '\-', $p1) . '#', '', dirname($_SERVER['SCRIPT_NAME'])) . '/');
  define('DIR_WS_CATALOG', '/new/');
  define('DIR_WS_HTTPS_ADMIN', preg_replace('#^' . str_replace('-', '\-', $p2) . '#', '', dirname($_SERVER['SCRIPT_NAME'])) . '/');
  define('DIR_WS_HTTPS_CATALOG', '/new/');

  define('DIR_WS_IMAGES', 'images/');
  define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
  define('DIR_WS_CATALOG_IMAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'images/');
  define('DIR_WS_CATALOG_TEMPLATE', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/templates/');
  define('DIR_WS_INCLUDES', 'includes/');
  define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
  define('DIR_WS_CATALOG_LANGUAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/languages/');

// * DIR_FS_* = Filesystem directories (local/physical)
  define('DIR_FS_ADMIN', realpath(dirname(__FILE__) . '/../') . '/');
  //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/
  define('DIR_FS_CATALOG', '/home/content/l/i/g/lights4holiday/html/new/');

  //the following path is a COMPLETE path to the /logs/ folder  eg: /var/www/vhost/accountname/public_html/store/logs ... and no trailing slash
  define('DIR_FS_LOGS', '/home/content/l/i/g/lights4holiday/html/new/logs');

  define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
  define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
  define('DIR_FS_CATALOG_TEMPLATES', DIR_FS_CATALOG . 'includes/templates/');
  define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
  define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');
  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

and the includes/configure.php

// Define the webserver and path parameters
  // HTTP_SERVER is your Main webserver: eg-http://www.your_domain.com
  // HTTPS_SERVER is your Secure webserver: eg-https://www.your_domain.com
  define('HTTP_SERVER', 'http://lightsforholidays.com');
  define('HTTPS_SERVER', 'https://lightsforholidays.com');

  // Use secure webserver for checkout procedure?
  define('ENABLE_SSL', 'false');

// NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
// * DIR_WS_* = Webserver directories (virtual/URL)
  // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
  define('DIR_WS_CATALOG', '/new/');
  define('DIR_WS_HTTPS_CATALOG', '/new/');

  define('DIR_WS_IMAGES', 'images/');
  define('DIR_WS_INCLUDES', 'includes/');
  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
  define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');
  define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/');

  define('DIR_WS_PHPBB', '/');

// * DIR_FS_* = Filesystem directories (local/physical)
  //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/
  define('DIR_FS_CATALOG', '/home/content/l/i/g/lights4holiday/html/new/');

  //the following path is a COMPLETE path to the /logs/ folder  eg: /var/www/vhost/accountname/public_html/store/logs ... and no trailing slash
  define('DIR_FS_LOGS', '/home/content/l/i/g/lights4holiday/html/new/logs');

  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');
  define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/');
  define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS);
  define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');
7 Jul 2016, 1:26 PM
#14
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,100
Plugin Contributions:
56

Re: Suddenly Front end blank. Admin fine.

I see no differences in the "key" definitions for those files, so that's not it.

Do you have a .htaccess file in your store's root, i.e. /home/content/l/i/g/lights4holiday/html/new/.htaccess? If so, would you post that file's contents?

7 Jul 2016, 1:30 PM
#15
nepherael avatar

nepherael

New Zenner

Join Date:
Jul 2016
Posts:
29
Plugin Contributions:
0

Re: Suddenly Front end blank. Admin fine.

lat9:

I see no differences in the "key" definitions for those files, so that's not it.

Do you have a .htaccess file in your store's root, i.e. /home/content/l/i/g/lights4holiday/html/new/.htaccess? If so, would you post that file's contents?

Sure thing.

# -FrontPage-
IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
<Limit GET POST>
order deny,allow
deny from all
allow from all
</Limit>
<Limit PUT DELETE>
order deny,allow
deny from all
</Limit>
AuthName www.lightsforholidays.com
AuthUserFile /var/chroot/home/content/l/i/g/lights4holiday/html/_vti_pvt/service.pwd
AuthGroupFile /var/chroot/home/content/l/i/g/lights4holiday/html/_vti_pvt/service.grp
7 Jul 2016, 1:44 PM
#16
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,100
Plugin Contributions:
56

Re: Suddenly Front end blank. Admin fine.

I'm not familiar with that AuthName control, but I'll note that it's referencing https://www.lightsforholidays.com while your configure files are using lightsforholidays.com (without the www.).

7 Jul 2016, 1:52 PM
#17
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Suddenly Front end blank. Admin fine.

What about at: /home/content/l/i/g/lights4holiday/html/.htaccess?
(one folder up from the new directory.)

7 Jul 2016, 1:55 PM
#18
nepherael avatar

nepherael

New Zenner

Join Date:
Jul 2016
Posts:
29
Plugin Contributions:
0

Re: Suddenly Front end blank. Admin fine.

mc12345678:

What about at: /home/content/l/i/g/lights4holiday/html/.htaccess?
(one folder up from the new directory.)

Apologies. What is there is what I pulled from the root. The new directory does not have an htaccess.

7 Jul 2016, 1:57 PM
#19
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Suddenly Front end blank. Admin fine.

Another "direction" is related to having a local directory and contents within it./home/content/l/i/g/lights4holiday/html/new/includes/local. Is it present? What files are present? is there a configure.php file?

7 Jul 2016, 2:02 PM
#20
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Suddenly Front end blank. Admin fine.

Nepherael:

Sure thing.

-FrontPage-

IndexIgnore .htaccess /.?? *~ *# /HEADER /README /_vti
<Limit GET POST>
order deny,allow
deny from all
allow from all
</Limit>
<Limit PUT DELETE>
order deny,allow
deny from all
</Limit>
AuthName www.lightsforholidays.com
AuthUserFile /var/chroot/home/content/l/i/g/lights4holiday/html/_vti_pvt/service.pwd
AuthGroupFile /var/chroot/home/content/l/i/g/lights4holiday/html/_vti_pvt/service.grp



I'd be strongly tempted to delete/rename this file. With your current zen install it doesnt appear to be doing anything, and if the domain names did match (www vs no www) it looks like it will be asking for a password to access the site, and if the auth paths are wrong, or the auth files are unreadable you could possibly end up with the blank screen. ...     just a thought.

Cheers 
RodG