Nepherael:
tested.
Unfortunately, full valid result. I see the PHP version followed by all of the info.
Bummer. Not what i wanted.
I did still note one oddity though, a url with no filename (just ending with a /), is supposed to serve up a default file if one can be found. Typically these files are search for in the order of index.htm, index.html, index.php and a couple of others. You site isnt doing that. Whether this is relevent to the blank page problem ive no idea... I suspect not.
Thanks for the offer of ftp access, but I will pass on that .. its 2am, and I dont think im thinking straight any more.... this whole thing now has me bamboozled..... I seriously dont know what to suggest or where to go from here. It is clear that godaddy have something weird going on, especially in the way it is handling file not found errors, which it really shouldn't be doing, because that in itself is going to cause problems with zencart which needs to handle these for itself (or silently ignored). How this relates to your blank page when the zencart index.php file is found is still a mystery. There may not evrn be a connection. (Btw, have you checked the error logs recently? If any exist, they may still provide a clue).
I really am lost for ideas though...... for me to debug any further I'd be adding "echo" commands in various places in the zencart code (starting from the index.php file) and working through the program flow to see where the echos stop working. This isnt something that I could guide you through though.
Hopefully one of the other folk here can see something that I'm missing, or can at least make a better suggestion .... but at the end of the day, most of us know that godaddy are quite possibly the worst host on the planet and have a habit of doing things in their own unique way, and often making a mess of things (not being able to install a site in the root folder being a classic example). Generally speaking there are ways around their weirdness, but this one is totally new, at least to me.
Sorry, but ive done my best to help isolate the problem. I/we now know many things that isn't the cause, but we still dont know enough to determine whzt the cause is.... other than everything points straight back to goddaddy (its not the htaccess, its not the redirects, its not the php version, mysql is fine, the zenczrt code hasnt changed (?), theres no default .html file being loaded instead of the index.php. the index.php file isn't being loaded by default (as it should be), but can be accessed when specifically called, so in itself the failure to load by default is of no significance. Godaddy shouldn't be handling the file not found errors like it is, but appears fine when the files aee found, so probably not significant... or perhaps it is...
So what am I missing? Anyone?
Cheers
RodG