Zen Cart Logo
Forums / General Questions / Some Issues After Moving To New Host & Upgrading

Some Issues After Moving To New Host & Upgrading

Views: 1,301

Results 1 to 11 of 11
7 Jul 2016, 7:15 PM
#1
patience avatar

patience

New Zenner

Join Date:
Dec 2011
Posts:
31
Plugin Contributions:
0

Some Issues After Moving To New Host & Upgrading

Hi all,
I recently switched to a new host (again. ha!), and figured I may as well upgrade Zen while I'm at it.
Everything looks and works as it should but there are a couple issues.
When you click on a product page to view the actual product, nothing is there. It's not a blank page, because the title is there, the background image, etc.. Its just that the normal layout with the image and product description, add to cart button, etc. just isn't there.
I am unable to figure out if this is something to do with the cart software itself, or re-installing my customized version of the Winchester Black responsive template after I had moved and upgraded.

I use my page inspectors in both Chrome and Firefox and it looks like the codes all there, so I'm confused.

My second issue is getting pop-up errors something about Ajax. Like for example if you try to log in by clicking the My Account link at the bottom, a pop-up with a message along the lines of "an unknown response null:text/html ;charset=utf-8: syntax error: unexpected token m n JSON at position 0 was recieved while processing an ajax call..."

The link to the site where this is happening is https://www.violetmoonchild.com

Thank so very much for reading and for any advice you may have :smile:

7 Jul 2016, 7:22 PM
#2
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Some Issues After Moving To New Host & Upgrading

Normally suggested to do one or the other (upgrade or move), by doing both it becomes complicated to know which action caused what.

That said, it sounds like you may have some error logs in your logs directory. Suggest reviewing the most recent and correcting it until the issue(s) are resolved.

7 Jul 2016, 8:09 PM
#3
patience avatar

patience

New Zenner

Join Date:
Dec 2011
Posts:
31
Plugin Contributions:
0

Re: Some Issues After Moving To New Host & Upgrading

Edit
Found a help file that explains where to find the error log file

7 Jul 2016, 8:10 PM
#4
patience avatar

patience

New Zenner

Join Date:
Dec 2011
Posts:
31
Plugin Contributions:
0

Re: Some Issues After Moving To New Host & Upgrading

Oh & meant to add that I didn't do both at the same time. I moved to my new host first then did the upgrade after.

7 Jul 2016, 8:15 PM
#5
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Some Issues After Moving To New Host & Upgrading

Patience:

Thank you!
Do you know if there's anywhere within the Zen Cart admin that I can check the error log? I did an error log check in my webhost cPanel but nothing showed up. So, I tried looking around in my admin menus thinking there may be something I could do in there to check things out but I got kind of lost >_< heh

If you look in the plugins section, there is one called display logs. It will allow seeing the logs while you are logged into the admin. But it will require ftping the files to the server (which is how you could review those logs now if you wish). :)

7 Jul 2016, 8:40 PM
#6
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Some Issues After Moving To New Host & Upgrading

Patience:

Oh & meant to add that I didn't do both at the same time. I moved to my new host first then did the upgrade after.

To confirm then. Before the upgrade part, the site worked fine ie. the issues currently seen were not occurring...

If so, then may want to describe how you did the upgrade. It could be that modifications that were made to a related directory/file were overwritten depending on how the process was performed. Hopefully still have a backup copy of the site before the upgrade.

7 Jul 2016, 11:47 PM
#7
patience avatar

patience

New Zenner

Join Date:
Dec 2011
Posts:
31
Plugin Contributions:
0

Re: Some Issues After Moving To New Host & Upgrading

Yes the site was looking and working as it should until I had to move to the new host.
I still have a backup of everything (thankfully!).
I followed the instructions per the tutorial from Zen for moving to the new server..where you install your original version first, then overwrite with your backup, then adjust the MySQL database info and configuration files so that all the same categories, products, admin settings etc.. are in the shop. The installer worked fine, no issues at all, but then after it said it was complete and I try to log in or go to the store front, all I got were blank pages on both the admin & storefront. I decided to delete all files, delete the database, then install via a one-click installer that my webhost provides.
Then I did the MySQL changes and configuration file changes so that all my old admin & shop data is there, uploaded all my Winchester Black template files, and there you have it.. Its all like it used to be, its just that its version 1.55 now instead of 1.54 and nothing shows in product pages. Also that weird Ajax popup error thing when clicking on "my account."

I looked in my error logs but all I found were where I had put in the wrong password earlier.

8 Jul 2016, 12:00 AM
#8
barco57 avatar

barco57

Totally Zenned

Join Date:
Apr 2006
Location:
West Salem, IL
Posts:
2,845
Plugin Contributions:
0

Re: Some Issues After Moving To New Host & Upgrading

Yes the site was looking and working as it should until I had to move to the new host.
So does that mean it was broken once it was moved to the new host BEFORE it was upgraded?

All other pages work as expected, it's only product_info pages that are broken. Using the inspector on product info pages, all of the code is not there, between the body open and body close it is completely empty. I suspect that the problem is a broken or missing file.

8 Jul 2016, 12:10 AM
#9
mc12345678 avatar

mc12345678

Totally Zenned

Join Date:
Jul 2012
Posts:
16,908
Plugin Contributions:
2

Re: Some Issues After Moving To New Host & Upgrading

Eeeeiiiii... I don't see anything in that description about either doing or being told by the software to perform a database upgrade after the ZC 1.5.5 files were put on the server and the old database referenced by the new fileset...

Have seen a number of explanations about that error message, some having to do with database/various file character set disagreements (latin1 versus utf-8), application of the latest ajax.php file, other errors associated with templates (BTW, there are some "additional" actions to be taken with ZC 1.5.5 if using one of Anne's templates. See: https://www.zen-cart.com/showthread.php?219801-Making-v154-DIY-Picaflor-Azul-templates-work-with-v1-5-5&p=1306879#post1306879)...

8 Jul 2016, 4:03 AM
#10
patience avatar

patience

New Zenner

Join Date:
Dec 2011
Posts:
31
Plugin Contributions:
0

Re: Some Issues After Moving To New Host & Upgrading

Hey, thank you BOTH for your helpful replies!! Really means a lot to me and I'm going to try to figure it all out & get it fixed sometime tomorrow.

About the database changes: I apologize, I have trouble wording things sometimes & making them more confusing than they need to be.. I meant as in the steps I had to do after moving to the new server in order to have the mySQL work right.. its in the tutorial on moving your ZC to a new host..(steps 3 through 5)
https://www.zen-cart.com/content.php?142-i-want-to-move-my-zen-cart-installation-to-another-host-or-a-different-server

If I don't do whats in those steps & leave it as-is then none of my products, admin settings, etc..are there.

Now that I know its product info pages causing emptiness, ajax files, & some things to tweak mentioned in that link mentioned.. I am not completely in the dark & can at least start somewhere. Thanks :)

9 Jul 2016, 1:59 PM
#11
patience avatar

patience

New Zenner

Join Date:
Dec 2011
Posts:
31
Plugin Contributions:
0

Re: Some Issues After Moving To New Host & Upgrading

Well..got the Ajax issue fixed (just uploaded my backup file from 1.5.4 and never got the errors again).
Never did figure out the blank pages issue though, unfortunately. So I had to downgrade back down to 1.5.4 and uploaded the backup of my original site.
I think I'm going to wait until I've made a few sales then just pay someone who is a lot more skilled with this to do the upgrade!
Usually I can follow steps fine and get things working but not this time haha.