Zen Cart Logo
Forums / General Questions / Getting the error "SMTP Error: Could not connect to SMTP host"

Getting the error "SMTP Error: Could not connect to SMTP host"

Views: 7,715

Results 1 to 9 of 9
3 Aug 2016, 1:44 PM
#1
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Getting the error "SMTP Error: Could not connect to SMTP host"

This error just STARTED happening suddenly. It does not occur when customer places orders, or when using the contact us form. This ONLY occurs when updating orders in the admin and sending out the order status updates. Not even sure where to begin to troubleshoot this..

Some info:
PHP Version: 5.4.38

Email settings:
E-Mail Transport Method: SMTPAUTH

E-Mail Linefeeds
*Current Value: LF

Use MIME HTML When Sending Emails
*Current Value: true

Email Archiving Active?
*Current Value: true

E-Mail Friendly-Errors
*Current Value: true

Emails must send from known domain?*
Current Value: Yes**


5 Aug 2016, 1:24 PM
#2
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Getting the error "SMTP Error: Could not connect to SMTP host"

So I talking to myself here.. Still hoping to get some insight as to how to resolve this..:smile: I switched the SMTP credentials to use Mailgun for SMTP authentication. This yields the SAME result.. Store-side emails go out just fine (Contact Us form, order confirmation emails) But ANY emails send from the admin (order confirmations in particular) leads to the following SMTP error.

ERROR: Failed sending email to: "Jessica Rabbit" with subject: "Order Update #84755" SMTP Error: The following recipients failed: ###### @ hotmail.com

Let me repeat.. Order confirmations are going out just fine. The contact us form works fine. But order status updates are not sending emails and the above error is what I get.

.

5 Aug 2016, 4:03 PM
#3
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,089
Plugin Contributions:
56

Re: Getting the error "SMTP Error: Could not connect to SMTP host"

Was the site's PHP version recently changed?

Does the site use Edit Orders? If so, does the same behavior (error sending email) occur whether you change the order's status using the "normal" orders handling and when you change the status using Edit Orders?

Does the same email error occur when you use the Tools->Send Email page?

6 Aug 2016, 3:09 PM
#4
divavocals avatar

divavocals

Totally Zenned

Join Date:
Jan 2007
Location:
Los Angeles, California, United States
Posts:
10,011
Plugin Contributions:
3

Re: Getting the error "SMTP Error: Could not connect to SMTP host"

lat9:

Was the site's PHP version recently changed?

Does the site use Edit Orders? If so, does the same behavior (error sending email) occur whether you change the order's status using the "normal" orders handling and when you change the status using Edit Orders?

Does the same email error occur when you use the Tools->Send Email page?
To my knowledge, the PHP version did not recently change, but i will have to check with the hosting company..

The site uses Edit Orders, but he rarely uses the module for order editing these days.. This behavior happens using the normal order handling.. yes same issue when using Tools->Send Email page.

6 Aug 2016, 4:02 PM
#5
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,089
Plugin Contributions:
56

Re: Getting the error "SMTP Error: Could not connect to SMTP host"

A shot in the dark, but have you recently checked the site's security protocols (like with https://www.ssllabs.com/ssltest/index.html%29? For that matter, is the admin running in SSL-mode?

I'm having a hard time explaining to myself that the storefront sends emails just fine, but that there are issues in the admin since both parts of the site use the same email settings and modules.

7 Aug 2016, 8:25 AM
#6
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Getting the error "SMTP Error: Could not connect to SMTP host"

DivaVocals:

But ANY emails send from the admin (order confirmations in particular) leads to the following SMTP error.
The following recipients failed: ###### @ hotmail.com

Clutching at straws, but do you have the same problem sending these emails to clients that are not using hotmail?

Perhaps hotmail has some security settings that are being triggered with these particular emails?

Cheers
RodG

9 Aug 2016, 8:41 PM
#7
carlwhat avatar

carlwhat

zennedOut

Join Date:
Nov 2005
Location:
los angeles
Posts:
2,962
Plugin Contributions:
8

Re: Getting the error "SMTP Error: Could not connect to SMTP host"

on the admin side, there is a script called:

mail.php

have you tried using that script as a test to see if you can email anything from the admin side?

have you verified (as rod suggested) that it's happening for all domains? or only some select domains?

good luck!

10 Aug 2016, 12:43 AM
#8
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Getting the error "SMTP Error: Could not connect to SMTP host"

carlwhat:

on the admin side, there is a script called:

mail.php

have you tried using that script as a test to see if you can email anything from the admin side?

have you verified (as rod suggested) that it's happening for all domains? or only some select domains?

good luck!
That /admin/mail.php file is the same "Tools->Send Email page" thing discussed earlier.

10 Aug 2016, 12:45 AM
#9
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Getting the error "SMTP Error: Could not connect to SMTP host"

DivaVocals:

ERROR: Failed sending email to: "Jessica Rabbit" with subject: "Order Update #84755" SMTP Error: The following recipients failed: ###### @ hotmail.comLet me repeat.. Order confirmations are going out just fine. The contact us form works fine. But order status updates are not sending emails and the above error is what I get.
The error you quoted shows as being the one sent to the customer. But the Admin for order-updates also immediately sends an email to the storeowner too (immediately after sending one to the customer). Does that one arrive properly? (Or have you turned that feature off?)

It's definitely peculiar (and very hard to explain why) that only the admin-side is failing, considering that both the admin and non-admin use the exact same infrastructure for sending emails.