Zen Cart Logo
Forums / General Questions / Error w/ changing servers:1146 Table 'configuration' doesn't exist

Error w/ changing servers:1146 Table 'configuration' doesn't exist

Views: 863

Results 1 to 8 of 8
30 Sep 2016, 2:40 AM
#1
sendmenews avatar

sendmenews

Zen Follower

Join Date:
May 2008
Posts:
122
Plugin Contributions:
0

Error w/ changing servers:1146 Table 'configuration' doesn't exist

I am switching servers (well switching from one panel to another panel.)
One website - kaleidoscopegalaxy.com worked fine but for some reason I am getting an error for the stainedglassgalaxy.com. I made the same changes in the configure.php under admin and under includes for both so I am at a loss why one worked fine and one is not:(

This is the complete error message: 1146 Table 'stainedglassgalaxy.configuration' doesn't exist
in:
[select configuration_key as cfgkey, configuration_value as cfgvalue from configuration]

Any ideas on how to tweak this.

30 Sep 2016, 2:43 AM
#2
sendmenews avatar

sendmenews

Zen Follower

Join Date:
May 2008
Posts:
122
Plugin Contributions:
0

Re: Error w/ changing servers:1146 Table 'configuration' doesn't exist

Ugh also just found another problem. When I click on add to cart it goes to a blank white page. What did I forget to tweak??? Thanks

30 Sep 2016, 12:29 PM
#3
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,097
Plugin Contributions:
56

Re: Error w/ changing servers:1146 Table 'configuration' doesn't exist

sendmenews:

I am switching servers (well switching from one panel to another panel.)
One website - kaleidoscopegalaxy.com worked fine but for some reason I am getting an error for the stainedglassgalaxy.com. I made the same changes in the configure.php under admin and under includes for both so I am at a loss why one worked fine and one is not:(

This is the complete error message: 1146 Table 'stainedglassgalaxy.configuration' doesn't exist
in:
[select configuration_key as cfgkey, configuration_value as cfgvalue from configuration]

Any ideas on how to tweak this.
Does your stainedglassgalaxy database use a different DB_PREFIX value? You can tell by looking at the database using phpMyAdmin: Do you have a table named xxx_configuration? If so, then your DB_PREFIX should be set (in both admin and storefront configure.php files) to 'xxx_'.

sendmenews:

Ugh also just found another problem. When I click on add to cart it goes to a blank white page. What did I forget to tweak??? Thanks
Blank whitepage indicates that a PHP error occurred. Check your /logs folder (Zen Cart 1.5.1 and later) or /cache folder (earlier Zen Cart versions) for the details.

30 Sep 2016, 7:56 PM
#4
sendmenews avatar

sendmenews

Zen Follower

Join Date:
May 2008
Posts:
122
Plugin Contributions:
0

Re: Error w/ changing servers:1146 Table 'configuration' doesn't exist

lat9:

Does your stainedglassgalaxy database use a different DB_PREFIX value? You can tell by looking at the database using phpMyAdmin: Do you have a table named xxx_configuration? If so, then your DB_PREFIX should be set (in both admin and storefront configure.php files) to 'xxx_'.

Okay so the problem was the sql on that one. It would not upload correctly for me but GoDaddy uploaded it fine.

Blank whitepage indicates that a PHP error occurred. Check your /logs folder (Zen Cart 1.5.1 and later) or /cache folder (earlier Zen Cart versions) for the details.

I have a zillion errors! One theme is how the DB_server is set up. Go daddy changed their software so I had to change it from what it was to just localhost. Well the errors seem to be pointing to the old name. Is there a way to search and find all of those places that I would need to change to localhost?

30 Sep 2016, 8:48 PM
#5
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,799
Plugin Contributions:
15

Re: Error w/ changing servers:1146 Table 'configuration' doesn't exist

you will need to look at the two configure.php files. One in yoursiteDOTcom/includes/configure.php. The other at yoursiteDOTcom/youradmin/includes/configure.php.

If you did the upgrade per http://www.zen-cart.com/entry.php?3-How-do-I-rebuild-my-site-on-the-new-version-instead-of-upgrading, then they should have been created correctly.

30 Sep 2016, 8:53 PM
#6
sendmenews avatar

sendmenews

Zen Follower

Join Date:
May 2008
Posts:
122
Plugin Contributions:
0

Re: Error w/ changing servers:1146 Table 'configuration' doesn't exist

I did do the changes in those areas - godaddy checked it too just as a double check:(. For some reason the new server software screwed up something. He is not sure what.

the first error message i get is: - the xxxx is to hide the names of path etc.
[30-Sep-2016 20:38:53 UTC] PHP Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/xxxxx/public_html/xxxxx/includes/classes/class.smtp.php:2135) in /home/xxx/public_html/xxxx/includes/functions/sessions.php on line 114

1 Oct 2016, 3:16 AM
#7
sendmenews avatar

sendmenews

Zen Follower

Join Date:
May 2008
Posts:
122
Plugin Contributions:
0

Re: Error w/ changing servers:1146 Table 'configuration' doesn't exist

sendmenews:

i did do the changes in those areas - godaddy checked it too just as a double check:(. For some reason the new server software screwed up something. He is not sure what.

The first error message i get is: - the xxxx is to hide the names of path etc.
[30-sep-2016 20:38:53 utc] php warning: Session_start(): Cannot send session cache limiter - headers already sent (output started at /home/xxxxx/public_html/xxxxx/includes/classes/class.smtp.php:2135) in /home/xxx/public_html/xxxx/includes/functions/sessions.php on line 114

i figured it out:) all appears to be working good after many fixes.

1 Oct 2016, 3:55 AM
#8
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,799
Plugin Contributions:
15

Re: Error w/ changing servers:1146 Table 'configuration' doesn't exist

This is where you help future campers by 'splaining what you did.