@haredo, I've seen the same on another fresh installation of Zen Cart 1.5.5f, running PHP 5.6.38. The issue is that the .woff and .ttf files in the /admin/includes/fonts directory are being 'access-denied' (i.e. a 403 error).
Following @twitchtoo's lead (for the the admin, as you'd identified), edit the /admin/includes/stylesheet.css, towards the top, finding
@import url("css/font-awesome.min.css");
/* @import url("//maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css"); */
and changing to
/* @import url("css/font-awesome.min.css"); */
@import url("//maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css");
... essentially removing the ability to use off-line, but using the CDN-based version of the FA styling.