Zen Cart Logo
Forums / General Questions / Site and Admin crashed!!!

Site and Admin crashed!!!

Views: 838

Results 1 to 10 of 10
9 Jun 2019, 3:43 PM
#1
wmorris avatar

wmorris

Totally Zenned

Join Date:
Aug 2007
Location:
Amarillo, Tx
Posts:
1,683
Plugin Contributions:
0

Site and Admin crashed!!!

I was switching to from a Blue Sheffield Responsive layout to a classic responsive layout then both Store and Admin showing:

Store:

This page isn’t working https://www.galaxyhomedecor.com is currently unable to handle this request.
HTTP ERROR 500

Admin:

This https://www.galaxyhomedecor.com page can’t be found No webpage was found for the web address: https://www.galaxyhomedecor.com/manager/
HTTP ERROR 404

9 Jun 2019, 3:49 PM
#2
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,809
Plugin Contributions:
15

Re: Site and Admin crashed!!!

When you get a 500 error, it usually means something is wrong at the host end.

Contact them with all the steps that led to the problem occurring.

9 Jun 2019, 4:07 PM
#3
swguy avatar

swguy

Administrator

Join Date:
Feb 2006
Location:
Tampa Bay, Florida
Posts:
10,711
Plugin Contributions:
56

Re: Site and Admin crashed!!!

Look and see if there are any logs. Did you perhaps switch to PHP7.2 without upgrading your site, for example? Check your .htaccess file as well to see if there's any odd redirecting going on.

9 Jun 2019, 6:06 PM
#4
wmorris avatar

wmorris

Totally Zenned

Join Date:
Aug 2007
Location:
Amarillo, Tx
Posts:
1,683
Plugin Contributions:
0

Re: Site and Admin crashed!!!

swguy:

Look and see if there are any logs. Did you perhaps switch to PHP7.2 without upgrading your site, for example? Check your .htaccess file as well to see if there's any odd redirecting going on.

I didn't touch my PHP7.X at all....

I did looked in my error debug logs:

[09-Jun-2019 12:19:29 America/Chicago] PHP Parse error: syntax error, unexpected 'HOME_PAGE_TITLE' (T_STRING), expecting ',' or ')' in /home1/hkeaton/public_html/galaxyhomedecor.com/includes/languages/english/meta_tags.php on line 24

9 Jun 2019, 6:38 PM
#5
swguy avatar

swguy

Administrator

Join Date:
Feb 2006
Location:
Tampa Bay, Florida
Posts:
10,711
Plugin Contributions:
56

Re: Site and Admin crashed!!!

Post lines (say) 20-26 of /home1/hkeaton/public_html/galaxyhomedecor.com/includes/languages/english/meta_tags.php

9 Jun 2019, 7:25 PM
#6
wmorris avatar

wmorris

Totally Zenned

Join Date:
Aug 2007
Location:
Amarillo, Tx
Posts:
1,683
Plugin Contributions:
0

Re: Site and Admin crashed!!!

swguy:

Post lines (say) 20-26 of /home1/hkeaton/public_html/galaxyhomedecor.com/includes/languages/english/meta_tags.php

I think I found the problem, I went into my MySQL and change my template back to blue_sheffield_reponsive the site went back up. So I believe that the classic_repsonsive template was conflicting the site. So right now I got the website back up and running.

9 Jun 2019, 7:33 PM
#7
swguy avatar

swguy

Administrator

Join Date:
Feb 2006
Location:
Tampa Bay, Florida
Posts:
10,711
Plugin Contributions:
56

Re: Site and Admin crashed!!!

Good news - but I do have sites where I can switch between these two without an issue. It would be worth figuring out the root cause.

9 Jun 2019, 8:59 PM
#8
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,809
Plugin Contributions:
15

Re: Site and Admin crashed!!!

Looks like you might have been changing the home page title in the meta_tags.php. It's not difficult to munge up a define if you get confused with a single(') or double(") quote.

Line 24 should either bedefine('HOME_PAGE_TITLE', ''); // usually best left blankor, if you wanted it to title your Home Page ```
define('HOME_PAGE_TITLE', 'This is the Home Page'); // usually best left blank


Two single quotes can be mistaken for a double quote and, often leaving off a single quote will cause the error you received.

There still may well be something going on as that file should have thrown the same error regardless of which template you selected.
9 Jun 2019, 11:51 PM
#9
swguy avatar

swguy

Administrator

Join Date:
Feb 2006
Location:
Tampa Bay, Florida
Posts:
10,711
Plugin Contributions:
56

Re: Site and Admin crashed!!!

dbltoe:

There still may well be something going on as that file should have thrown the same error regardless of which template you selected.

If this was indeed the issue (likely so), and the file was in the template folder (includes/languages/english/responsive_classic/meta_tags.php), then the crash would occur only under the responsive template, since the older responsive_sheffield_blue template would either load includes/languages/english/responsive_sheffield_blue/meta_tags.php or includes/languages/english/meta_tags.php.

10 Jun 2019, 4:20 PM
#10
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,809
Plugin Contributions:
15

Re: Site and Admin crashed!!!

I was switching to from a Blue Sheffield Responsive layout to a classic responsive layout> I did looked in my error debug logs:
[09-Jun-2019 12:19:29 America/Chicago] PHP Parse error: syntax error, unexpected 'HOME_PAGE_TITLE' (T_STRING), expecting ',' or ')' in /home1/hkeaton/public_html/galaxyhomedecor.com/includes/languages/english/meta_tags.php on line 24> swguy:

If this was indeed the issue (likely so), and the file was in the template folder (includes/languages/english/responsive_classic/meta_tags.php), then the crash would occur only under the responsive template, since the older responsive_sheffield_blue template would either load includes/languages/english/responsive_sheffield_blue/meta_tags.php or includes/languages/english/meta_tags.php.Since the supplied debug log did not mention an override folder and this apparently upon a switch to responsive_classic, one can assume (I know) that there was no override in the responsive_classic folder for that file.

Thus, as I saw it (again assuming):

  1. Site is working
  2. Switch site to responsive_classic
  3. Site fails
  4. debug log lists /home1/hkeaton/public_html/galaxyhomedecor.com/includes/languages/english/meta_tags.php on line 24

    From that, wouldn't one assume that, since the debug contained no mention of an override folder:
  5. responsive_sheffield_blue had an override for the meta_tags.php that was correct -- If not, the error would have reported itself earlier. Don't know if it was part of the template package or an addition when the template was installed.
  6. responsive_classic did not have an override for the meta_tags.php file or the debug would have pointed to it.
  7. One can assume number 2 is more likely since the basic 1.5.# distribution packages do not include the override meta_tags.php in the includes/languages/english/responsive_classic folder.
  8. Which brings us to the final assumption that the culprit was the originally provided /home1/hkeaton/public_html/galaxyhomedecor.com/includes/languages/english/meta_tags.php on line 24

I'm not trying to channel RodG here. Often, information really needed to drill down to a problem is not provided by the OP. I'm just hoping to improve from what I might have missed in the assumption.
Normally, I tend to be more general in my pointing someone to a solution but, I felt there was enough info here to be a little more specific.
Appreciate your thoughts