johnniejetski2:
log file after fixing bad dates:
[04-Sep-2024 02:35:41 UTC] PHP Fatal error: Uncaught Error: Undefined constant "MFA_ENABLED" in /home/bladez5/monstergoped.com/hulk/includes/functions/functions_mfa.php:36
Stack trace:
#0 /home/bladez5/monstergoped.com/hulk/includes/functions/general.php(431): zen_mfa_handler(Array)
#1 /home/bladez5/monstergoped.com/hulk/includes/functions/admin_access.php(380): zen_call_function('zen_mfa_handler', Array)
#2 /home/bladez5/monstergoped.com/hulk/login.php(29): zen_validate_user_login('xxxxxxx', 'xxxxxxx')
#3 /home/bladez5/monstergoped.com/hulk/index.php(16): require('/home/bladez5/m...')
#4 {main}
thrown in /home/bladez5/monstergoped.com/hulk/includes/functions/functions_mfa.php on line 36
you are running a v2.1.x codeset.
v2.1.x is a pre-release. are you sure that is what you want to be running?
the error that you are seeing is due to a missing value in your configuration table that was part of the v2.1.0 update. you can see that here:
https://github.com/zencart/zencart/blob/434da0eb9fa82277a01039ade5fa134f1b410054/zc_install/sql/updates/mysql_upgrade_zencart_210.sql#L79-L80
or here for a fresh install:
https://github.com/zencart/zencart/blob/434da0eb9fa82277a01039ade5fa134f1b410054/zc_install/sql/install/mysql_zencart.sql#L2490
without that value in your database configuration table, things will not work.