Zen Follower
- Join Date:
- Jan 2008
- Posts:
- 174
- Plugin Contributions:
- 0
Views: 45,488
Zen Follower
Totally Zenned
You chose 01 for Customer Classification code which means the normal rates. Are you sure that your shipper account hasn't been granted rates? What happens when you toggle the rate to 00 (Rates associated with your Shipper Number) or 04 (Retail Rates).
Zen Follower
I have customer classification code as: 00
Administrator
pazdar:
I have customer classification code as: 00
Turn on the shipping-module's debug, repeat that storefront transaction and contact me via PM for my direct email address.
New Zenner
Hi there, I'm new to zen cart and evaluating some details before we commit to it.
One of the items we need to work is the UPS rates.
I have installed 1.3.7 into our test setup and it is failing with:
"code": "250002",
"message": "Invalid Authentication Information."
In trying to track things down. We do get a valid and initial response although the getOAuthToken function seems to be called 2 times. Tried to figure out why but regardless, the UPS fails on the RateRequest with the above error.
It does come back with an access_token etc...but then fails on the rates so nothing comes back.
Any suggestions?
Administrator
V Boruvka:
Hi there, I'm new to zen cart and evaluating some details before we commit to it.
One of the items we need to work is the UPS rates.
I have installed 1.3.7 into our test setup and it is failing with:
"code": "250002",
"message": "Invalid Authentication Information."In trying to track things down. We do get a valid and initial response although the getOAuthToken function seems to be called 2 times. Tried to figure out why but regardless, the UPS fails on the RateRequest with the above error.
It does come back with an access_token etc...but then fails on the rates so nothing comes back.
Any suggestions?
You've likely missed a step in the UPS account setup, specifically adding the Rating API to your OAuth product. Refer to the shipping module's wiki for additional information: https://github.com/lat9/upsoauth/wiki/Creating-Your-OAuth-Client-ID-and-Client-Secret
New Zenner
Help Please!
1.3.7 is doing nothing. Does not report at all on main_page=checkout_shipping. Default "Flat Rate" module works fine.
This is a new install of 1.5.8a with php 8.0. However it is running in a subdirectory for testing.
Everything looks correct in the shipping module setup page, Enabled=True, Debug=True, ID and Secret look good, everything else filled out and looks correct.
No debug info in /logs in the subdirectory or the main directory ..
verified files exist:
subdir/includes/languages/english/modules/shipping/lang.upsoauth.php
subdir/includes/languages/english/modules/shipping/upsoauth.php
subdir/includes/modules/shipping/upsoauth.php
subdir/includes/modules/shipping/upsoauth/UpsOAuthApi.php
subdir/includes/templates/template_default/images/icons/shipping_ups.gif
UPDATE.. just figured it out.. Shipping Zone was disabling it.
Administrator
mesmerism:
Help Please!
1.3.7 is doing nothing. Does not report at all on main_page=checkout_shipping. Default "Flat Rate" module works fine.
This is a new install of 1.5.8a with php 8.0. However it is running in a subdirectory for testing.
Everything looks correct in the shipping module setup page, Enabled=True, Debug=True, ID and Secret look good, everything else filled out and looks correct.
No debug info in /logs in the subdirectory or the main directory ..
verified files exist:
subdir/includes/languages/english/modules/shipping/lang.upsoauth.php
subdir/includes/languages/english/modules/shipping/upsoauth.php
subdir/includes/modules/shipping/upsoauth.php
subdir/includes/modules/shipping/upsoauth/UpsOAuthApi.php
subdir/includes/templates/template_default/images/icons/shipping_ups.gif
UPDATE.. just figured it out.. Shipping Zone was disabling it.
Thanks for posting back the root cause!
New Zenner
Just installed UPS V1.3.7 to zencart V. 2.0.1, but it shows missing keys or out of date you should reinstall. The same message shows again after re-install. Where should I check? I already got the ID & secret from UPS.
Administrator
ericwu001:
Just installed UPS V1.3.7 to zencart V. 2.0.1, but it shows missing keys or out of date you should reinstall. The same message shows again after re-install. Where should I check? I already got the ID & secret from UPS.
Was this the first time you installed the shipping module on the site? Are there any myDEBUG-adm-*.log files in the site's /logs directory on/around the time you tried the installation?
New Zenner
Thanks for the reply. My site had upsxml 1.8.1 installed. Before I installed, I uninstalled UPSxml first. I checked my admin logs file, there is nothing about the error on the new module.
Administrator
If you go to your site's phpMyAdmin tool, click the SQL tab and enter/run the following query:
SELECT configuration_key FROM configuration WHERE configuration_key LIKE 'MODULE\_SHIPPING\_UPSOAUTH\_%';
... how many results show and what configuration_key values are present?
If your Zen Cart store uses database prefixes, e.g. zen_, you'll need to prefix the configuration table name with that prefix, e.g. zen_configuration.
New Zenner
After executing the query, it shows SELECT configuration_key FROM configuration WHERE configuration_key LIKE 'MODULE_SHIPPING_UPSOAUTH_%'; It shows no result. I don't use any prefix for my database.
Administrator
ericwu001:
After executing the query, it shows SELECT configuration_key FROM configuration WHERE configuration_key LIKE 'MODULE_SHIPPING_UPSOAUTH_%'; It shows no result. I don't use any prefix for my database.
OK, that sounds like the shipping-module isn't installed at all. Try that again, after you've installed the module and are receiving the "Missing keys" message.
New Zenner
I completely removed the UPSXML and reinstalled the RESTful/OAuth API module, missing key or out of date shown again as soon as I reinstalled.
Administrator
ericwu001:
I completely removed the UPSXML and reinstalled the RESTful/OAuth API module, missing key or out of date shown again as soon as I reinstalled.
When you, again, follow the instructions from post 152 above, what are your results?
New Zenner
I searched this thread and don't see anything on this. I apologize if it's a duplicate.
I have v1.3.7 installed on a 1.57d site. Everything seems to work ok, except, I'm not seeing any service descriptions on the checkout pages. It shows the rates, but not the descriptions. They're just blank. I've looked at the UPS logs and the service description fields are coming back blank.
I've searched the code and language files and don't see a place this should be coming from on the site.
Suggestions? Some setting out of whack?
Administrator
bbsbcastle:
I searched this thread and don't see anything on this. I apologize if it's a duplicate.
I have v1.3.7 installed on a 1.57d site. Everything seems to work ok, except, I'm not seeing any service descriptions on the checkout pages. It shows the rates, but not the descriptions. They're just blank. I've looked at the UPS logs and the service description fields are coming back blank.
I've searched the code and language files and don't see a place this should be coming from on the site.
Suggestions? Some setting out of whack?
Those service definitions (for zc157) come from /includes/languages/english/modules/shipping/upsoauth.php.
Check to make sure that the file's been copied.
New Zenner
I had checked to make sure those files were there and also copied them fresh from the install files.
I'll take a closer look there and see if I can tell anything. Thanks!
New Zenner
Ok. Looking at the code, I figured out the origin had gotten set as "All other origins" for some reason and that's why it wasn't finding them.
Tell staff why this post should be reviewed.