Forums / Basic Configuration / trouble with paradise--admin/market dame link

trouble with paradise--admin/market dame link

Views: 8,082

Results 41 to 60 of 62
3 Sep 2024, 1:16 AM
#41
heavensportal avatar

heavensportal

New Zenner

Join Date:
Jun 2021
Posts:
95
Plugin Contributions:
0

trouble with paradise--admin/market dame link

Its me again!

I am trying to reassociate my images with their products but I get this with some. I then need to copy/paste the text to a doc with the price and then delete the item from the store before it will accept the image and behave.

Is it something that this verison of ckeditor is quirky on. It is the updater that you have for download here on site.
what should I do? Or maybe renameing the image??

3 Sep 2024, 1:26 AM
#42
heavensportal avatar

heavensportal

New Zenner

Join Date:
Jun 2021
Posts:
95
Plugin Contributions:
0

Re: trouble with paradise--admin/market dame link

I forgot to post the error message:

https://fantasiesrealm.com/market/xxx/index.php?cmd=product&cPath=284&page=1&pID=1473&action=new_product 172.103.65.146 /market/xxx/index.php?cmd=product&cPath=284&pID=1473&action=new_product_preview&page=1 fantasiesrealm.com Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:129.0) Gecko/20100101 Firefox/129.0 500
3 Sep 2024, 12:36 PM
#43
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,109
Plugin Contributions:
56

Re: trouble with paradise--admin/market dame link

There's going to be a myDEBUG-adm-*.log file present in the site's /logs directory that identifies the details of that server 500 error.

3 Sep 2024, 4:43 PM
#44
heavensportal avatar

heavensportal

New Zenner

Join Date:
Jun 2021
Posts:
95
Plugin Contributions:
0

Re: trouble with paradise--admin/market dame link

lat9:

There's going to be a myDEBUG-adm-*.log file present in the site's /logs directory that identifies the details of that server 500 error.

ok, will look thanks

3 Sep 2024, 4:53 PM
#45
heavensportal avatar

heavensportal

New Zenner

Join Date:
Jun 2021
Posts:
95
Plugin Contributions:
0

Re: trouble with paradise--admin/market dame link

This is greek to me as to what it needs since it is in the vendor director/imagename.jpg on ftp.

[03-Sep-2024 16:44:01 UTC] Request URI: /market/xxx/index.php?cmd=product&cPath=138_284&page=1&pID=1473&action=new_product, IP address: 172.103.65.146
--> PHP Fatal error: Uncaught Error: Undefined constant "TEXT_PRODUCTS_IMAGE_DIR" in /home/fantasies/public_html/market/xxx/includes/modules/product/collect_info.php:383
Stack trace:
#0 /home/fantasies/public_html/market/xxx/product.php(111): require()
#1 /home/fantasies/public_html/market/xxx/index.php(16): require('/home/fantasies...')
#2 {main}
  thrown in /home/fantasies/public_html/market/xxx/includes/modules/product/collect_info.php on line 383.

[03-Sep-2024 16:44:01 UTC] Request URI: /market/xxx/index.php?cmd=product&cPath=138_284&page=1&pID=1473&action=new_product, IP address: 172.103.65.146
--> PHP Fatal error: Uncaught Error: Undefined constant "TEXT_PRODUCTS_IMAGE_DIR" in /home/fantasies/public_html/market/xxx/includes/modules/product/collect_info.php:383
Stack trace:
#0 /home/fantasies/public_html/market/xxx/product.php(111): require()
#1 /home/fantasies/public_html/market/xxx/index.php(16): require('/home/fantasies...')
#2 {main}
  thrown in /home/fantasies/public_html/market/xxx/includes/modules/product/collect_info.php on line 383.
3 Sep 2024, 7:14 PM
#46
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,109
Plugin Contributions:
56

Re: trouble with paradise--admin/market dame link

heavensportal:

This is greek to me as to what it needs since it is in the vendor director/imagename.jpg on ftp.

[03-Sep-2024 16:44:01 UTC] Request URI: /market/xxx/index.php?cmd=product&cPath=138_284&page=1&pID=1473&action=new_product, IP address: 172.103.65.146
--> PHP Fatal error: Uncaught Error: Undefined constant "[B]TEXT_PRODUCTS_IMAGE_DIR[/B]" in /home/fantasies/public_html/market/xxx/includes/modules/product/collect_info.php:383
Stack trace:
#0 /home/fantasies/public_html/market/xxx/product.php(111): require()
#1 /home/fantasies/public_html/market/xxx/index.php(16): require('/home/fantasies...')
#2 {main}
thrown in /home/fantasies/public_html/market/xxx/includes/modules/product/collect_info.php on line 383.

[03-Sep-2024 16:44:01 UTC] Request URI: /market/xxx/index.php?cmd=product&cPath=138_284&page=1&pID=1473&action=new_product, IP address: 172.103.65.146
--> PHP Fatal error: Uncaught Error: Undefined constant "TEXT_PRODUCTS_IMAGE_DIR" in /home/fantasies/public_html/market/xxx/includes/modules/product/collect_info.php:383
Stack trace:
#0 /home/fantasies/public_html/market/xxx/product.php(111): require()
#1 /home/fantasies/public_html/market/xxx/index.php(16): require('/home/fantasies...')
#2 {main}
thrown in /home/fantasies/public_html/market/xxx/includes/modules/product/collect_info.php on line 383.

The highlighted constant doesn't exist in the as-shipped Zen Cart distribution; I'll suggest reviewing the additions that you have made to your admin file-set.
3 Sep 2024, 9:24 PM
#47
heavensportal avatar

heavensportal

New Zenner

Join Date:
Jun 2021
Posts:
95
Plugin Contributions:
0

Re: trouble with paradise--admin/market dame link

I removed the text for (no image for) but that was text no images from server

3 Sep 2024, 10:07 PM
#48
heavensportal avatar

heavensportal

New Zenner

Join Date:
Jun 2021
Posts:
95
Plugin Contributions:
0

Re: trouble with paradise--admin/market dame link

another idiotic question...when uploading an image for the existing productss that for some reason are in their proper place -- for instance: market/images/promos/vendors name/name of jpg--- it seems to add the image but it plops it into the main images directory no using the one on the server in its proper area.

We used to have an area at the bottom of the page that showed an area to choose the location for the image (images/promos/) then we would enter the vendors directory and the name then click preview. There is no way to tell it to go to the promos/vendor/image.

Is my store screwed up still and I need to reinstall it....EEEEEK.

3 Sep 2024, 10:12 PM
#49
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,109
Plugin Contributions:
56

Re: trouble with paradise--admin/market dame link

I'm going to go out on a limb and suggest that you've successfully borked your upgrade.

3 Sep 2024, 10:51 PM
#50
heavensportal avatar

heavensportal

New Zenner

Join Date:
Jun 2021
Posts:
95
Plugin Contributions:
0

Re: trouble with paradise--admin/market dame link

wonderful, then I need to redo the install from the beginning with a total new upload. well that will be for tomorrow, I hope it works, maybe by using the db for 1.3.9h to upgrade to 1.5 then further it will behave.
thanks....now to remove the files/leaving my promos and downloads folder as is.

4 Sep 2024, 10:45 AM
#51
gothstone avatar

gothstone

Zen Follower

Join Date:
Jun 2005
Posts:
330
Plugin Contributions:
0

Re: trouble with paradise--admin/market dame link

I'm gonna go out on a limb here. I have no idea what priority you have on this project, or how much revenue is at stake. I can see you have had a lot of trouble and frustration. People on this forum will absolutely help, but replies back and forth will be slow, and lacking access, we won't always see the gotcha issue.
There are people who deal with these upgrades for a fee, and lat9 who has been helping you is the one ofthem i would first recomend if she has time for another client right now. If not, there are several others. Not saying you can't do it, but if your tired of it, there are options.
My personal guess is that your old db has various corruption that will need fixed before upgrading. Might try the audit plugin on the old site as it can find some of it.

2 + 2 = 5 for extremely large values of 2

Pez Collectors Store •••••••• My Plugins List

4 Sep 2024, 4:18 PM
#52
heavensportal avatar

heavensportal

New Zenner

Join Date:
Jun 2021
Posts:
95
Plugin Contributions:
0

Re: trouble with paradise--admin/market dame link

gothstone:

I'm gonna go out on a limb here. I have no idea what priority you have on this project, or how much revenue is at stake. I can see you have had a lot of trouble and frustration. People on this forum will absolutely help, but replies back and forth will be slow, and lacking access, we won't always see the gotcha issue.
There are people who deal with these upgrades for a fee, and lat9 who has been helping you is the one ofthem i would first recomend if she has time for another client right now. If not, there are several others. Not saying you can't do it, but if your tired of it, there are options.
My personal guess is that your old db has various corruption that will need fixed before upgrading. Might try the audit plugin on the old site as it can find some of it.

I wouldn't mind but then I---like with the older version---need to learn the "new atuff" to keep maintaining it. That and always broke is why I try and try and eventually win. BUT will keep that in mind for if my head actually implodes...LOL

4 Sep 2024, 5:33 PM
#53
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,845
Plugin Contributions:
17

Re: trouble with paradise--admin/market dame link

Not only are responses slow, store owners often try several Bandaids while waiting on an answer.

Installation/Upgrade is a whole different ballgame than maintenance/additions.

IMHO, you are skipping/missing some steps/notifications along the way to a site ready to be maintained.

Bandaids applied during installation/upgrade generally result in festering sores somewhere down the line.

Get some help to create the foundation your operation needs.

Need a hand with Zen Cart? Hire the team at myZenCartZone.com for upgrades, repairs, and custom plugins.
Zen Cart Certified hosting at myZenCartHost.com

6 Sep 2024, 10:30 PM
#54
heavensportal avatar

heavensportal

New Zenner

Join Date:
Jun 2021
Posts:
95
Plugin Contributions:
0

Re: trouble with paradise--admin/market dame link

dbltoe:

Not only are responses slow, store owners often try several Bandaids while waiting on an answer.

Installation/Upgrade is a whole different ballgame than maintenance/additions.

IMHO, you are skipping/missing some steps/notifications along the way to a site ready to be maintained.

Bandaids applied during installation/upgrade generally result in festering sores somewhere down the line.

Get some help to create the foundation your operation needs.

I'm certain that something did not get done right which is why I was going to try upgrading from 1.3.9h however, I got no upgrades done because it told me that my old database is not allowed anymore by myPHPadmin area since it is for 7.4PHP and they do not allow cURL to be installed within the structure anymore--PHP server put it on the cloud. I then just did the upgrades for the 1.5 to 2.0.1 and see the pages like they should be. I need to get with PayPal and see how to install their new payment methods. I find I will need to insert the information manually into the table from the old DB or the product/merchant/promos into the store by hand from admin.

7 Sep 2024, 11:05 AM
#55
gothstone avatar

gothstone

Zen Follower

Join Date:
Jun 2005
Posts:
330
Plugin Contributions:
0

Re: trouble with paradise--admin/market dame link

Now we are getting somwhere! Zencart still requires curl! You need a new host. But you can drag over the old DB, and the upgrade will probably go better on a server with the proper requirements.
https://docs.zen-cart.com/user/first_steps/server_requirements/#mysql-version

2 + 2 = 5 for extremely large values of 2

Pez Collectors Store •••••••• My Plugins List

8 Sep 2024, 12:47 AM
#56
heavensportal avatar

heavensportal

New Zenner

Join Date:
Jun 2021
Posts:
95
Plugin Contributions:
0

Re: trouble with paradise--admin/market dame link

well ai shall get hold of the host and let them know that I need cURL to be installed and then see if it behaves, yes it let me install v2.0.1 but it did say that about cURL. This host has been very helpful, more so than any of the others we've had. maybe he will know how to get it and I also don't really mind taking all off the server once more then reinstalling it again to screenshot everything it says is not right.

8 Sep 2024, 11:28 PM
#57
heavensportal avatar

heavensportal

New Zenner

Join Date:
Jun 2021
Posts:
95
Plugin Contributions:
0

Re: trouble with paradise--admin/market dame link

ok, this is what the host just sent me. He worked on it and tomorrow I will remove all, then install first trying with my DB then recording any errors it may spit out. Then try again with only the empty DB.

He said to share this link with you: ```
https://fantasiesrealm.com/market/phpCZinfo.php


He said this also:
Curl is enabled and has OpenSSL/1.1.1k  (you can search that in the PHPinfo page above).
 
As for this:

### Apache modules
The Apache configuration must have AllowOverride set to All or at least Limit Indexes Options. (Without this the .htaccess rules will fail and trigger 500 Server Error errors.)
Recommended Apache modules include: expires, headers, env, alias, deflate, ssl, http2, mime, phpX, rewrite (in addition to other standard/default modules for a typical webserver serving PHP applications).
In Apache I see these aren’t currently enabled:
 
Mod_env (available but not installed)
Mod_vhost_alias  (available but not installed)
phpX (don’t see this as an option at the moment and don’t see much on google – Maybe they’re just referring to “PHP version x” meaning PHP itself must be enabled?)
 
Can you ask if these are a requirement? 
9 Sep 2024, 11:10 AM
#58
gothstone avatar

gothstone

Zen Follower

Join Date:
Jun 2005
Posts:
330
Plugin Contributions:
0

Re: trouble with paradise--admin/market dame link

Your config we can see looks pretty sane.
Apache Modules: No, they aren't required, but they are recomended.
Env - just get your host to turn it on, it should be considered a requirement
Vhost-alias - id mod_alias is in you dont necessarily need vhost_alias. Depends on servers config. You do need at least one.
Phpx - this is already installed. Looks like they are using php-fpm which is fine.

Note: with php 8.3 and mysql 8.3 you must install zencart 2 or higher. The zc_install for 1.5.8 should have failed in php 8.3.
After your host verifies apache config, since they are so helpfull, ask them to download zc 2.0.1 directly to the server and unzip it to an empty directory for you. That will eliminate any file upload issues for you. You can then run zcinstall and get a clean blank store. If that has an issue, send up any on screen errors and logs. If it works your setup is definately valid and you can load a copy of your old DB, reupload zcinstall folder, and try it as a database upgrade. Again, send any errors you encounter.
The only zcinstall error you can ignore is the gzip disabled as its frequently wrong. Anything else should be reported.

2 + 2 = 5 for extremely large values of 2

Pez Collectors Store •••••••• My Plugins List

9 Sep 2024, 4:25 PM
#59
heavensportal avatar

heavensportal

New Zenner

Join Date:
Jun 2021
Posts:
95
Plugin Contributions:
0

Re: trouble with paradise--admin/market dame link

gothstone:

Your config we can see looks pretty sane.
Apache Modules: No, they aren't required, but they are recomended.
Env - just get your host to turn it on, it should be considered a requirement
Vhost-alias - id mod_alias is in you dont necessarily need vhost_alias. Depends on servers config. You do need at least one.
Phpx - this is already installed. Looks like they are using php-fpm which is fine.

Note: with php 8.3 and mysql 8.3 you must install zencart 2 or higher. The zc_install for 1.5.8 should have failed in php 8.3.
After your host verifies apache config, since they are so helpfull, ask them to download zc 2.0.1 directly to the server and unzip it to an empty directory for you. That will eliminate any file upload issues for you. You can then run zcinstall and get a clean blank store. If that has an issue, send up any on screen errors and logs. If it works your setup is definately valid and you can load a copy of your old DB, reupload zcinstall folder, and try it as a database upgrade. Again, send any errors you encounter.
The only zcinstall error you can ignore is the gzip disabled as its frequently wrong. Anything else should be reported.

ok, I removed everything last night since I couldn't sleep with this flu, and after I installed it, I went and yes they all failed with 8.3 so I installed 2.0.1

there were no error messages. I did just that, took down everything, uploaded the zip -- it is so much faster and easier to get the files up there...LOL Ran the installer, no errors, emptied not dropped the tables and inserted the sql database throough the "insert" tab. Again no errors and the only thing I noticed is that my own admin was replaced with the one on the DB inserted.

I then used the zc_installer again to do the upgrade -- no issues except that when it came time to enter the superuser name it would not let me -- it said the one entry was not there and yup. it was gone. I see that it actually didn't replace the info but the entire tables. I can't remember the name, maybe admin profile sooo Iemptied them again ran the installer and got ready but even after that it still would not let me continue, stating the superuser name was not valid. Used the instructions to inter the Admin user info and it still won't behave.

I thought today I would reinstall the software fresh, using the old DB at the beginning but I am afraid that will just make it a clean install where I will need to go through the other way again.

Do you know if there are other additional info lines with the other tables? Since the old DB seems to replace not just insert the information I should just insert thru the actual table sql area not thru the insert area.

Sorry if I confused you, that is my specialty, but I don't really want to bother my host with things right now, he/wife had a death in the family and dealing with that.

9 Sep 2024, 9:52 PM
#60
gothstone avatar

gothstone

Zen Follower

Join Date:
Jun 2005
Posts:
330
Plugin Contributions:
0

Re: trouble with paradise--admin/market dame link

It might just be your description, but the way you describe replacing the database is weird. You shouldn't be just putting in data or laying one on top the other. You should:

  1. Drop or delete the existing 2.0.1 database.
  2. Create a new database of the same name.
  3. Restore a backup of the old 1.3.9 database.
  4. If you don't know the old admin user/pass just create a new one following this doc: https://docs.zen-cart.com/user/troubleshooting/reset_admin_password/#:~:text=Password%3A%20admin&text=ie.,username%2C%20not%20'admin'.
  5. Run zc_install selecting upgrade, not clean install

There should be no need to touch the fileset at all (beyond zc_install), you should currently have a clean 2.0.1 file set. You just need to correctly restore the old database and upgrade it with zc_install.

2 + 2 = 5 for extremely large values of 2

Pez Collectors Store •••••••• My Plugins List