Forums / Installing on a Linux/Unix Server / "Problems with session support" error on new install on VPS

"Problems with session support" error on new install on VPS

Views: 3,103

Results 1 to 15 of 15
3 Apr 2026, 6:43 PM
#1
starrysky avatar

starrysky

New Zenner

Join Date:
Aug 2013
Posts:
44
Plugin Contributions:
0

"Problems with session support" error on new install on VPS

I have a Zencart version from a very long time ago (version 1.5.0, 1.5.1, and 1.3.8a all had the same functionality and version), and I was previously able to operate it, albeit without actual purchasing functions (just as a store display that one could email or call if interested), on a shared hosting service with CloudLinux, with no issues. All of the carts of these versions had an htaccess handler to allow them to call php version 5.6 and use that, and it was working without incident. I was recently required to move to a new VPS server by the provider, which is running AlmaLinux 9. I have cPanel installed and WHM, along with EasyApache and Cloudlinux.

The cart version (there are several that don't work) is 1.5.0 and 1.5.1, with another that is 1.3.8a. The one I have been focusing on trying to repair first was 1.5.0. When I change the version of php to 5.6, and use Cgi (instead of PHP-FPM), the website brings up a 500 error. I tried multiple troubleshooting steps, including resetting the php engine and the apache engine, none of which worked.

So, instead I installed a brand new, up to date zencart version 2.2.1 installation on the same server running AlmaLinux, cpanel, WHM. I installed it using ftp to put it on the server. I activated php version 8.2 with PHP-FPM activated as well. I pointed the domain name that had previously been on the ZC 1.5.0 version to this new folder with the fresh install.

When I visit the site, it does go to the installation page, but when I click on “Click here” to run the installer, the first error that comes up, in red and preventing further progress, is Problems with session support

I have tried activating and deactivating php-fpm on the server. I have reinstalled php 8.2. I have restarted php and apache. Nothing seems to work. I want to mention that Wordpress sites, of the latest version, are working fine on this exact same server using this exact version of PHP (8.2 with fpm), so the php version and all associated plugins that are needed for that software is working. Perhaps there is some extension that is needed for Zencart, and most of the extensions that should be needed for zen cart appear to be installed and functioning. This server is using for SQL 10.11.16-MariaDB, Apache version 2.4.66, and php versoin 8.2.

Still, it doesn't allow me to install it. Once I am able to complete the install, I should be then be able to pull in the old database and upgrade it, and have a functioning cart again. But I cannot get to that point, as I am stuck before installing, and there is not yet a configure file in the includes or admin includes, since they haven't been created yet. If you can help with what possible issues might be, whether it is fixable through cpanel or some other method, that would be great. As I said, I am attempting to install the very latest version (2.2.1), and cannot get it to work.

Also, since I was not able to get this to work, and it does go to the installation page, I have renamed the folder for the website itself, so it will just go to a error 500 as of this moment. See the attached screenshotof the full message on the error page that comes up after clicking "click here" on the installation page. Thank you.

3 Apr 2026, 6:50 PM
#2
balihr avatar

balihr

Totally Zenned

Join Date:
Oct 2008
Location:
Croatia
Posts:
1,802
Plugin Contributions:
22

Re: "Problems with session support" error on new install on VPS

I've had the same issue the other day, drove me nuts. Adding the following line in the php.ini resolved it:

output_buffering = 16384

My site - Pro ZC Help
My portfolio | My plugins

3 Apr 2026, 7:17 PM
#3
starrysky avatar

starrysky

New Zenner

Join Date:
Aug 2013
Posts:
44
Plugin Contributions:
0

Re: "Problems with session support" error on new install on VPS

Thanks very much. This is what the php.ini file, in the cart main folder, shows, and adding that didn't fix the issue:
session.save_path = "/tmp"
session.auto_start = 0
session.gc_maxlifetime = 1440
output_buffering = 16384

Thanks for your help!

3 Apr 2026, 8:26 PM
#5
starrysky avatar

starrysky

New Zenner

Join Date:
Aug 2013
Posts:
44
Plugin Contributions:
0

Re: "Problems with session support" error on new install on VPS

Thanks very much. That worked to install the cart. However, once I uploaded the old database to overwrite the automatically created one, it goes to a 500 error page. It does not offer the option to upgrade the database. Do I need to give the database a brand new name? How do I get to the screen that asks if I want to upgrade the database after I have completed the installation? I appreciate your help. Thanks!

3 Apr 2026, 8:31 PM
#6
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,848
Plugin Contributions:
17

Re: "Problems with session support" error on new install on VPS

Replacing the database should not result in a 500 error, but there should be a file in your logs directory if you haven't turned on Display Logs in the Plugin Manager.

If you need help with what it says, post the file here using the # above.

Need a hand with Zen Cart? Hire the team at myZenCartZone.com for upgrades, repairs, and custom plugins.
Zen Cart Certified hosting at myZenCartHost.com

3 Apr 2026, 8:47 PM
#7
starrysky avatar

starrysky

New Zenner

Join Date:
Aug 2013
Posts:
44
Plugin Contributions:
0

Re: "Problems with session support" error on new install on VPS

This is what keeps repeating:

[03-Apr-2026 20:43:47 UTC] Request URI: /index.php?main_page=index, IP address:
--> PHP Fatal error: Uncaught Error: Undefined constant "WHOLESALE_PRICING_CONFIG" in /home/public_html/cart/includes/classes/Customer.php:58
Stack trace:
#0 /home/public_html/md-cart/includes/classes/Customer.php(85): Customer::getCustomerWholesaleInfo()
#1 /home/public_html/cart/includes/init_includes/init_header.php(86): Customer::isWholesaleCustomer()
#2 /home/public_html/cart/includes/autoload_func.php(40): require_once('/home/t1server/...')
#3 /home/public_html/cart/includes/application_top.php(395): require('/home/t1server/...')
#4 /home/public_html/cart/index.php(27): require('/home/t1server/...')
#5 {main}
thrown in /home/public_html/cart/includes/classes/Customer.php on line 58.

Thank you!

3 Apr 2026, 9:15 PM
#8
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,110
Plugin Contributions:
56

Re: "Problems with session support" error on new install on VPS

starrysky:

This is what keeps repeating:

[03-Apr-2026 20:43:47 UTC] Request URI: /index.php?main_page=index, IP address:
--> PHP Fatal error: Uncaught Error: Undefined constant "WHOLESALE_PRICING_CONFIG" in /home/public_html/cart/includes/classes/Customer.php:58
Stack trace:
#0 /home/public_html/md-cart/includes/classes/Customer.php(85): Customer::getCustomerWholesaleInfo()
#1 /home/public_html/cart/includes/init_includes/init_header.php(86): Customer::isWholesaleCustomer()
#2 /home/public_html/cart/includes/autoload_func.php(40): require_once('/home/t1server/...')
#3 /home/public_html/cart/includes/application_top.php(395): require('/home/t1server/...')
#4 /home/public_html/cart/index.php(27): require('/home/t1server/...')
#5 {main}
thrown in /home/public_html/cart/includes/classes/Customer.php on line 58.

Thank you!
Right, since you've now changed the database to contain "old" contents, that WHOLESALE_PRICING_CONFIG setting isn't present. You'll need to run the zc_install process against that version of the database to get all the required changes "booked".

3 Apr 2026, 9:35 PM
#9
oldngrey avatar

oldngrey

Zen Follower

Join Date:
Apr 2008
Location:
Qld, Australia
Posts:
427
Plugin Contributions:
0

Re: "Problems with session support" error on new install on VPS

After you have imported the old database into the new site and you see the 500 "This page isn’t working" error, simply add "/zc_install" to the end of the URL to start the installer for the upgrade.

OldNGrey
ZC222 PHP 8.4.16
MySQL 11.8.5-MariaDB

9 Apr 2026, 5:06 AM
#10
todoonada avatar

todoonada

Zen Follower

Join Date:
Nov 2006
Posts:
127
Plugin Contributions:
0

Re: "Problems with session support" error on new install on VPS

After installing the new version and importing my DB from version 2.1.0, I go to zc_install again to do the DB-upgrade. The upgrade finished successfully, but it seems the session table is not created. I get an error in the log files:
--> PHP Fatal error: FATAL MySQL error 1146: Table 'xxx.sessions' doesn't exist :: SELECT value
FROM sessions
WHERE sesskey = 'vgnets3d7inf34h5qnd3mj0f2b'
AND expiry > '1775710974' ==> (as called by) /zencart-2.2.2/includes/classes/SessionHandler.php on line 74 <== in /zencart-2.2.2/includes/classes/db/mysql/query_factory.php on line 757.

9 Apr 2026, 12:42 PM
#11
lat9 avatar

lat9

Administrator

Join Date:
Sep 2009
Location:
Stuart, FL
Posts:
14,110
Plugin Contributions:
56

Re: "Problems with session support" error on new install on VPS

todoonada:

After installing the new version and importing my DB from version 2.1.0, I go to zc_install again to do the DB-upgrade. The upgrade finished successfully, but it seems the session table is not created. I get an error in the log files:
--> PHP Fatal error: FATAL MySQL error 1146: Table 'xxx.sessions' doesn't exist :: SELECT value
FROM sessions
WHERE sesskey = 'vgnets3d7inf34h5qnd3mj0f2b'
AND expiry > '1775710974' ==> (as called by) /zencart-2.2.2/includes/classes/SessionHandler.php on line 74 <== in /zencart-2.2.2/includes/classes/db/mysql/query_factory.php on line 757.
Were there any zcInstall*.log files created in the /logs directory when the update was processed?

9 Apr 2026, 7:28 PM
#12
starrysky avatar

starrysky

New Zenner

Join Date:
Aug 2013
Posts:
44
Plugin Contributions:
0

Re: "Problems with session support" error on new install on VPS

Thanks so much for your help. going to /zc_install fixed the issue and the upgrade proceeded normally. Everything is working now, except that it is missing the old header information, as so much has changed between the old version and the current version. I would like to at least change the zencart installation message: Congratulations! You have successfully installed your Zen Cart® E-Commerce Solution.

The lang.index.php file inside includes/languages/english/responsive_classic was suggested in the forum as the place to find this line of text. But it is not there. Is there a way to import the data from the old site, such as heading information and other info into this new version, or do they have to be copied and pasted into new files? Is there a list of files that would need to be changed and what the new files would be (going from classic to responsive_classic templates, from version 1.5.0)

This is what is in the above referenced file contains:

<?php $define = [ 'TABLE_HEADING_IMAGE' => '', ]; return $define; Thanks very much!
10 Apr 2026, 7:00 AM
#14
todoonada avatar

todoonada

Zen Follower

Join Date:
Nov 2006
Posts:
127
Plugin Contributions:
0

Re: "Problems with session support" error on new install on VPS

lat9:

Were there any zcInstall*.log files created in the /logs directory when the update was processed?

Five zcInstallLogs.
One debug log. It reads:
MySQL error 1062 encountered during zc_install:
Duplicate entry 'featured_categories' for key 'page_key'
VALUES ('featured_categories', 'BOX_CATALOG_FEATURED_CATEGORIES', 'FILENAME_FEATURED_CATEGORIES', '', 'catalog', 'Y', 13);

10 Apr 2026, 7:18 PM
#15
starrysky avatar

starrysky

New Zenner

Join Date:
Aug 2013
Posts:
44
Plugin Contributions:
0

Re: "Problems with session support" error on new install on VPS

Thanks for all your help. Is there an instruction guide for upgrading between 1.5.0 and 2.2.1? One of the carts had a lot of styling that I would like to port over if possible, but the files are very different between these versions. Is there a list of file equivalencies that I can use to bring the old cart styling into the new one? Thank you!