shrimp-gumbo-mmmhhh:
It works fine for me on 157c with php 8.0.3.... maybe you need to post what issues you are having.
shrimp-gumbo-mmmhhh:
If anyone is the caretaker of this wonderful tool.... I have an issue that just popped up for me. My item name in the file was larger than 64 chars.... It populated in the products table but not the products_description table. So the category showed 1 product but I could not see it. It would be great if you could add some checks to see if any of the data is too long for the database objects to accept and then not process them but put those records into a separate file so they can be worked with.
Thank you!
shrimp-gumbo-mmmhhh:
Here is another issue that might want to be looked at: products_price is treated like a character field and cannot accept "$" before the amount. Still works but this gave me a problem at first... had to remove "$"
INSERT INTO products SET products_model = 'SKU501', products_type = 1, products_price = '$72.00 ',
shrimp-gumbo-mmmhhh:
Okay, here are some other issues I believe I found with this module.... runs great but has some things you might need to clean up to get in:
- I had measurements (26 13/16") in the metatags_description and the sql failed with error 1366: Incorrect String value
- I had measurements in the products_description field and they failed if there was only one (") in the enclosed field..... if there were 2(") it seemed to load.
Maybe it needs code to clean up for quotes in strings?
- I got a bunch of these "SKIPPED! - v_products_model: SHU018 Woodchuck | Woodchuck - specials price higher than normal price..." but the field value for both came from the same place so they were actually the same.... but this error showed up a lot.
Having seen you post the list of plugins installed to your system, the one associated with mass product import is not the same plugin as discussed in this thread. The issues experienced are generally easy to correct when the csv file is properly created and/or escaped. For example, consider this situation:
The file processor (which is a php process) is looking for a double quote to indicate the start of a new field with a matching quote at the end of the field. But, somewhere between the two is a standard quote... without that inner quote identified as just text to be part of the grouping, then an error tends to be generated because after that "extra" quote, there isn't a field separator. This causes "confusion" to php basically and results in an error in that line. So the next line is then attempted... one fix is to escape that "inner" quote. This is done by using the backslash before a quote that is to be shown as text. That backslash looks like: \ so that an escaped quote would be ". Another way is to use the html equivalent of a quote: ```
"e;
The specials prices issue, well, a determination is made when importing prices associated with specials. The determination is to evaluate the price being imported against the resulting price of applying the special. The point of the special is generally to provide a price that is "better" than the product's price. If the special price is higher than the standard price, why would that be considered a "special" in a properly managed site? If the special and the product price were the same, why would *that* be considered a special? While the Zen Cart store allows these conditions, the version of bulk product software you have reported using prevents it. Considering that normally such a situation would exist/occur for a limited number of product, it should be something easily/quickly corrected through manual operation.
Now I say that, the comment was that they both came from the same place... that is not very descriptive which is why I provided the above general description of expectations. Might there be an issue in the code? Maybe, but I don't have enough information to say that there is/is not a problem with the code so would need more information and preferably at the thread associated with the plugin you are using. The thread path should be in the plugins documentation.