Forums / General Questions / Can't Login to Admin- DB Error?

Can't Login to Admin- DB Error?

Locked

Views: 3,223

Results 1 to 7 of 7
This thread is locked. New replies are disabled.
11 May 2006, 1:34 AM
#1
luckykat avatar

luckykat

New Zenner

Join Date:
Mar 2006
Posts:
18
Plugin Contributions:
0

Can't Login to Admin- DB Error?

I am in the process of moving to a new host. I did a fresh install of 1.2.7 and copied all of my files over and imported the database. I ran the db installer upgrade just to make sure it was all updated and it successfully did so. The catalog looks fine but when trying to go to my admin page, it says:
1146 Table 'luckykat_zencart.project_version' doesn't exist

I looked and project_version does exist in the database, so I figured it has something to do with a file that is requesting this in the wrong way. I do need to have a database prefix, so maybe that is missing somewhere.... I am not sure where to look or what to change.

Honestly, I am not sure why I installed 1.2.7 and not the newest version, I guess because that is what I already had been using. Do you think this problem would possibly be solved if I did? Its just that I am so close to being done.....

11 May 2006, 1:43 AM
#2
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: Can't Login to Admin- DB Error?

are you sure that your catalog and admin are pointed at the same database.

open admin/includes/configure.php and make sure its pointing towards the correct DB

Zen cart PCI compliant Hosting

11 May 2006, 1:59 AM
#3
luckykat avatar

luckykat

New Zenner

Join Date:
Mar 2006
Posts:
18
Plugin Contributions:
0

Re: Can't Login to Admin- DB Error?

Yes, it is pointing to the correct DB.

But I did notice that there was no DB prefix listed- so when I added mine (which is what I did in includes/config previously)- but it created a new error when I go to Admin.
1146 Table 'luckykat_zencart.zen_zen_project_version' doesn't exist

So apparently, that put an incorrect prefix in there...

11 May 2006, 2:01 AM
#4
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: Can't Login to Admin- DB Error?

OK
open the /includes/configuration.php

copy and past the DB information to

admin/includes/configuration.php

over write the exsisting DB info

make a back up first of course see if that dosnt help you out

Zen cart PCI compliant Hosting

11 May 2006, 2:13 AM
#5
luckykat avatar

luckykat

New Zenner

Join Date:
Mar 2006
Posts:
18
Plugin Contributions:
0

Re: Can't Login to Admin- DB Error?

Okay, I did, but it is the same error message.
It looks like there is an extra zen_ in there... it should be only one.

First, it didn't have any zen_ in the error message and then now it has two!

11 May 2006, 5:11 AM
#6
cartika avatar

cartika

New Zenner

Join Date:
May 2004
Location:
Toronto
Posts:
26
Plugin Contributions:
0

Re: Can't Login to Admin- DB Error?

Hello luckycat,

OK - when you ran the install on the new server, did you ensure you didnt leave the default zen_ prefix in during the install?

What you may want to try is simply dropping the tables in the database using phpmyadmin, then importing your backup DB again. Do this without running the re-install - also, make sure you config files (/includes/configure.php and /admin/includes/configure.php have the correct connection settings - particularly your DB prefix - which should match with what you import from your local backup)

Andrew
www.cartikahosting.com
Business Grade, Clustered Application Hosting with years of superior uptime history
Host Zen Cart on Linux, Windows or FreeBSD

11 May 2006, 5:58 AM
#7
luckykat avatar

luckykat

New Zenner

Join Date:
Mar 2006
Posts:
18
Plugin Contributions:
0

Re: Can't Login to Admin- DB Error?

I tried re-installing a couple of times and did a new backup of the old database and reimporting and it was always the same error.

But... I think I fixed it!

Because it looked like it was looking for a table with double prefixes... I just copied the data in the regular zen_project_history table in the database and added a new table with the same data called zen_zen_project_history. It works and I guess that whatever different files that needs these tables to run are somehow set to get it from different places, so now they can correctly get it from either table.