Zen Cart Logo
Forums / Installing on a Windows Server / Clean 1.3.0.1 kills php (1.3.0 works fine)

Clean 1.3.0.1 kills php (1.3.0 works fine)

Locked

Views: 4,907

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
12 May 2006, 10:45 PM
#1
wils avatar

wils

Zen Follower

Join Date:
Apr 2006
Location:
Göteborg
Posts:
124
Plugin Contributions:
0

Clean 1.3.0.1 kills php (1.3.0 works fine)

Having had 1.3.0.0 working fine as a local backup, running on a Win2k machine for a while, I can't get 1.3.0.1 to work.

I used a clean install.

The catalog works fine with a brand new database.

When logging in to admin, php crash on the web server "PHP Script Interpreter has encountered a problem and needs to close..." == fatal error.

Then the web server gives:

"Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error."

If I simply use an old copy of the admin/ directory it works fine.

Apache log say: "[Sat May 13 00:30:52 2006] [error] [client 192.168.1.24] Premature end of script headers: php.exe, referer: http://192.168.1.14/admin/login.php"

192.168.1.14 my server
192.168.1.24 my client

Database: MySQL 4.0.18-nt
PHP Version: 4.4.2 (Zend: 1.3.0)
HTTP Server: Apache/2.0.55 (Win32)

All input appreciated.

/Anders

12 May 2006, 11:00 PM
#2
wils avatar

wils

Zen Follower

Join Date:
Apr 2006
Location:
Göteborg
Posts:
124
Plugin Contributions:
0

Re: Clean 1.3.0.1 kills php (1.3.0 works fine)

An update: Replacing header.php with the file from 1.3.0 avoids the crash. But still have not found out why.

/Anders

12 May 2006, 11:18 PM
#3
wils avatar

wils

Zen Follower

Join Date:
Apr 2006
Location:
Göteborg
Posts:
124
Plugin Contributions:
0

Re: Clean 1.3.0.1 kills php (1.3.0 works fine)

Workaround: disable version checking upon login. Doing a manual version check in the admin area still crash php on the server (Win2k) though.