Zen Cart Logo
Forums / Templates, Stylesheets, Page Layout / Need immediate Help!

Need immediate Help!

Locked

Views: 4,764

Results 1 to 16 of 16
This thread is locked. New replies are disabled.
15 May 2006, 1:59 AM
#1
virtue avatar

virtue

New Zenner

Join Date:
May 2006
Posts:
58
Plugin Contributions:
0

Need immediate Help!

I was making some changes to my Zen Cart.

Suddently this is what I am getting. See a very ugly outcome! Need immediate help on this!!!:shocking: :shocking: THIS IS HORRIFYING!

insert into zen_db_cache set cache_entry_name = 'zc_6ec65decb95a7741ada473af0fde76e1', cache_data = 'a:515:{i:0;a:2:{s:6:"cfgkey";s:10:"STORE_NAME";s:8:"cfgvalue";s:12:"exophora.com";}i:1;a:2:{s:6:"cfgkey";s:11:"STORE_OWNER";s:8:"cfgvalue";s:5:"admin";}i:2;a:2:{s:6:"cfgkey";s:13:"STORE_COUNTRY";s:8:"cfgvalue";s:3:"223";}i:3;a:2:{s:6:"cfgkey";s:10:"STORE_ZONE";s:8:"cfgvalue";s:2:"61";}i:4;a:2:{s:6:"cfgkey";s:22:"EXPECTED_PRODUCTS_SORT";s:8:"cfgvalue";s:4:"desc";}i:5;a:2:{s:6:"cfgkey";s:23:"EXPECTED_PRODUCTS_FIELD";s:8:"cfgvalue";s:13:"date_expected";}i:6;a:2:{s:6:"cfgkey";s:29:"USE_DEFAULT_LANGUAGE_CURRENCY";s:8:"cfgvalue";s:5:"false";}i:7;a:2:{s:6:"cfgkey";s:25:"LANGUAGE_DEFAULT_SELECTOR";s:8:"cfgvalue";s:7:"Default";}i:8;a:2:{s:6:"cfgkey";s:27:"SEARCH_ENGINE_FRIENDLY_URLS";s:8:"cfgvalue";s:5:"false";}i:9;a:2:{s:6:"cfgkey";s:12:"DISPLAY_CART";s:8:"cfgvalue";s:4:"true";}i:10;a:2:{s:6:"cfgkey";s:32:"ADVANCED_SEARCH_DEFAULT_OPERATOR";s:8:"cfgvalue";s:3:"and";}i:11;a:2:{s:6:"cfgkey";s:18:"STORE_NAME_ADDRESS";s:8:"cfgvalue";s:38:"Store Name\r\n Address\r\n Country\r\n Phone";}i:12;a:2:{s:6:"cfgkey";s:11:"SHOW_COUNTS";s:8:"cfgvalue";s:4:"true";}i:13;a:2:{s:6:"cfgkey";s:18:"TAX_DECIMAL_PLACES";s:8:"cfgvalue";s:1:"0";}i:14;a:2:{s:6:"cfgkey";s:22:"DISPLAY_PRICE_WITH_TAX";s:8:"cfgvalue";s:5:"false";}i:15;a:2:{s:6:"cfgkey";s:28:"DISPLAY_PRICE_WITH_TAX_ADMIN";s:8:"cfgvalue";s:5:"false";}i:16;a:2:{s:6:"cfgkey";s:23:"STORE_PRODUCT_TAX_BASIS";s:8:"cfgvalue";s:8:"Shipping";}i:17;a:2:{s:6:"cfgkey";s:24:"STORE_SHIPPING_TAX_BASIS";s:8:"cfgvalue";s:8:"Shipping";}i:18;a:2:{s:6:"cfgkey";s:24:"STORE_TAX_DISPLAY_STATUS";s:8:"cfgvalue";s:1:"0";}i:19;a:2:{s:6:"cfgkey";s:21:"SESSION_TIMEOUT_ADMIN";s:8:"cfgvalue";s:4:"3600";}i:20;a:2:{s:6:"cfgkey";s:21:"GLOBAL_SET_TIME_LIMIT";s:8:"cfgvalue";s:2:"60";}i:21;a:2:{s:6:"cfgkey";s:29:"SHOW_VERSION_UPDATE_IN_HEADER";s:8:"cfgvalue";s:4:"true";}i:22;a:2:{

Virtue

15 May 2006, 2:34 AM
#2
theoracle avatar

theoracle

Suspended

Join Date:
Aug 2004
Posts:
3,180
Plugin Contributions:
1

Re: Need immediate Help!

I was making some changes to my Zen Cart.

When does this SQL error message occurs specificly ?

15 May 2006, 3:01 AM
#3
virtue avatar

virtue

New Zenner

Join Date:
May 2006
Posts:
58
Plugin Contributions:
0

Re: Need immediate Help!

When I try to link with the shopping cart. I was deleting the default messages on the html so to complete my customization and this is what I am getting.

If this is cannot be fixed, I am thinking of re-installing the cart. But this is such a pain to start all over again. You see what I am saying?

Thanks.

Virtue

15 May 2006, 4:09 AM
#4
sermonzone avatar

sermonzone

Zen Follower

Join Date:
Oct 2005
Location:
New Mexico
Posts:
365
Plugin Contributions:
0

Re: Need immediate Help!

Virtue,

You will need to be much more specific to get help from the Zen masters. Give them a link to the site and "I did this and got this error" kind of detail or they cannot help.

Also, if I am reading the tea leaves correctly, you may be having trouble with the template system. Here is some info I have collected that may help.

Zen Cart is built on a system called ‘overrides.’ When you have worked hard on customizing your site you do not want to lose all that work when a new version or cart update comes along. So, follow the guide for creating a custom template and it will ‘override’ the stock template.

Read, comprehend and apply these threads and you will be blessed by the Zen Cart magic. Your new custom template folder should only contain files that have been edited for your site. Copy the files from template_default, edit them, and make sure they are in the correct ’my_custom_template’ folder.

The Wiki is a great place to start. However, since the forum experienced an emergency reload, many of links have not been updated. Be patient.

http://www.zen-cart.com/wiki/index.php/Customisation_-_Templates_-_Customizing
http://www.zen-cart.com/wiki/index.php/Customisation_-_Templates
http://www.zen-cart.com/wiki/index.php/Developers_API_Overrides
http://www.zen-cart.com/wiki/index.php/Basic_Checklist

From the previous forum by NetworkDad is my favorite.

http://www.zen-cart.com/forum/showthread.php?t=7263

Hope some of this helps.

Good luck

15 May 2006, 4:32 AM
#5
virtue avatar

virtue

New Zenner

Join Date:
May 2006
Posts:
58
Plugin Contributions:
0

Re: Need immediate Help!

Thank you for your good advice Bruce.

Now, I am just confused because when I checked it from a different computer the cart looks normal. But from another computer, it has that crazy look. Was it hacked? Here's the store's link:

https://www.exophora.com/e-store

I am still working on this (as this is my project) and suddenly I got that weird screen when I tried to go and check the store.

But here's another big error I got. When I tried to configure the SSL to link with LinkPoint, it doesn't save my changes.

// Use secure webserver for checkout procedure?
define('ENABLE_SSL', 'false');

I am trying to change the "false" to "yes". But it gives me "fatal error or runtime error occured" message and doesn't save the changes.

Is this what is causing it?

Thanks.

Virtue

15 May 2006, 5:02 AM
#6
sermonzone avatar

sermonzone

Zen Follower

Join Date:
Oct 2005
Location:
New Mexico
Posts:
365
Plugin Contributions:
0

Re: Need immediate Help!

Virtue,

When you say > I am still working on this (as this is my project) and suddenly I got that weird screen when I tried to go and check the store. it is unlikely you will get much help. It is just too vague.

I can only help new zenners with very basic things like the template override. I hope it takes some pressure off the 'big guns' to handle more serious issues.

A problem with the database qualifies as more serious and the only help I can give you is this - to be a specific as possible about the problem. Who does the hosting? what is the exact error message? how did it happen, EXACTLY? etc.

But here's another big error I got. When I tried to configure the SSL to link with LinkPoint, it doesn't save my changes.

// Use secure webserver for checkout procedure?
define('ENABLE_SSL', 'false');

I am trying to change the "false" to "yes". But it gives me "fatal error or runtime error occured" message and doesn't save the changes.

Is this what is causing it?

I suggest you search for threads on this. I have not dealt with the problem but someone has.

If you don't get some helpful feedback I will PM someone that can likely help. In the meantime, maybe you can work on the content for your custom template and load a test product or two.

i can tell you that I installed and re-installed the cart multiple times at the beginning to get everything set right. I just kept messing something up. After that however, smooth sailing. So don't give up.

Good luck.

15 May 2006, 5:44 AM
#7
virtue avatar

virtue

New Zenner

Join Date:
May 2006
Posts:
58
Plugin Contributions:
0

Re: Need immediate Help!

Dear Bruce,

I appreciate your advice.

To answer you question:

Our webhosting company is: http://advancednetworkhosts.com/hosting.htm

Now, I don't know but my changes messed up the whole website. The whole site is down. I already emailed the webhosting company since we are now getting this error message:

Forbidden
You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

I know this is such a pain. :down:

Virtue

15 May 2006, 9:10 AM
#8
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Need immediate Help!

An item that you should check is the server name for your SSL in your configure.php file, if you are using a 'shared' SSL it most probably will not be 'yoursite.com'. Verify the SSL site & path and edit accordingly.

  * URLs for your site will be built via:  
   *     HTTP_SERVER plus DIR_WS_ADMIN or
   *     HTTPS_SERVER plus DIR_WS_HTTPS_ADMIN or 
   *     HTTP_SERVER plus DIR_WS_CATALOG or 
   *     HTTPS_SERVER plus DIR_WS_HTTPS_CATALOG
   * ...depending on your system configuration settings
   */
  define('HTTP_SERVER', 'http://yoursite.com');
  define('HTTPS_SERVER', 'https://yoursite.com');
  define('HTTP_CATALOG_SERVER', 'http://yoursite.com');
  define('HTTPS_CATALOG_SERVER', 'https://yoursite.com');

I am trying to change the "false" to "yes". But it gives me "fatal error or runtime error occured" message and doesn't save the changes.
What are you using to attempt this change? And maybe how are you trying to do this?

If you are attempting to use a file editor in like a cPanel location this could be a problem. Suggest that you use a FTP app and FTP the file to your PC, use notepad or an editor to make change > save and FTP back to your site.

Zen-Venom Get Bitten

15 May 2006, 10:16 PM
#9
virtue avatar

virtue

New Zenner

Join Date:
May 2006
Posts:
58
Plugin Contributions:
0

Re: Need immediate Help!

Dear Kobra,

Thank you for your help. I think you are right. I am using the cPanel to make the changes and that is probably the reason why I got the error.

I think see now why I am getting all these errors because everytime I make the changes I use the cPanel.

Thanks again.

Virtue

Virtue

15 May 2006, 10:44 PM
#10
kobra avatar

kobra

Black Belt

Join Date:
Aug 2005
Location:
Arizona
Posts:
31,500
Plugin Contributions:
4

Re: Need immediate Help!

First, did you determine your HTTPS server name? and get that sorted?

Second, I can't recall exactly what the problem with the cPanel editor is but as the code is very sensitive to characters, I think that this editor tends to add them at inappropriate spots causing errors.

There have been many posts eluding to that fact and I just passed this along to you as your post indicated that you were getting errors trying to edit a file and not being able to save...I know that if you were using an editor on your PC this would not happen. The downside is that you still can make an error in the coding, upload it and then receive an error trying to process your site. At least then you know what file you just changed.

Zen-Venom Get Bitten

16 May 2006, 8:59 PM
#11
virtue avatar

virtue

New Zenner

Join Date:
May 2006
Posts:
58
Plugin Contributions:
0

Re: Need immediate Help!

Yes, I was able to get the HTTPS straight. And now the shopping cart is back to normal.

My big headache again right now are:

  1. when I can make the LinkPoint API payment gateway function
  2. how to make the price converted from dollars to the choice of currency (cad, euro, gbp) the buyer make convert right.
  3. contact us doens't have a feature where we can add our company's address. It keeps on showing a blank info.

For the LinkPoint API, I got three errors everytime I make a test purchase after the credit card info and buyers info was entered. The error said that lphp.php is missing when I already have that installed. These errors appear right after I click the button checkout button to finish the transaction.:down: :down:

I added the LinkPoint module just where I can see the other modules for paypal, authorize.net, etc. I can now see it in the Admin being installed. But how come it doens't work? Did I install the module incorrectly? Where should I add the module properly? I certainly would appreciate your further assistance with these. I am really trying hard to make this cart work.

As for the currency, I noticed that it doens't put a right decimal point when it converts it.

I am sorry, I am such a pain here.

Thanks.

Virtue

Virtue

17 May 2006, 3:15 AM
#12
sermonzone avatar

sermonzone

Zen Follower

Join Date:
Oct 2005
Location:
New Mexico
Posts:
365
Plugin Contributions:
0

Re: Need immediate Help!

Virtue,

Have you done a search on 'Linkpoint API' and then read those threads? I got 145 matches on the topic. It seems likely that your answer is in one or more of them.

In my case, one of the reasons I chose my host is exactly the problem you are having. As a result, I have no problems.

No one thinks you are a pain. We all went through, are going through and/or will go through something that requires help. As long as you will be diligent in searching for answers for yourself, give clear details about the problem and be polite no one will be offended by your questions.

Don't give up. Good luck.

17 May 2006, 5:27 AM
#13
virtue avatar

virtue

New Zenner

Join Date:
May 2006
Posts:
58
Plugin Contributions:
0

Re: Need immediate Help!

Hello Sermonzone,

Thanks for your good encouragement! But good news. Finally, I was able to figure it out. Now I don't see those ugly :no: error messages everytime I try to do a test. However, my main concern again is that the test buy was not recorded in LinkPoint Central. Was it because it's in a test mode? I don't want to do the live test since if I am not that 200% sure that my connection is secured.

Any idea, why?

But I will not give up. Hope is there for those who persevere and have the patience.

Virtue

17 May 2006, 1:52 PM
#14
sermonzone avatar

sermonzone

Zen Follower

Join Date:
Oct 2005
Location:
New Mexico
Posts:
365
Plugin Contributions:
0

Re: Need immediate Help!

Virtue,

I am unable to help you with LinkPoint as I am not using it and it is beyond my understanding. The little help I am able to give beginning Zenners is point them on the right road to building templates on the right foundation.

My suggestions are -

  1. Search, search, search and then read, read, read.
  2. Post you linkpoint question in a thread like 'Payment modules' in the contribs section of the forum.
  3. Search, search, search and then read, read, read.
  4. Contact your host about security. Did they help you install the ssl?
  5. Search, search, search and then read, read, read.
  6. contact LinkPoint support.

Oops! I just took a peek at your site and when I click on a category it gives me an error message. You may not have the right permissions set for that folder.

Kuroi has a simple template built on CSS that will certainly help you. You used the /classic template which is 'backward' compatible. The Zen Masters have suggested that is not the best way to go unless an established site reqires it. Just a thought.

17 May 2006, 2:19 PM
#15
sermonzone avatar

sermonzone

Zen Follower

Join Date:
Oct 2005
Location:
New Mexico
Posts:
365
Plugin Contributions:
0

Re: Need immediate Help!

Also,

You probably should not ask the same question about linkpoint (or any topic) in multiple threads. It is frustrating to discover that you are answering a question that has been resoved in another place.

17 May 2006, 7:15 PM
#16
virtue avatar

virtue

New Zenner

Join Date:
May 2006
Posts:
58
Plugin Contributions:
0

Re: Need immediate Help!

Thank you Bruce!

My apology to everyone for posting the same question. I was able to get rid of some of the major errors and I already called the webhosting company. The tech support enabled the port and help me make the shopping cart secured.

Yeah, the shopping still look so backward looking. I am still trying to beautify it. I am not using the classic. I am trying to come up of something different. A combination of ideas from some other members that I have gathered here after reading their postings.

I also see some new free templates available with different stylesheet. I will download those and apply some of the good stuff.

Thank you for great help! I know your sermons are good always! I always learn something -- something indepth!:thumbsup: :thumbsup: :thumbsup:

Thanks.:wink2:

Virtue