Zen Cart Logo

Failed Opening

Locked

Views: 6,874

Results 1 to 14 of 14
This thread is locked. New replies are disabled.
16 May 2006, 12:48 AM
#1
dad47466 avatar

dad47466

New Zenner

Join Date:
May 2006
Posts:
3
Plugin Contributions:
0

Failed Opening

I just installed Zen-cart, changed permissions and 2 filenames as directed and set up the database.

When I run the install script, I get a blank screen and this entry in the error log:

PHP Fatal error: main(): Failed opening required 'includes/templates/template_default/common/html_header.php' (include_path='.:/usr/share/pear') in /var/www/vhosts/domain.com/httpdocs/store/zc_install/index.php on line 27

The "includes/templates/template_default/common/html_header.php" IS there, according to smartFTP, LeapFTP and the server's file manager.

I try to access the "includes/templates/template_default/common/html_header.php" file directly on my browser and I get a 403 message.

The server is running PHP 5.0

I'm at a loss, and open for suggestions.

16 May 2006, 5:20 AM
#2
nepton avatar

nepton

New Zenner

Join Date:
May 2006
Location:
USA
Posts:
40
Plugin Contributions:
0

Re: Failed Opening

I will offer you assistants, but due to the rules of no advertising on this forum all I can do is offer you a link to my web services site, Nepton Web Design.

-Nepton

16 May 2006, 7:05 AM
#3
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Failed Opening

Can you share a URL to your zc_install/techsupp.php file?

16 May 2006, 9:25 AM
#4
dad47466 avatar

dad47466

New Zenner

Join Date:
May 2006
Posts:
3
Plugin Contributions:
0

Re: Failed Opening

floralmemoriesandconcepts.com/store/zc_install/techsupp.php

16 May 2006, 1:01 PM
#5
theoracle avatar

theoracle

Suspended

Join Date:
Aug 2004
Posts:
3,180
Plugin Contributions:
1

Re: Failed Opening

So far, this is what I can see wrong here:

PHP Safe Mode= ON

It should definitely be set to OFF for PHP scripts saighs. ;)

16 May 2006, 7:51 PM
#7
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Failed Opening

weizguy:

I am having the same problem. But my safe mode is off. Here is the path to techsupp.php.

http://www.golfcarmidwest.com.weizguy.org/zencart/zc_oldinstall/techsupp.php

thanks in advance

Hmmm ... /home/weizguy is in /home/weizguy/public_html, so it shouldn't be reporting an error.... you're safe to proceed. If you're upgrading, proceed to Database-Upgrade.

16 May 2006, 7:57 PM
#8
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Failed Opening

dad47466:

I just installed Zen-cart, changed permissions and 2 filenames as directed and set up the database.

When I run the install script, I get a blank screen and this entry in the error log:

PHP Fatal error: main(): Failed opening required 'includes/templates/template_default/common/html_header.php' (include_path='.:/usr/share/pear') in /var/www/vhosts/domain.com/httpdocs/store/zc_install/index.php on line 27

The "includes/templates/template_default/common/html_header.php" IS there, according to smartFTP, LeapFTP and the server's file manager.

I try to access the "includes/templates/template_default/common/html_header.php" file directly on my browser and I get a 403 message.

The server is running PHP 5.0

I'm at a loss, and open for suggestions.

I'm guessing your server doesn't like the .htaccess settings for some reason.
Try TEMPORARILY renaming the .htaccess file in the /includes folder, and maybe also in the /zc_install folder

16 May 2006, 10:10 PM
#9
weizguy avatar

weizguy

New Zenner

Join Date:
May 2006
Posts:
5
Plugin Contributions:
0

Re: Failed Opening

Well, I tried temporarily renaming my .htaccess file and I am still getting the following error:

Fatal error: main(): Failed opening required '' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/weizguy/public_html/golfcarmidwest.com/zencart/includes/templates/template_default/templates/tpl_index_default.php on line 39

Here is line 39:

<div id="indexDefaultMainContent" class="content"><?php require($define_page); ?></div>

any other ideas?

16 May 2006, 10:31 PM
#10
weizguy avatar

weizguy

New Zenner

Join Date:
May 2006
Posts:
5
Plugin Contributions:
0

Re: Failed Opening

Nevermind, I figured it out :) I went through folder by folder and found a few files didn't get uploaded.

All is good now...

:oops:

16 May 2006, 11:19 PM
#11
dad47466 avatar

dad47466

New Zenner

Join Date:
May 2006
Posts:
3
Plugin Contributions:
0

Re: Failed Opening

Unfortunately, my problem is still remaining. Safe mode is off. .htaccess files have been removed and I'm still getting

PHP Fatal error: main(): Failed opening required 'includes/templates/template_default/common/html_header.php' (include_path='.:/usr/share/pear') in /var/www/vhosts/floralmemoriesandconcepts.com/httpdocs/store/zc_install/index.php on line 27

.htaccess files were returned, with no change.

Just for fun, I removed the line in the zc_install/index.php file that referenced the common/html_header.php file, and I got this error message

PHP Fatal error: main(): Failed opening required 'includes/templates/template_default/common/main_template_vars.php' (include_path='.:/usr/share/pear') in /var/www/vhosts/floralmemoriesandconcepts.com/httpdocs/store/zc_install/index.php on line 27

the vars file is the next in line after the header file.

I was thinking it might be a server problem, but the server says that there is nothing wrong at their end.

I have uploaded the cart once again and copied and pasted the configuration settings directly from the techsupp screen.

I have dozens of php files running on this server, and this cart is the only one causing me serious problems.

I'm about out of ideas.

16 May 2006, 11:28 PM
#12
weizguy avatar

weizguy

New Zenner

Join Date:
May 2006
Posts:
5
Plugin Contributions:
0

Re: Failed Opening

The problem I had was that I was missing quite a few files from the following directory:

includes/modules/pages/

once I completely uploaded them, my problem went away ::thumbsup:

16 May 2006, 11:29 PM
#13
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Failed Opening

Thanks for the update .... :smile:

19 May 2006, 5:34 AM
#14
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Failed Opening

dad47466:

(include_path='.:/usr/share/pear')
Technically, shouldn't that be ```
.;/usr/share/pear