Zen Cart Logo
Forums / Addon Shipping Modules / AUSTPost module

AUSTPost module

Locked

Views: 56,508

Results 161 to 180 of 321
This thread is locked. New replies are disabled.
8 Sep 2008, 1:04 PM
#161
snype avatar

snype

New Zenner

Join Date:
Mar 2008
Location:
Adelaide, SA
Posts:
32
Plugin Contributions:
0

AUSTPost module

Recently I downloaded the auspost model. It looks awesome and would solve so many of my shipping issues.

I had a little trouble installing it as there were a few sql issues.

Currently I can't seem to get it to work. I have V3.02 of the AUSpost mod.

I tested it and I got this error when trying to ship to Australia. I also get this error when shipping internationally.

'Sorry, we are not shipping to your region at this time.'

I tired adding all individual aus states to the zone definition but this does not work.

does anyone have any idea why this is not working. I followed all instructions and cannot figure out why.

:unsure:

9 Sep 2008, 9:54 AM
#162
jazzah avatar

jazzah

Zen Follower

Join Date:
Jun 2007
Posts:
104
Plugin Contributions:
0

Re: AUSTPost module

Hi, We use the fantastic Aust Post shipping module, but we want to also ship to New Zealand, I have searched on what I need to change, but am basically confused. Any help is appreciated! Thanks

9 Sep 2008, 10:08 AM
#163
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: AUSTPost module

Snype:

Recently I downloaded the auspost model. It looks awesome and would solve so many of my shipping issues.

I had a little trouble installing it as there were a few sql issues.

Currently I can't seem to get it to work. I have V3.02 of the AUSpost mod.

I tested it and I got this error when trying to ship to Australia. I also get this error when shipping internationally.

'Sorry, we are not shipping to your region at this time.'

I tired adding all individual aus states to the zone definition but this does not work.

does anyone have any idea why this is not working. I followed all instructions and cannot figure out why.

:unsure:

Try using the "Austpost Improved" module. The one that you downloaded hasn't been updated for a couple of years and may not be compatible with the latest versions of zencart.

Cheers
Rod

9 Sep 2008, 10:09 AM
#164
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: AUSTPost module

jazzah:

Hi, We use the fantastic Aust Post shipping module, but we want to also ship to New Zealand, I have searched on what I need to change, but am basically confused. Any help is appreciated! Thanks

Do you have the overseas parcel post option enabled?

Cheers
Rod

10 Sep 2008, 5:48 AM
#165
jazzah avatar

jazzah

Zen Follower

Join Date:
Jun 2007
Posts:
104
Plugin Contributions:
0

Re: AUSTPost module

Ok, we have done that! Thankyou but we only want to ship tp Australia and New Zealand, can you restrict that anywhere? I have had people email from who knows where! Thanks

10 Sep 2008, 11:35 AM
#166
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: AUSTPost module

jazzah:

Ok, we have done that! Thankyou but we only want to ship tp Australia and New Zealand, can you restrict that anywhere? I have had people email from who knows where! Thanks

This would normally be done via the 'zone' files, but since so many people originally had trouble setting these up simply to differentiate between 'Australia' and 'Not Australia' I found it easier (for all) to let the module do this automatically.

The downside being that it is no longer 'easy' for the end user to set up and use their own zone files for specific purposes, such as yours.

The easiest way to limit delivery to any given country is to simply remove it from the dropdown list. Alas, I have no idea where that code resides.

Cheers
Rod

12 Sep 2008, 2:04 AM
#167
beckinoz avatar

beckinoz

New Zenner

Join Date:
Aug 2006
Location:
Australia
Posts:
22
Plugin Contributions:
0

Re: AUSTPost module

Hi Rod,

I was using the Austpost module well until I changed to another provider (won't mention names but I made a huge mistake changing to them :( ).

Anyway, after I changed everything over the Austpost module has errors that for the life of me I can't figure out.

I uninstalled it and reinstalled but it still has the same errors when trying to checkout:

Warning: file() [function.file]: URL file-access is disabled in the server configuration in /var/virtual/web/w1248/html/shop/includes/modules/shipping/austpost.php on line 624

Warning: file(http://drc.edeliver.com.au/ratecalc.asp?Pickup_Postcode=3342&Destination_Postcode=3342&Country=AU&Weight=30&Service_Type=STANDARD&Height=50&Width=50&Length=80&Quantity=1) [function.file]: failed to open stream: no suitable wrapper could be found in /var/virtual/web/w1248/html/shop/includes/modules/shipping/austpost.php on line 624

Warning: file() [function.file]: URL file-access is disabled in the server configuration in /var/virtual/web/w1248/html/shop/includes/modules/shipping/austpost.php on line 624

Warning: file(http://drc.edeliver.com.au/ratecalc.asp?Pickup_Postcode=3342&Destination_Postcode=3342&Country=AU&Weight=30&Service_Type=EXPRESS&Height=50&Width=50&Length=80&Quantity=1) [function.file]: failed to open stream: no suitable wrapper could be found in /var/virtual/web/w1248/html/shop/includes/modules/shipping/austpost.php on line 624

When I go to line 624 it has this:

$myfile = file($url);

My website is:

http://www.craftyones.com.au/shop

I can't find any posts about this. This is the only shipping module I want to use as it worked the best for me.

Thanks

Beck

12 Sep 2008, 6:43 AM
#168
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: AUSTPost module

BeckInOz:

Hi Rod,

Anyway, after I changed everything over the Austpost module has errors that for the life of me I can't figure out.

Thanks

Beck

Under the Austpost settings you'll see something like this
"Use cURL
Try Setting this to Yes if you get server connection errors"

That should fix your problem,

Cheers
Rod

15 Sep 2008, 3:29 AM
#169
snype avatar

snype

New Zenner

Join Date:
Mar 2008
Location:
Adelaide, SA
Posts:
32
Plugin Contributions:
0

Re: AUSTPost module

RodG:

Try using the "Austpost Improved" module. The one that you downloaded hasn't been updated for a couple of years and may not be compatible with the latest versions of zencart.

Cheers
Rod

Thanks for the reply.

I tried as you suggested and recieved exactly the same error.

Sorry, we are not shipping to your region at this time.

In tpl_checkout_shipping_default.php this line seems to be the problem
if (zen_count_shipping_modules() > 0) {

However it is installed in the admin.

Can anyone point me in the right direction. I can't see why it will not work.

15 Sep 2008, 4:15 AM
#170
snype avatar

snype

New Zenner

Join Date:
Mar 2008
Location:
Adelaide, SA
Posts:
32
Plugin Contributions:
0

Re: AUSTPost module

Snype:

Thanks for the reply.

I tried as you suggested and recieved exactly the same error.

Sorry, we are not shipping to your region at this time.

In tpl_checkout_shipping_default.php this line seems to be the problem
if (zen_count_shipping_modules() > 0) {

However it is installed in the admin.

Can anyone point me in the right direction. I can't see why it will not work.

I digged a bit more and it seems to be a generic problem with my shipping.

I tracked the problem to the classes in the $GLOBALS arrays.
IE an auspost object is at $GLOBALS[austpost] however it's enabled values is null.

This is to case for all shipping methods I set. Their enable values is set to null, hence the system believes that they are not on.

I’m going to keep digging any help would be appreciated as Im not familiar with the shipping systems in zen cart

15 Sep 2008, 5:04 AM
#171
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: AUSTPost module

Snype:

Thanks for the reply.

I tried as you suggested and recieved exactly the same error.

Sorry, we are not shipping to your region at this time.

Curious.
This error message is only reported by the original austpost module by Gerard Serna.

The fact that you are still getting this tells me that you are not yet using the "Improved" version, therefore I can't offer any help until you change modules.

Cheers
RodG

15 Sep 2008, 5:34 AM
#172
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: AUSTPost module

Snype:

I tracked the problem to the classes in the $GLOBALS arrays.
IE an auspost object is at $GLOBALS[austpost] however it's enabled values is null.

I’m going to keep digging any help would be appreciated as Im not familiar with the shipping systems in zen cart

Although I can't say exactly what is causing your problem (regardless of which shipping module(s) you are using, I CAN say that you are treading very murky waters.
I wrote the Austpost Improved shipping module, and not even I had to concern myself with the $GLOBALS arrays to make things work.
I'd suggest that if you are having to delve into this part of the code you may be better off doing a fresh install and starting again.

Cheers
Rod

15 Sep 2008, 7:36 AM
#173
snype avatar

snype

New Zenner

Join Date:
Mar 2008
Location:
Adelaide, SA
Posts:
32
Plugin Contributions:
0

Re: AUSTPost module

Snype:

Thanks for the reply.

I tried as you suggested and recieved exactly the same error.

Sorry, we are not shipping to your region at this time.

In tpl_checkout_shipping_default.php this line seems to be the problem
if (zen_count_shipping_modules() > 0) {

However it is installed in the admin.

Can anyone point me in the right direction. I can't see why it will not work.

RodG:

Although I can't say exactly what is causing your problem (regardless of which shipping module(s) you are using, I CAN say that you are treading very murky waters.
I wrote the Austpost Improved shipping module, and not even I had to concern myself with the $GLOBALS arrays to make things work.
I'd suggest that if you are having to delve into this part of the code you may be better off doing a fresh install and starting again.

Cheers
Rod

Argh sorry I figured it out by tunnelling through the code and debugging it.

the reason why there were no shipping option is because the product I was testing with was set to free shipping. Hence no cost for shipping required.

Solved :clap:

Thanks for the help. Such a silly mistake.

16 Sep 2008, 1:09 AM
#174
beckinoz avatar

beckinoz

New Zenner

Join Date:
Aug 2006
Location:
Australia
Posts:
22
Plugin Contributions:
0

Re: AUSTPost module

RodG:

Under the Austpost settings you'll see something like this
"Use cURL
Try Setting this to Yes if you get server connection errors"

That should fix your problem,

Cheers
Rod

Thanks Rod for your reply.

I have changed this option before and it just comes up with new errors. I reinstalled the module and now I don't get this option in the Austpost settings.

What do you think the reason for this error is? Is it something to do with my host?

Thanks

Beck

16 Sep 2008, 1:22 AM
#175
beckinoz avatar

beckinoz

New Zenner

Join Date:
Aug 2006
Location:
Australia
Posts:
22
Plugin Contributions:
0

Re: AUSTPost module

One more thing I forgot to mention. If I continue on with step 1, step 2 comes up with the following errors and I can't continue on. It is just a blank screen.

Warning: file() [function.file]: URL file-access is disabled in the server configuration in /var/virtual/web/w1248/html/shop/includes/modules/shipping/austpost.php on line 624

Warning: file(http://drc.edeliver.com.au/ratecalc.asp?Pickup_Postcode=3342&Destination_Postcode=3342&Country=AU&Weight=30&Service_Type=STANDARD&Height=50&Width=50&Length=80&Quantity=1) [function.file]: failed to open stream: no suitable wrapper could be found in /var/virtual/web/w1248/html/shop/includes/modules/shipping/austpost.php on line 624

Warning: file() [function.file]: URL file-access is disabled in the server configuration in /var/virtual/web/w1248/html/shop/includes/modules/shipping/austpost.php on line 624

Warning: file(http://drc.edeliver.com.au/ratecalc.asp?Pickup_Postcode=3342&Destination_Postcode=3342&Country=AU&Weight=30&Service_Type=EXPRESS&Height=50&Width=50&Length=80&Quantity=1) [function.file]: failed to open stream: no suitable wrapper could be found in /var/virtual/web/w1248/html/shop/includes/modules/shipping/austpost.php on line 624

Warning: Cannot modify header information - headers already sent by (output started at /var/virtual/web/w1248/html/shop/includes/modules/shipping/austpost.php:624) in /var/virtual/web/w1248/html/shop/includes/functions/functions_general.php on line 44

16 Sep 2008, 8:24 AM
#176
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: AUSTPost module

BeckInOz:

Thanks Rod for your reply.

I have changed this option before and it just comes up with new errors. I reinstalled the module and now I don't get this option in the Austpost settings.

What do you think the reason for this error is? Is it something to do with my host?

Thanks

Beck

I know what your original error is/was (and told you what to do to fix it).

If you tell me what these 'new errors' are I may be able to tell you how to fix those too.

Yes, it does have something to do with your host.

Rgds
Rod

16 Sep 2008, 8:53 AM
#177
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: AUSTPost module

BeckInOz:

Warning: file() [function.file]: URL file-access is disabled in the server configuration

Warning: file() [function.file]: URL file-access is disabled in the server configuration

Just taking a wee stab in the dark here, but I'd say that there is something in your server configuration that has disabled the ability for you to use the URL file-access method (Don't you just hate these cryptic error messages) <grin>

Assuming you, like most others, have no way of reconfiguring your hosts servers, the Australia Post module has implemented an alternate method of URL access known as "cURL" (which is why I suggested you make that change).

cURL itself is unrelated to the AustPost module, but it is used for several aspects of zencarts operation, eg, for accepting PayPal payments.
cURL has its own configuration settings.

Some ISP's don't support cURL, but in my experience all ISP's support either one or the other of these two methods.
cURL is supposedly a little more secure than "file".

Anyway, the error message tells us that it is really pointless for you to continue to use the "file" method, so your only hope is to use cURL (which you'll need to configure to get rid of the 'new' errors).

Cheers
Rod

17 Sep 2008, 11:31 PM
#178
beckinoz avatar

beckinoz

New Zenner

Join Date:
Aug 2006
Location:
Australia
Posts:
22
Plugin Contributions:
0

Re: AUSTPost module

Thanks Rod,

I have completely removed the Austpost module and reinstalled it and it still won't even show the Curl Option in Admin>Shipping>Austpost.

Can I activate Curl if I edit the file perhaps? Otherwise I will just leave it on Table Rate until I change hosts again.

Thanks so much for your time.

Beck

18 Sep 2008, 1:22 PM
#179
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: AUSTPost module

BeckInOz:

Thanks Rod,

I have completely removed the Austpost module and reinstalled it

I never asked do to do that. If you can't or won't follow instructions it is rather pointless for me to try to help you.

BeckInOz:

and it still won't even show the Curl Option in Admin>Shipping>Austpost.

I'm now confused. What do you mean by "still won't" ?

Does that mean you have never seen this option, or that it was showing until you did the uninstall/reinstall ?

If you aren't seeing the cURL switch, what are the last FIVE configuration settings that you are seeing on the AustPost admin page?

Rgds
Rod

18 Sep 2008, 2:23 PM
#180
snype avatar

snype

New Zenner

Join Date:
Mar 2008
Location:
Adelaide, SA
Posts:
32
Plugin Contributions:
0

Re: AUSTPost module

I have a few issues again with my shipping system that I hope someone can help me with. I have the lastest version on zen cart with the auspost improved module.

For some reason the weight values seem to be calcualting incorrectly. I have set my toggle to grams, have 1 item in the cart and no extra handling fees. I ran some test data and here are my results.

weight = parcel shipping cost.
5 = 4.20
10 = 4.20
15 = 4.20
17 = 4.20
17.05 = 8.40
17.2 = 8.40
17.5 = 8.40
18.5 = 8.40
20 = 8.40
25 = 8.40
40 = 12.60
50 = 12.60

My understanding is that austpost charges $4.20 up to 250 grams and then 5.40 between 250 and 500 grams.

I do not understand where all these prices are coming from?

Also I have a tax issue. It's not really a problem with the aust shipping module so to speak. I do not have tax set on the shipping but I have set it on the products. I need to charge GST to australian customers.

When adding products the gross amount equals the net amount + 2xGST. IE 2 lots of gst get added. Also these are added to all customer australian and international. I have set my tax zone to for all austrlian zone. The duel gst amount can clearly be seen adding twice in the payment information screen.

Can anyone point me in the right direction or have any ideas? Im stuck.

Also is it possible to display the auspost prices in US dollars. My clients for some reason wants all values to be in amerian. Just wondering if it's possible.