Zen Cart Logo
Forums / General Questions / exceeded the 'max_questions' resource Error

exceeded the 'max_questions' resource Error

Locked

Views: 2,129

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
24 May 2006, 2:28 PM
#1
busybuds avatar

busybuds

New Zenner

Join Date:
Jan 2006
Location:
PA
Posts:
26
Plugin Contributions:
0

exceeded the 'max_questions' resource Error

1226 User 'busybuds' has exceeded the 'max_questions' resource (current value: 50000)

This is the error I had, the host manually reset so my site is back up but I want to fix the problem before it happens again.

I spoke with the host and he said that I either have too much traffic (not that...I wish it was), a connection is not resetting or I should set up multiple users (up to 5) since they each have a value of 50000.

Can anyone help me with this?

Warning: Not a programmer, so please layman's terms.

Thanks,

Linda McVeigh

28 May 2006, 2:44 AM
#2
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: exceeded the 'max_questions' resource Error

Do you have an URL we can peek at?

Who are you hosting with?

28 May 2006, 7:17 PM
#3
busybuds avatar

busybuds

New Zenner

Join Date:
Jan 2006
Location:
PA
Posts:
26
Plugin Contributions:
0

Re: exceeded the 'max_questions' resource Error

Right now the my site is working but it is https://www.busybuds.com and my host is ipowerweb.

I called the host and they said that I can have 5 users with up to 50000 queries each and that I should alternate users. Not sure how to do that but I did check out the OsCommerce site and found that someone posted what is below between the lines. I tried this and was getting errors so went back to the way it was.

It sounded like what the tech at Ipowerweb said but it didn't work for me.

Would really appreciate help in keeping this error from shutting my site down temporarily.

Thanks,

Linda McVeigh


DO NOT USE CODE BELOW AS IT IS NOT A FIX - CAUSES ERRORS

replace:

CODE
define('DB_SERVER_USERNAME', 'your_username');

with:
CODE
$db_user_array[] = "your_username"; //enter 1st user name
$db_user_array[] = "your_username_1"; //enter 2nd user name
$db_user_array[] = "your_username_2"; //enter 3rd user name
$db_user_array[] = "your_username_3"; //enter 4th user name
$db_user_array[] = "your_username_4"; //enter 5th user name

//defined variable
define( 'DB_SERVER_USERNAME', $db_user_array[ rand( 0, ( sizeof($db_user_array) -1 ) ) ] );

// define('DB_SERVER_USERNAME', 'your_username');

create 4 new db users in your control panel your_username_1, your_username_2, your_username_3, your_username_4 assign them to your database with the same password as the original.

edit includes/configure.php and replace the same line.

This removes the problem by sharing the queries across 4 extra users.