Zen Cart Logo
Forums / General Questions / Done something awful to admin/configure.php!

Done something awful to admin/configure.php!

Locked

Views: 1,367

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
2 Jun 2006, 1:44 PM
#1
high2k avatar

high2k

Zen Follower

Join Date:
May 2006
Location:
Scotland
Posts:
198
Plugin Contributions:
0

Done something awful to admin/configure.php!

I've really messed-up and have done something awful to admin/configure.php as I am now getting the following error message when trying to access admin:

Warning: main(/includes/autoload_func.php): failed to open stream: No such file or directory in /home/961/kentmusic/www.kentmusictechnology.co.uk/public_html/catalog/admin/includes/application_top.php on line 145

Warning: main(/includes/autoload_func.php): failed to open stream: No such file or directory in /home/961/kentmusic/www.kentmusictechnology.co.uk/public_html/catalog/admin/includes/application_top.php on line 145

Fatal error: main(): Failed opening required '/includes/autoload_func.php' (include_path='.:/usr/local/lib/php') in /home/961/kentmusic/www.kentmusictechnology.co.uk/public_html/catalog/admin/includes/application_top.php on line 145

I tried re-uploading a clean version of admin/configure.php but to no avail. Is there some way that I can reinstall the whole admin folder without losing the information in my store so far?

2 Jun 2006, 1:52 PM
#2
vger avatar

vger

Past Contributor

Join Date:
Nov 2004
Location:
Norfolk, United Kingdom
Posts:
3,189
Plugin Contributions:
0

Re: Done something awful to admin/configure.php!

If your admin/includes/configure.php file was write protected then you may have thought you uploaded another file over the top of it without actually doing so.

Upload the new file and then click to View it in the right hand side of your FTP programme - that'll tell you if it has been changed or not.

Vger

2 Jun 2006, 1:54 PM
#3
high2k avatar

high2k

Zen Follower

Join Date:
May 2006
Location:
Scotland
Posts:
198
Plugin Contributions:
0

Re: Done something awful to admin/configure.php!

No. I deleted the old one before uploading the updated version. I know - really stupid not to have backed-up...
Can I reinstall my entire admin directory afresh? Would this be the solution?

2 Jun 2006, 2:10 PM
#4
high2k avatar

high2k

Zen Follower

Join Date:
May 2006
Location:
Scotland
Posts:
198
Plugin Contributions:
0

Re: Done something awful to admin/configure.php!

It's OK. I fixed it. I had an incorrect path in admin/configure.php - I had define```
('DIR_WS_ADMIN', '/admin/');

instead of

define('DIR_WS_ADMIN', '/catalog/admin/');


Panic over. Phew!
2 Jun 2006, 2:28 PM
#5
merlinpa1969 avatar

merlinpa1969

Totally Zenned

Join Date:
Mar 2004
Posts:
13,031
Plugin Contributions:
4

Re: Done something awful to admin/configure.php!

thanks for posting the fix