Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Errors after move my zencart system from OS Windows to LInux

Errors after move my zencart system from OS Windows to LInux

Locked

Views: 5,014

Results 1 to 9 of 9
This thread is locked. New replies are disabled.
6 Jun 2006, 6:51 AM
#1
bianbian avatar

bianbian

New Zenner

Join Date:
Jun 2006
Posts:
10
Plugin Contributions:
0

Errors after move my zencart system from OS Windows to LInux

Hi,I have a zencart system which is alredi installed and modify in OS Windows and it can be show properly.
Now, I have to move my zencart system to Linux.
So, I export my zencart database and import to Linux by using phpmyadmin and also move all my zencart files to Linux under location at /srv/www.
But when i go to http://localhost/cart with browser firefox,
it show me errors as below:

Warning: main(includes/configure.php): failed to open stream: No such file or directory in /srv/www/cart/includes/application_top.php on line 37

Warning: main(): Failed opening 'includes/configure.php' for inclusion (include_path='/usr/share/php') in /srv/www/cart/includes/application_top.php on line 37

Warning: Cannot modify header information - headers already sent by (output started at /srv/www/cart/includes/application_top.php:37) in /srv/www/cart/includes/application_top.php on line 52

Below about my server and zencart information:

zencart : v12.7
mysql : v4.1.13
phpmyadmin : v2.6.4
apache : Apache/2.0.54 (Linux/SUSE)
OS system: linux 2.6.13-15-default #1

Thanks for help =)

6 Jun 2006, 7:54 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Errors after move my zencart system from OS Windows to LInux

I suspect you've missed setting the right information in your includes/configure.php and admin/includes/configure.php files to match your server's configuration.

There are some FAQ's on this topic:
http://www.zen-cart.com/forum/faq.php?faq=server#faq_offline_then_live

7 Jun 2006, 1:09 AM
#3
bianbian avatar

bianbian

New Zenner

Join Date:
Jun 2006
Posts:
10
Plugin Contributions:
0

Re: Errors after move my zencart system from OS Windows to LInux

Thanks for reply.
I have make some checks but I can't find any things wrong in both configuration files.:no:
Below is my includes/configure.php

<?php // Define the webserver and path parameters // Main webserver: eg, <http://localhost> - should not be empty for productive servers define('HTTP_SERVER', 'http://localhost'); // Secure webserver: eg, <https://localhost> - should not be empty for productive servers define('HTTPS_SERVER', 'https://localhost'); // secure webserver for checkout procedure? define('ENABLE_SSL', 'false'); // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes! // * DIR_WS_* = Webserver directories (virtual/URL) // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder) define('DIR_WS_CATALOG', '/cart/'); define('DIR_WS_HTTPS_CATALOG', '/cart/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/'); define('DIR_WS_BLOCKS', DIR_WS_INCLUDES . 'blocks/'); define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/'); define('DIR_WS_PHPBB', '/'); // * DIR_FS_* = Filesystem directories (local/physical) //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/ # define('DIR_FS_CATALOG', 'c:/appserv/www/cart/'); define('DIR_FS_CATALOG', '/srv/www/cart/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/'); define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS); define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/'); // define our database connection define('DB_TYPE', 'mysql'); define('DB_PREFIX', ''); define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty define('DB_SERVER_USERNAME', 'root'); define('DB_SERVER_PASSWORD', ''); define('DB_DATABASE', 'zencart'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', 'db'); // leave empty '' for default handler or set to 'db' // The next 2 "defines" are for SQL cache support. // For SQL_CACHE_METHOD, you can select from: none, database, or file // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder // ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash define('SQL_CACHE_METHOD', 'none'); # define('DIR_FS_SQL_CACHE', 'c:/appserv/www/cart/cache'); define('DIR_FS_SQL_CACHE', '/srv/www/cart/cache'); ?>

And this is my admin/includes/configure.php

<?php // Define the webserver and path parameters // Main webserver: eg, <http://localhost> - should not be empty for productive servers define('HTTP_SERVER', 'http://localhost'); // Secure webserver: eg, <https://localhost> - should not be empty for productive servers define('HTTPS_SERVER', 'https://localhost'); // eg, <https://localhost> define('HTTP_CATALOG_SERVER', 'http://localhost'); define('HTTPS_CATALOG_SERVER', 'https://localhost'); // secure webserver for catalog module and/or admin areas? define('ENABLE_SSL_CATALOG', 'false'); define('ENABLE_SSL_ADMIN', 'false'); // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes! // * DIR_WS_* = Webserver directories (virtual/URL) // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder) define('DIR_WS_ADMIN', '/cart/admin/'); define('DIR_WS_CATALOG', '/cart/'); define('DIR_WS_HTTPS_ADMIN', '/cart/admin/'); define('DIR_WS_HTTPS_CATALOG', '/cart/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_CATALOG_IMAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'images/'); define('DIR_WS_CATALOG_TEMPLATE', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/templates/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_CATALOG_LANGUAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/languages/'); define('DIR_WS_BLOCKS', DIR_WS_INCLUDES . 'blocks/'); // * DIR_FS_* = Filesystem directories (local/physical) //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/ define('DIR_FS_ADMIN', '/srv/www/cart/admin/'); define('DIR_FS_CATALOG', '/srv/www/cart/'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_CATALOG_TEMPLATES', DIR_FS_CATALOG . 'includes/templates/'); define('DIR_FS_CATALOG_BLOCKS', DIR_FS_CATALOG . 'includes/blocks/'); define('DIR_FS_CATALOG_BOXES', DIR_FS_CATALOG . 'includes/boxes/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/'); define('DIR_FS_FILE_MANAGER_ROOT', '/srv/www/cart'); // path to starting directory of the file manager // define our database connection define('DB_TYPE', 'mysql'); define('DB_PREFIX', ''); define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty define('DB_SERVER_USERNAME', 'root'); define('DB_SERVER_PASSWORD', ''); define('DB_DATABASE', 'zencart'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', 'db'); // leave empty '' for default handler or set to 'db' // The next 2 "defines" are for SQL cache support. // For SQL_CACHE_METHOD, you can select from: none, database, or file // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder // ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash define('SQL_CACHE_METHOD', 'none'); define('DIR_FS_SQL_CACHE', '/srv/www/cart/cache'); ?>

Anyone knows what's the problems?

Thanks for your help.

7 Jun 2006, 1:14 AM
#4
bianbian avatar

bianbian

New Zenner

Join Date:
Jun 2006
Posts:
10
Plugin Contributions:
0

Re: Errors after move my zencart system from OS Windows to LInux

After that, I try to download a new zencart and install in Linux,
But it also fail to install and it show me some messages as below,

Warning: main(version.php): failed to open stream: No such file or directory in /srv/www/zen-cart-v1.3.0.1-full-fileset/zc_install/includes/application_top.php on line 25

Fatal error: main(): Failed opening required 'version.php' (include_path='/usr/share/php') in /srv/www/zen-cart-v1.3.0.1-full-fileset/zc_install/includes/application_top.php on line 25

Actually the file (version.php) exist.

Any ideas?

7 Jun 2006, 2:37 AM
#5
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Errors after move my zencart system from OS Windows to LInux

Do you have control over your php.ini file?

If so, can you edit the "include_path" setting? .... it appears that it needs to have the following added to it (to the beginning of the line):.:or for Windows hosts:```
.;


Reference thread:
<http://www.zen-cart.com/forum/showpost.php?p=210324&postcount=12>
8 Jun 2006, 12:55 AM
#6
bianbian avatar

bianbian

New Zenner

Join Date:
Jun 2006
Posts:
10
Plugin Contributions:
0

Re: Errors after move my zencart system from OS Windows to LInux

;;;;;;;;;;;;;;;;;;;;;;;;;
; Paths and Directories ;
;;;;;;;;;;;;;;;;;;;;;;;;;

; UNIX: "/path1:/path2"
include_path = ".:/php/includes"

;include_path = ".:/usr/share/php"

; Windows: "\path1;\path2"
;include_path = ".;c:\php\includes"

This is what I have modified in php.ini,
but it still show me same errors.
Any mistake inf my setting???

Thanks

8 Jun 2006, 1:07 AM
#7
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Errors after move my zencart system from OS Windows to LInux

what you've posted here looks like it should be fine.

Is the error message still the EXACT same ?

8 Jun 2006, 1:14 AM
#8
bianbian avatar

bianbian

New Zenner

Join Date:
Jun 2006
Posts:
10
Plugin Contributions:
0

Re: Errors after move my zencart system from OS Windows to LInux

yes, exactly same....

8 Jun 2006, 1:29 AM
#9
bianbian avatar

bianbian

New Zenner

Join Date:
Jun 2006
Posts:
10
Plugin Contributions:
0

Re: Errors after move my zencart system from OS Windows to LInux

After restart the pc, it become blank page already, didn't show any error messages.:bored: