Zen Cart Logo
Forums / Built-in Shipping and Payment Modules / Shipping Estimator to another country

Shipping Estimator to another country

Locked

Views: 2,295

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
11 Jun 2006, 4:50 AM
#1
danmcguire avatar

danmcguire

New Zenner

Join Date:
Jun 2004
Location:
Eagle Creek, OR USA
Posts:
46
Plugin Contributions:
0

Shipping Estimator to another country

Trying to solve a small issue with Estimate Shipping Costs. When shipping from the US to another country and not inputing a postal code, we get this response above the shipping estimates:

Warning: strpos(): Empty delimiter. in /home/httpd/vhosts/mydomain.com/httpdocs/store/includes/modules/shipping/ups.php on line 423

Ups is only enabled for domestic, not foreign. Put any random numbers at all in the postal code spot, the error goes away.

Thanks,

dan

Fresh install with imported, updated database.

Zen Cart 1.3.0.1
Database Patch Level: 1.3.0.1

Server OS: Linux 2.4.21-40.ELsmp
Database: MySQL 4.0.24
PHP Version: 4.3.11 (Zend: 1.3.0)
HTTP Server: Apache/2.0.46 (Red Hat)

11 Jun 2006, 5:14 PM
#2
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Shipping Estimator to another country

Could you post some examples where you are getting this error to occure?

11 Jun 2006, 8:06 PM
#3
danmcguire avatar

danmcguire

New Zenner

Join Date:
Jun 2004
Location:
Eagle Creek, OR USA
Posts:
46
Plugin Contributions:
0

Re: Shipping Estimator to another country

Hi Ajeh,

Thank you for your reply. I have discovered that the problem appears to reside in the UPS Delivery Area Surcharge mod. It took awhile to discover this [till about an hour ago.] I tested the mod for various zip codes and cross checked with ups online prices and we were good to go. Subsequently, I activated/configured the zone shipping module. This was to allow us to use the USPS Flat Rate box, without someone trying to ship 80lbs in it, or 6lbs to Japan. [Has happenned enough times to be a bother.] Having never used the zone shipping module, I spent a lot of time focused on it. So back tracking involved installing and uninstalling both ups and zone till the error disappeared and reappeared.

So now all is better. Zones work for our purpose. Some might consider our use of it a bit of a hack, but it certainly works well enough. We will redirect our UPS Delivery Area Surcharge issues to Dennis [stagebrace] and see if he can find the error of our ways.

Thanks again -- am really enjoying 1.3
Sorry for the long epistle.

dan