New site owners very often are frightened of the words 'phpMyAdmin' but there's really no need to be. phpMyAdmin is there to make manipulating your database as easy as any other task you carry out on your website. I won't try and teach you here how to carry out things via MySQL console using command line stuff, but will keep it simple with phpMyAdmin.
So unless you wish to keep paying through the nose to get your hosts to do everything related to your database for you, follow these steps:
-
The database is around 3Mb, so chunk it up into three separate files. Open the backup file in Text Pad, highlight about a third of it and elect to 'Copy' the highlighted code. Make sure that what you copy ends on a complete ine (don't stop in the middle of a line).
-
Create a new text file and Paste that code into it.
-
Do the same with the next two thirds of the file, and you'll now have three text files all about 1Mb each which can be run into a blank database without coming up against either the file size limit or the time limit to execute.
-
Access the database you set up using phpMyAdmin, and where you see the list of tables that are in there - tick them all and then elect to drop them.
-
Next locate the SQL or Import tab in the top middle of the phpMyAdmin page. Use the Browse function to locate the first of the three text files you created. Then click the Go button. Hopefully the contents of that file should be inserted and you'll get a message which says it has been successful. Do the same with the other two files (in order), and hopefully all of your backup will now have been inserted into the new (blank) database.
Normally I'd tell people to backup their database before doing this, but if you are still getting the error that 'the configuration table does not exist' then that database isn't working anyway.
If all this goes well and you still get the error then this is caused by the backup you took not being complete.
Vger