Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Older version 1.2.6

Older version 1.2.6

Locked

Views: 2,050

Results 1 to 4 of 4
This thread is locked. New replies are disabled.
22 Jun 2006, 3:53 PM
#1
eltel78 avatar

eltel78

New Zenner

Join Date:
Nov 2005
Location:
Wigan, UK
Posts:
50
Plugin Contributions:
0

Older version 1.2.6

For the time being I am using older versions of this cart for reason that I have templates designed around them that wont work in the newer version 1.3. So please bare in mind I am wanting to use it.

The problem I have with my new site is that I have come up with a few errors on my homepage, they are as follows:

Warning: main(searchactivity/searchbot.php): failed to open stream: No such file or directory in /path/to/hosting/includes/templates/hipctech_lite/common/tpl_footer.php on line 137

Warning: main(): Failed opening 'searchactivity/searchbot.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /path/to/hosting/includes/templates/hipctech_lite/common/tpl_footer.php on line 137

As you can see, I am using the old hiptech lite template that I have modified and its coming up with this error. I have installed it fine on another website with no problems.

What could be causing it?

Thank you and regards
Terry

22 Jun 2006, 4:18 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Older version 1.2.6

ElTel78:

Warning: main(searchactivity/searchbot.php): failed to open stream: No such file or directory in /path/to/hosting/includes/templates/hipctech_lite/common/tpl_footer.php on line 137

Terry,

The error message indicates that on line 137 of your hipctech tpl_footer.php file there is a call to a file named "searchbot.php" which it's expecting to find in a folder named "searchactivity". Neither of these is part of the core Zen Cart files, regardless of version.

If you didn't put that there, and nobody else touching your site would have done so, then you should check to see whether someone has gotten into your site's files on the server and maybe hacked other junk into things too.

That said, a quick search on Google suggests that "searchbot.php" may be a mambo/joomla-related file.
Or else it came from here: http://scripts.ringsworld.com/search-engines/searchactivity

22 Jun 2006, 4:26 PM
#3
eltel78 avatar

eltel78

New Zenner

Join Date:
Nov 2005
Location:
Wigan, UK
Posts:
50
Plugin Contributions:
0

Re: Older version 1.2.6

Yeah, its okay. I found the code I needed to remove.

Also, I want to change the image pixel size on the sub-category page but had a look though the control panel and couldn't find the current sizes (I think was 43 x 70 pixels).

Is this something I need to change in one of the templates?

Thanks for the reply.

Terry

22 Jun 2006, 4:30 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Older version 1.2.6

If you haven't modified the functions that generate images, then you can edit the settings in Admin->Configuration->Images