Zen Cart Logo
Forums / Templates, Stylesheets, Page Layout / define pages and CHMOD not cooperating

define pages and CHMOD not cooperating

Locked

Views: 1,726

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
29 Jun 2006, 2:15 AM
#1
justwade avatar

justwade

Zen Follower

Join Date:
Oct 2005
Posts:
206
Plugin Contributions:
0

define pages and CHMOD not cooperating

1.27d

I am trying to set up security on my hope to be live soon site.

I went to /includes/languages/english/html_includes and CHMOD (the permissions) from 777 to 644, (the whole html_includes and everything inside.)

After doing this, on the website, the defineable text pages gives a warning such as below;

Warning: main(includes/languages/english/html_includes/define_main_page.php): failed to open stream: No such file or directory in /home/#######/public_html/catalog/includes/templates/template_default/templates/tpl_index_default.php on line 42

Warning: main(includes/languages/english/html_includes/define_main_page.php): failed to open stream: No such file or directory in /home/#######/public_html/catalog/includes/templates/template_default/templates/tpl_index_default.php on line 42

Warning: main(includes/languages/english/html_includes/define_main_page.php): failed to open stream: No such file or directory in /home/#######/public_html/catalog/includes/templates/template_default/templates/tpl_index_default.php on line 42

Fatal error: main(): Failed opening required 'includes/languages/english/html_includes/define_main_page.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/#######/public_html/catalog/includes/templates/template_default/templates/tpl_index_default.php on line 42

If I "only CHMOD my_template" folder to 644, then the default text will come up ok.

Could someone please explain to me how I can secure the difine pages with a 644 permission?

1.27d version

Justwade
Zen 1.5.5f
Zen 1.3.9h*, Zen 1.27 + (did that, done with that)*

29 Jun 2006, 6:01 AM
#2
justwade avatar

justwade

Zen Follower

Join Date:
Oct 2005
Posts:
206
Plugin Contributions:
0

Re: define pages and CHMOD not cooperating

I been doing some experimenting and found-

If you CHMOD your "my_template" directory as 644, it will not load the edited text as per my prior post.

But you can CHMOD 644 all the define pages files "in" the directory. I CHMOD all define pages as 644 including those in classic and default for security overkill, but left all the directories as 777.

Appears to work OK, if I left a security hole out there, please, someone let me know.

Justwade
Zen 1.5.5f
Zen 1.3.9h*, Zen 1.27 + (did that, done with that)*

29 Jun 2006, 6:13 AM
#3
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: define pages and CHMOD not cooperating

Typical secure settings are:

directories at 755
files at 644

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

29 Jun 2006, 6:24 AM
#4
justwade avatar

justwade

Zen Follower

Join Date:
Oct 2005
Posts:
206
Plugin Contributions:
0

Re: define pages and CHMOD not cooperating

Thank you DrByte,

Fixed all those directories to 755. I's lerned somethin nuuw tooday.

Justwade
Zen 1.5.5f
Zen 1.3.9h*, Zen 1.27 + (did that, done with that)*

29 Jun 2006, 6:50 AM
#5
seethrou avatar

seethrou

Totally Zenned

Join Date:
May 2004
Location:
Hong Kong
Posts:
1,156
Plugin Contributions:
0

Re: define pages and CHMOD not cooperating

Some background had given from Ajeh in other thread. :smile:

edititing define pages problems from admin

.

A New Starter again