Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Error: The requested URL /index.php was not found on this server.

Error: The requested URL /index.php was not found on this server.

Locked

Views: 55,035

Results 1 to 6 of 6
This thread is locked. New replies are disabled.
5 Jul 2006, 3:46 PM
#1
etoile03 avatar

etoile03

Zen Follower

Join Date:
Jun 2006
Posts:
123
Plugin Contributions:
0

Error: The requested URL /index.php was not found on this server.

I have installed zencart on domain.com/zencart directory. But, I get the following error whenever I try to access my login, tell a friend, and reviews page.

The requested URL /index.php was not found on this server.

Can anyone help?

5 Jul 2006, 4:23 PM
#2
vger avatar

vger

Past Contributor

Join Date:
Nov 2004
Location:
Norfolk, United Kingdom
Posts:
3,189
Plugin Contributions:
0

Re: Error: The requested URL /index.php was not found on this server.

This will happen if you enabled ssl when installing - without having an ssl cert for yourt website. The solution, set enable_ssl to false in both configure.php files.

Vger

5 Jul 2006, 4:47 PM
#3
etoile03 avatar

etoile03

Zen Follower

Join Date:
Jun 2006
Posts:
123
Plugin Contributions:
0

Re: Error: The requested URL /index.php was not found on this server.

Thanks for your quick reply. I have them set to False already... But, I think that my customer login gets redirected to the root directory instead of the /zencart directory when I try to click on customer login. But, I'm not sure why I can't access the reviews or tell a friend links under the product pages. Here are both my configure files:

define('HTTP_SERVER', 'http://byjeannie.com');
define('HTTPS_SERVER', 'https://byjeannie.com/zencart');
define('HTTP_CATALOG_SERVER', 'http://byjeannie.com');
define('HTTPS_CATALOG_SERVER', 'https://byjeannie.com/zencart');

define('ENABLE_SSL_CATALOG', 'false');
define('ENABLE_SSL_ADMIN', 'false');

define('DIR_WS_ADMIN', '/zencart/admin/');
define('DIR_WS_CATALOG', '/zencart/');
define('DIR_WS_HTTPS_ADMIN', '/admin/');
define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
define('DIR_WS_CATALOG_IMAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'images/');
define('DIR_WS_CATALOG_TEMPLATE', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/templates/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
define('DIR_WS_CATALOG_LANGUAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_ADMIN', '/hsphere/local/home/foto2art/byjeannie.com/zencart/admin/');
define('DIR_FS_CATALOG', '/hsphere/local/home/foto2art/byjeannie.com/zencart/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
define('DIR_FS_CATALOG_TEMPLATES', DIR_FS_CATALOG . 'includes/templates/');
define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');
define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DB_TYPE', 'mysql');
define('DB_PREFIX', 'xxxxx');
define('DB_SERVER', 'xxxx'); // eg, localhost - should not be empty
define('DB_SERVER_USERNAME', 'xxxxx');
define('DB_SERVER_PASSWORD', 'xxxxx');
define('DB_DATABASE', 'xxxxx');
define('USE_PCONNECT', 'false'); // use persistent connections?
define('STORE_SESSIONS', 'db'); // leave empty '' for default handler or set to 'db'

define('SQL_CACHE_METHOD', 'none');
define('DIR_FS_SQL_CACHE', '/hsphere/local/home/foto2art/byjeannie.com/zencart/cache');


define('HTTP_SERVER', 'http://byjeannie.com');
define('HTTPS_SERVER', 'https://byjeannie.com/zencart');

define('ENABLE_SSL', 'false');

define('DIR_WS_CATALOG', '/zencart/');
define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');
define('DIR_WS_INCLUDES', 'includes/');
define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');
define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/');

define('DIR_WS_PHPBB', '/');

define('DIR_FS_CATALOG', '/hsphere/local/home/foto2art/byjeannie.com/zencart/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');
define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/');
define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS);
define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');

define('DB_TYPE', 'mysql');
define('DB_PREFIX', 'xxxxx');
define('DB_SERVER', 'xxxxx'); // eg, localhost - should not be empty
define('DB_SERVER_USERNAME', 'xxxxx');
define('DB_SERVER_PASSWORD', 'xxxxx');
define('DB_DATABASE', 'xxxxx');
define('USE_PCONNECT', 'false'); // use persistent connections?
define('STORE_SESSIONS', 'db'); // leave empty '' for default handler or set to 'db'

define('SQL_CACHE_METHOD', 'none');
define('DIR_FS_SQL_CACHE', '/hsphere/local/home/foto2art/byjeannie.com/zencart/cache');

5 Jul 2006, 4:52 PM
#4
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Error: The requested URL /index.php was not found on this server.

A few errors here that will stop your site cold:

define('HTTP_SERVER', 'http://byjeannie.com');
define('HTTPS_SERVER', 'https://byjeannie.com/zencart');
define('HTTP_CATALOG_SERVER', 'http://byjeannie.com');
define('HTTPS_CATALOG_SERVER', 'https://byjeannie.com/zencart');

Should read:

define('HTTP_SERVER', 'http://byjeannie.com');
define('HTTPS_SERVER', 'https://byjeannie.com');
define('HTTP_CATALOG_SERVER', 'http://byjeannie.com');
define('HTTPS_CATALOG_SERVER', 'https://byjeannie.com');

These settings:

define('DIR_WS_ADMIN', '/zencart/admin/');
define('DIR_WS_CATALOG', '/zencart/');
define('DIR_WS_HTTPS_ADMIN', '/admin/');
define('DIR_WS_HTTPS_CATALOG', '/');

Should read:

define('DIR_WS_ADMIN', '/zencart/admin/');
define('DIR_WS_CATALOG', '/zencart/');
define('DIR_WS_HTTPS_ADMIN', '/zencart/admin/');
define('DIR_WS_HTTPS_CATALOG', '/zencart/');

See if those don't help get you on the right track with the 2 files ...

5 Jul 2006, 7:09 PM
#5
etoile03 avatar

etoile03

Zen Follower

Join Date:
Jun 2006
Posts:
123
Plugin Contributions:
0

Re: Error: The requested URL /index.php was not found on this server.

Thanks for your help! It works now!

6 Jul 2006, 3:28 AM
#6
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: Error: The requested URL /index.php was not found on this server.

Thanks for the update ... glad you got your configure.php files straightened out ... :smile:

Don't you hate when those things listen to what we tell them and not what we meant? :eek: