Zen Cart Logo
Forums / Installing on a Windows Server / mysql problems....I want to give up!

mysql problems....I want to give up!

Locked

Views: 3,373

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
3 Aug 2006, 2:15 AM
#1
scoutj avatar

scoutj

New Zenner

Join Date:
Jun 2006
Posts:
71
Plugin Contributions:
0

mysql problems....I want to give up!

I almost wish I had just left things alone but of course I got the bright idea to get my shop its own domain name and now I can't get through the re-installation of everything.

my working shop is this:
http://www.scoutsswag.scoutj.com

my new domain shop is:
http://www.scoutsswag.com

Yes I was able to install the cart on the new domain.

I have read the instructions over and over to get the database from my old shop to the new one and it's giving me this error:

Error

SQL query:

-- phpMyAdmin SQL Dump
-- version 2.8.0.3
-- http://www.phpmyadmin.net

-- Host: scoutswag.scoutj.com
-- Generation Time: Aug 02, 2006 at 09:04 AM
-- Server version: 5.0.18
-- PHP Version: 4.4.2

-- Database: information_schema

CREATE DATABASE information_schema DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;

MySQL said: Documentation
#1044 - Access denied for user 'scoutj'@'208.113.128.0/255.255.224.0' to database 'information_schema'

I am not very knowledgeable with the whole mysql stuff. Anyone have any idea? Please help! I have almost 150 customers I would like to be able to switch over!

3 Aug 2006, 4:49 AM
#2
dbltoe avatar

dbltoe

Totally Zenned

Join Date:
Jan 2004
Location:
N of San Antonio TX
Posts:
9,799
Plugin Contributions:
15

Re: mysql problems....I want to give up!

Your database is looking for the correct password for user scoutj on the database. If this is the user you have declared in your configure.php files, you need to give the database the password for scoutj that you put in the configure.php files.

3 Aug 2006, 5:10 AM
#3
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: mysql problems....I want to give up!

On lines 11 and 12 of your .SQL backup file, you see these:```
CREATE DATABASE information_schema ......;
USE information_schema;


Either remove them or put a # in front of both of them. Then re-attempt to import the file.


The problem stems from the fact that your hosting company doesn't let .SQL scripts create databases... instead, it gives you a more secure way to create and select databases and do imports into them. 
Simply removing those 2 lines from the file should be enough.... provided there are no compatibility problems between MySQL versions on old and new servers.