Zen Cart Logo
Forums / General Questions / Admin page is gone

Admin page is gone

Locked

Views: 1,165

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
15 Aug 2006, 12:08 AM
#1
shqipo avatar

shqipo

New Zenner

Join Date:
Apr 2006
Posts:
94
Plugin Contributions:
0

Admin page is gone

I'm not sure what happened. Last time I was working on it (10 days ago) it was working fine. Now when I try to go to admin site it gives me this error:

Warning: main(DIR_FS_CATALOG_LANGUAGESenglish/meta_tags.php): failed to open stream: No such file or directory in /home/totaltra/public_html/store/admin/includes/languages/english.php on line 63

Warning: main(DIR_FS_CATALOG_LANGUAGESenglish/meta_tags.php): failed to open stream: No such file or directory in /home/totaltra/public_html/store/admin/includes/languages/english.php on line 63

Warning: main(DIR_FS_CATALOG_LANGUAGESenglish/meta_tags.php): failed to open stream: No such file or directory in /home/totaltra/public_html/store/admin/includes/languages/english.php on line 63

Fatal error: main(): Failed opening required 'DIR_FS_CATALOG_LANGUAGESenglish/meta_tags.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/totaltra/public_html/store/admin/includes/languages/english.php on line 63

Any help would be greatly appreciated.

15 Aug 2006, 12:30 AM
#2
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,650
Plugin Contributions:
0

Re: Admin page is gone

Please post your admin/includes/configure.php without your password.

Please do not PM for support issues: a private solution doesn't benefit the community.

Be careful with unsolicited advice via email or PM - Make sure the person you are talking to is a reliable source.

15 Aug 2006, 1:37 AM
#3
shqipo avatar

shqipo

New Zenner

Join Date:
Apr 2006
Posts:
94
Plugin Contributions:
0

Re: Admin page is gone

<?php /** * * @package Configuration Settings * @copyright Copyright 2003-2006 Zen Cart Development Team * @copyright Portions Copyright 2003 osCommerce * @license <http://www.zen-cart.com/license/2_0.txt> GNU Public License V2.0 */ // Define the webserver and path parameters // HTTP_SERVER is your Main webserver: eg, <http://www.yourdomain.com> // HTTPS_SERVER is your Secure webserver: eg, <https://www.yourdomain.com> define('HTTP_SERVER', 'http://totaltrailerparts.com'); define('HTTPS_SERVER', 'https://totaltrailerparts.com'); // Use secure webserver for checkout procedure? define('ENABLE_SSL', 'true'); // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes! // * DIR_WS_* = Webserver directories (virtual/URL) // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder) define('DIR_WS_CATALOG', '/store/'); define('DIR_WS_HTTPS_CATALOG', '/store/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/'); define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/'); define('DIR_WS_PHPBB', '/'); // * DIR_FS_* = Filesystem directories (local/physical) //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/ define('DIR_FS_CATALOG', '/home/totaltra/public_html/store/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/'); define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS); define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/'); // define our database connection define('DB_TYPE', 'mysql'); define('DB_PREFIX', 'zen_'); define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty define('DB_SERVER_USERNAME', ''); define('DB_SERVER_PASSWORD', ''); define('DB_DATABASE', ''); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', 'db'); // leave empty '' for default handler or set to 'db' // The next 2 "defines" are for SQL cache support. // For SQL_CACHE_METHOD, you can select from: none, database, or file // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder // ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash define('SQL_CACHE_METHOD', 'database'); define('DIR_FS_SQL_CACHE', '/home/totaltra/public_html/store/cache'); ?>
15 Aug 2006, 1:51 AM
#4
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,650
Plugin Contributions:
0

Re: Admin page is gone

Uh- are you sure you have the right file? That is includes/configure.php NOT admin/includes/configure.php

Please do not PM for support issues: a private solution doesn't benefit the community.

Be careful with unsolicited advice via email or PM - Make sure the person you are talking to is a reliable source.

15 Aug 2006, 2:05 AM
#5
shqipo avatar

shqipo

New Zenner

Join Date:
Apr 2006
Posts:
94
Plugin Contributions:
0

Re: Admin page is gone

Hm... I must have done something stupid. Well, the one I showed here was the right file - but I had placed the wrong one in that folder :(

I just FTP-ed the right one from my backup and it's working now. whew! Thanks!