Zen Cart Logo
Forums / Templates, Stylesheets, Page Layout / PHP error in log file after install

PHP error in log file after install

Locked

Views: 1,131

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
23 Aug 2006, 11:08 PM
#1
flame avatar

flame

New Zenner

Join Date:
Aug 2006
Posts:
15
Plugin Contributions:
0

PHP error in log file after install

I moved a Zen cart to a new server after never using zen-cart before and it seems to be working fine. However this morning I discovered that there it a log file (/error_log) that is 14MB in size. I have checked the file and discovered the recurring error

PHP Warning: Zend Optimizer for PHP 4.4.x cannot be found (expected at '/usr/local/Zend/lib/Optimizer-2.5.7/php.4.4.x/ZendOptimizer.so') - try reinstalling the Zend Optimizer in Unknown on line 0

I have checked back at the sites old location and this problem didn't seem to be happening there. I have searched google but not found any zen-cart related information.

Zen cart is currently version 1.2.5
PHP is version 4.4.1

How can I clear this error?

23 Aug 2006, 11:24 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: PHP error in log file after install

Zen Cart and Zend Optimizer are completely different things.

Zend Optimizer is a PHP plugin that your host would install and maintain.
Zen Cart is unrelated.

23 Aug 2006, 11:42 PM
#3
flame avatar

flame

New Zenner

Join Date:
Aug 2006
Posts:
15
Plugin Contributions:
0

Re: PHP error in log file after install

OK, I understand that they are different but I was unsure why it was coming up. Is the Zen Cart attempting to do something that the version of ZendOptimizer cannot do? I guess it is possible that other PHP scripts on the server are creating the same error but maybe not reporting it.

If the error is no big deal, how would I stop Zen-cart from logging the error and filling up the HDD?

23 Aug 2006, 11:46 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: PHP error in log file after install

Zen Cart does nothing to specifically use any features of Zend Optimizer.

Some other software is likely trying to use it to decrypt PHP code in another application and thus filling your log file.

How to fix it? Talk to your host and report the problem.
Either they need to fix the problem, or you need to remove the other software you've installed that's using it.

24 Aug 2006, 1:58 AM
#5
flame avatar

flame

New Zenner

Join Date:
Aug 2006
Posts:
15
Plugin Contributions:
0

Re: PHP error in log file after install

Thanks DrByte.

I think I have solved the problem. Zen-Cart is the only application that is installed on the server (for this domain). Also, the file is actually located at /admin/error_log and this error was occuring at the last host. Sorry for the misinformation.

What I have found though is the file /admin/php.ini with a line that reads

error_log = error_log

I guess this is where the file is being written from. The file is being written between every 1 and 10 seconds. I guess everytime someone accesses the site (PHP is running as CGI for security reasons).

I am going to comment the line out. At least for now.

Thanks again.