Zen Cart Logo
Forums / Installing on a Linux/Unix Server / English Flag for catalog Admin works fine

English Flag for catalog Admin works fine

Locked

Views: 7,708

Results 1 to 20 of 28
This thread is locked. New replies are disabled.
24 Aug 2006, 7:09 AM
#1
visualdeath avatar

visualdeath

New Zenner

Join Date:
Aug 2006
Posts:
14
Plugin Contributions:
0

English Flag for catalog Admin works fine

I am getting the english flag for the display of my catalog. The admin pannel works fine. I have tried to check everything the one problem I have run into is in the install but I can not figure out how to get the error fixed. The error I get on install is as follows:
PHP open_basedir restrictions = /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp
I have read and seached the forum tring to find a solution and have check and rechecked both confirure files. Can someone please help me.

24 Aug 2006, 7:18 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: English Flag for catalog Admin works fine

On the home page of the installer (zc_install), what version is stated in the Welcome message?

24 Aug 2006, 7:19 AM
#3
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: English Flag for catalog Admin works fine

VisualDeath:

I am getting the english flag for the display of my catalog. The admin pannel works fine.
I don't understand what you're seeing.

24 Aug 2006, 7:28 AM
#4
visualdeath avatar

visualdeath

New Zenner

Join Date:
Aug 2006
Posts:
14
Plugin Contributions:
0

Re: English Flag for catalog Admin works fine

On the install it says v1.3.0.1

After install when I try to go the catalog all i get is a english flag on the top left corner and that is it. Nothing else displays the admin panel works fine. The install works fine, but catalog does not do anything but show a flag.

24 Aug 2006, 7:29 AM
#5
visualdeath avatar

visualdeath

New Zenner

Join Date:
Aug 2006
Posts:
14
Plugin Contributions:
0

Re: English Flag for catalog Admin works fine

and view source is disabled for some reason. The error that I posted is the only thing on the install - system inspection. I dont know what the error means and have not been able to find out why it wants that directory anyway.

24 Aug 2006, 7:34 AM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: English Flag for catalog Admin works fine

v1.3.0.2 fixed an error in the installer that was reporting the basedir restrictions as problematic even when they were not.

v1.3.0.2 also fixes a number of other bugs.

I recommend that you grab the latest version and install it before going any further. Link is on the "downloads" page, accessible by button on top of this screen.

Once installed, apply the security patch instructions I posted in the "Announcements" area of the forum.

24 Aug 2006, 7:35 AM
#7
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: English Flag for catalog Admin works fine

I suspect some of the reason for problems in your catalog is incomplete uploads of files caused by your FTP program.

If you're not using FileZilla, I might encourage you to grab it, esp since it's free and reliable: http://filezilla.sf.net

24 Aug 2006, 7:50 AM
#8
visualdeath avatar

visualdeath

New Zenner

Join Date:
Aug 2006
Posts:
14
Plugin Contributions:
0

Re: English Flag for catalog Admin works fine

I am using cuteftp 7.1 pro and i have made the changes that you posted and updates to 1.3.0.2 and still have the same problem I have never had a problem with my ftp program before and I thought is was a good one. Is it not good?

24 Aug 2006, 7:56 AM
#9
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: English Flag for catalog Admin works fine

Who knows. Some have reported that after switching to filezilla things worked better. I personally do not recommend either SmartFTP or CuteFTP.

Anyway, this may or may not be related to FTP programs.

But it may be that you have incomplete uploads.

At the very least, since it appears you're just starting out, at least grab the newer version and proceed from there.

24 Aug 2006, 8:25 AM
#10
visualdeath avatar

visualdeath

New Zenner

Join Date:
Aug 2006
Posts:
14
Plugin Contributions:
0

Re: English Flag for catalog Admin works fine

I downloaded fileZilla and now I just have a blank page. The PHP open_basedir restrictions = /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp has now become a warning and is no longer in the system - inspection results. It is now in the other system information box.

24 Aug 2006, 8:33 AM
#11
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: English Flag for catalog Admin works fine

what is the URL to your zc_install folder?

25 Aug 2006, 12:42 AM
#13
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: English Flag for catalog Admin works fine

The basedir issue shouldn't be affecting you.

So, why the blank pages?

I think you'll need to go to your hosting control panel and look at your site's errorlog. It should tell you about things happening to cause the blank screen. Perhaps it's a permissions problem or unwanted statements in .htaccess files etc.

If you can't find access to your errorlog, contact your host.

25 Aug 2006, 4:35 AM
#14
visualdeath avatar

visualdeath

New Zenner

Join Date:
Aug 2006
Posts:
14
Plugin Contributions:
0

Re: English Flag for catalog Admin works fine

[Thu Aug 17 00:16:02 2006] [error] [client 65.188.33.65] Directory index forbidden by rule: /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/ 
[Thu Aug 17 00:16:42 2006] [error] [client 65.188.33.65] Directory index forbidden by rule: /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/ 
[Thu Aug 17 02:32:21 2006] [error] PHP Warning: main(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:21 2006] [error] PHP Warning: main(/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php): failed to open stream: Operation not permitted in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:21 2006] [error] PHP Warning: main(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:21 2006] [error] PHP Warning: main(/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php): failed to open stream: Operation not permitted in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:21 2006] [error] PHP Warning: main(): Failed opening '/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php' for inclusion (include_path='.:/usr/share/pear') in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:21 2006] [error] PHP Warning: main(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/includes/classes/class.notifier.php) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:21 2006] [error] PHP Warning: main(/home/visualdeath/ss.visualpcs.com/includes/classes/class.notifier.php): failed to open stream: Operation not permitted in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:21 2006] [error] PHP Warning: main(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/includes/classes/class.notifier.php) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:21 2006] [error] PHP Warning: main(/home/visualdeath/ss.visualpcs.com/includes/classes/class.notifier.php): failed to open stream: Operation not permitted in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:21 2006] [error] PHP Warning: main(): Failed opening '/home/visualdeath/ss.visualpcs.com/includes/classes/class.notifier.php' for inclusion (include_path='.:/usr/share/pear') in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:21 2006] [error] PHP Fatal error: Cannot instantiate non-existent class: notifier in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 78 
[Thu Aug 17 02:32:21 2006] [error] [client 65.188.33.65] File does not exist: /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/zc_install 
[Thu Aug 17 02:32:34 2006] [error] PHP Warning: main(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:34 2006] [error] PHP Warning: main(/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php): failed to open stream: Operation not permitted in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:34 2006] [error] PHP Warning: main(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:34 2006] [error] PHP Warning: main(/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php): failed to open stream: Operation not permitted in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:34 2006] [error] PHP Warning: main(): Failed opening '/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php' for inclusion (include_path='.:/usr/share/pear') in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:34 2006] [error] PHP Warning: main(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/includes/classes/class.notifier.php) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:34 2006] [error] PHP Warning: main(/home/visualdeath/ss.visualpcs.com/includes/classes/class.notifier.php): failed to open stream: Operation not permitted in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:34 2006] [error] PHP Warning: main(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/includes/classes/class.notifier.php) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:34 2006] [error] PHP Warning: main(/home/visualdeath/ss.visualpcs.com/includes/classes/class.notifier.php): failed to open stream: Operation not permitted in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:34 2006] [error] PHP Warning: main(): Failed opening '/home/visualdeath/ss.visualpcs.com/includes/classes/class.notifier.php' for inclusion (include_path='.:/usr/share/pear') in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Thu Aug 17 02:32:34 2006] [error] PHP Fatal error: Cannot instantiate non-existent class: notifier in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 78 
[Thu Aug 17 02:32:35 2006] [error] [client 65.188.33.65] File does not exist: /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/zc_install, referer: [url]http://test.siliconsolutions.com/zc_install/index.php[/url] 
[Thu Aug 17 02:34:00 2006] [error] [client 65.188.33.65] File does not exist: /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/zc_install 
[Thu Aug 17 02:34:01 2006] [error] [client 65.188.33.65] File does not exist: /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/zc_install 
[Wed Aug 23 03:20:16 2006] [error] PHP Warning: main(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Wed Aug 23 03:20:16 2006] [error] PHP Warning: main(/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php): failed to open stream: Operation not permitted in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Wed Aug 23 03:20:16 2006] [error] PHP Warning: main(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Wed Aug 23 03:20:16 2006] [error] PHP Warning: main(/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php): failed to open stream: Operation not permitted in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Wed Aug 23 03:20:16 2006] [error] PHP Warning: main(): Failed opening '/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php' for inclusion (include_path='.:/usr/share/pear') in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Wed Aug 23 03:20:16 2006] [error] PHP Warning: main(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/includes/classes/class.notifier.php) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Wed Aug 23 03:20:16 2006] [error] PHP Warning: main(/home/visualdeath/ss.visualpcs.com/includes/classes/class.notifier.php): failed to open stream: Operation not permitted in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Wed Aug 23 03:20:16 2006] [error] PHP Warning: main(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/includes/classes/class.notifier.php) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Wed Aug 23 03:20:16 2006] [error] PHP Warning: main(/home/visualdeath/ss.visualpcs.com/includes/classes/class.notifier.php): failed to open stream: Operation not permitted in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Wed Aug 23 03:20:16 2006] [error] PHP Warning: main(): Failed opening '/home/visualdeath/ss.visualpcs.com/includes/classes/class.notifier.php' for inclusion (include_path='.:/usr/share/pear') in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59 
[Wed Aug 23 03:20:16 2006] [error] PHP Fatal error: Cannot instantiate non-existent class: notifier in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 78 
[Wed Aug 23 03:48:27 2006] [error] PHP Warning: session_save_path(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/cache) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/functions/sessions.php on line 143 
[Wed Aug 23 03:48:57 2006] [error] [client 65.188.33.65] File does not exist: /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/favicon.ico 
[Wed Aug 23 03:48:57 2006] [error] PHP Warning: session_save_path(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/cache) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/functions/sessions.php on line 143 
[Wed Aug 23 03:49:06 2006] [error] PHP Warning: session_save_path(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/cache) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/functions/sessions.php on line 143 
[Wed Aug 23 03:49:09 2006] [error] PHP Warning: session_save_path(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/cache) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/functions/sessions.php on line 143 
[Wed Aug 23 03:49:22 2006] [error] PHP Warning: session_save_path(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/cache) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/functions/sessions.php on line 143 
[Wed Aug 23 03:49:53 2006] [error] PHP Warning: session_save_path(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/cache) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/functions/sessions.php on line 143
25 Aug 2006, 6:39 AM
#15
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: English Flag for catalog Admin works fine

[Thu Aug 17 02:32:21 2006] [error] PHP Warning: main(): open_basedir restriction in effect. File(/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php) is not within the allowed path(s): (/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs:/tmp) in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59
[Thu Aug 17 02:32:21 2006] [error] PHP Warning: main(/home/visualdeath/ss.visualpcs.com/includes/classes/class.base.php): failed to open stream: Operation not permitted in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/includes/autoload_func.php on line 59

Please post the contents of your /includes/configure.php file here, without passwords.

25 Aug 2006, 7:10 AM
#16
visualdeath avatar

visualdeath

New Zenner

Join Date:
Aug 2006
Posts:
14
Plugin Contributions:
0

Re: English Flag for catalog Admin works fine

Catalog configure

// Define the webserver and path parameters
  // HTTP_SERVER is your Main webserver: eg, http://www.yourdomain.com
  // HTTPS_SERVER is your Secure webserver: eg, https://www.yourdomain.com
  define('HTTP_SERVER', 'http://test.siliconsolutions.com');
  define('HTTPS_SERVER', 'https://test.siliconsolutions.com');

  // Use secure webserver for checkout procedure?
  define('ENABLE_SSL', 'false');

// NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
// * DIR_WS_* = Webserver directories (virtual/URL)
  // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
  define('DIR_WS_CATALOG', '/');
  define('DIR_WS_HTTPS_CATALOG', '/');

  define('DIR_WS_IMAGES', 'images/');
  define('DIR_WS_INCLUDES', 'includes/');
  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
  define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');
  define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/');

  define('DIR_WS_PHPBB', '/');

// * DIR_FS_* = Filesystem directories (local/physical)
  //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/
  define('DIR_FS_CATALOG', '/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/');

  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');
  define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/');
  define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS);
  define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');

// define our database connection
  define('DB_TYPE', 'mysql');
  define('DB_PREFIX', '');
  define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty
  define('DB_SERVER_USERNAME', '');
  define('DB_SERVER_PASSWORD', '');
  define('DB_DATABASE', '');
  define('USE_PCONNECT', 'false'); // use persistent connections?
  define('STORE_SESSIONS', 'db'); // leave empty '' for default handler or set to 'db'

  // The next 2 "defines" are for SQL cache support.
  // For SQL_CACHE_METHOD, you can select from:  none, database, or file
  // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache 
  // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder
  // ie: /path/to/your/webspace/public_html/zen/cache   -- leave no trailing slash  
  define('SQL_CACHE_METHOD', 'none'); 
  define('DIR_FS_SQL_CACHE', '/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/cache');

admin

// Define the webserver and path parameters
  // Main webserver: eg, http://localhost - should not be empty for productive servers
  // HTTP_SERVER is your Main webserver: eg, http://www.yourdomain.com
  // HTTPS_SERVER is your Secure webserver: eg, https://www.yourdomain.com
  // HTTP_CATALOG_SERVER is your Main webserver: eg, http://www.yourdomain.com
  // HTTPS_CATALOG_SERVER is your Secure webserver: eg, https://www.yourdomain.com
  /* 
   * URLs for your site will be built via:  
   *     HTTP_SERVER plus DIR_WS_ADMIN or
   *     HTTPS_SERVER plus DIR_WS_HTTPS_ADMIN or 
   *     HTTP_SERVER plus DIR_WS_CATALOG or 
   *     HTTPS_SERVER plus DIR_WS_HTTPS_CATALOG
   * ...depending on your system configuration settings
   */
  define('HTTP_SERVER', 'http://test.siliconsolutions.com');
  define('HTTPS_SERVER', 'https://test.siliconsolutions.com');
  define('HTTP_CATALOG_SERVER', 'http://test.siliconsolutions.com');
  define('HTTPS_CATALOG_SERVER', 'https://test.siliconsolutions.com');

  // Use secure webserver for catalog module and/or admin areas?
  define('ENABLE_SSL_CATALOG', 'false');
  define('ENABLE_SSL_ADMIN', 'false');

// NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
// * DIR_WS_* = Webserver directories (virtual/URL)
  // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
  define('DIR_WS_ADMIN', '/admin/');
  define('DIR_WS_CATALOG', '/');
  define('DIR_WS_HTTPS_ADMIN', '/admin/');
  define('DIR_WS_HTTPS_CATALOG', '/');

  define('DIR_WS_IMAGES', 'images/');
  define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
  define('DIR_WS_CATALOG_IMAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'images/');
  define('DIR_WS_CATALOG_TEMPLATE', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/templates/');
  define('DIR_WS_INCLUDES', 'includes/');
  define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
  define('DIR_WS_CATALOG_LANGUAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/languages/');

// * DIR_FS_* = Filesystem directories (local/physical)
  //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/
  define('DIR_FS_ADMIN', '/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/admin/');
  define('DIR_FS_CATALOG', '/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/');

  define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
  define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
  define('DIR_FS_CATALOG_TEMPLATES', DIR_FS_CATALOG . 'includes/templates/');
  define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
  define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');
  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

// define our database connection
  define('DB_TYPE', 'mysql');
  define('DB_PREFIX', '');
  define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty
  define('DB_SERVER_USERNAME', '');
  define('DB_SERVER_PASSWORD', '');
  define('DB_DATABASE', '');
  define('USE_PCONNECT', 'false'); // use persistent connections?
  define('STORE_SESSIONS', 'db'); // leave empty '' for default handler or set to 'db'

  // The next 2 "defines" are for SQL cache support.
  // For SQL_CACHE_METHOD, you can select from:  none, database, or file
  // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache 
  // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder
  // ie: /path/to/your/webspace/public_html/zen/cache   -- leave no trailing slash  
  define('SQL_CACHE_METHOD', 'none'); 
  define('DIR_FS_SQL_CACHE', '/home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/cache');
25 Aug 2006, 7:28 AM
#17
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: English Flag for catalog Admin works fine

Does this have any meaning to you:

/home/visualdeath/ss.visualpcs.com/

For some reason your server is picking that up even though Zen Cart (running in your subdomain) is not asking for it.

I'm guessing your subdomain configuration in your hosting account is causing you some problems. What does your host have to say about it?

25 Aug 2006, 7:37 AM
#18
visualdeath avatar

visualdeath

New Zenner

Join Date:
Aug 2006
Posts:
14
Plugin Contributions:
0

Re: English Flag for catalog Admin works fine

I have not been able to contact them yet. When I do contact them what should I talk/ask them about?

25 Aug 2006, 7:48 AM
#19
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: English Flag for catalog Admin works fine

my posts 15 & 17 in this thread.

Can you try installing without using a subdomain?

What is "ss.visualpcs.com" in relation to you?

25 Aug 2006, 7:51 AM
#20
visualdeath avatar

visualdeath

New Zenner

Join Date:
Aug 2006
Posts:
14
Plugin Contributions:
0

Re: English Flag for catalog Admin works fine

it was on another host where it was installed. I have moved over to this server and it will not work. On the old server it had a one click install for zen cart. After you pointed that out to me i decided to do a fresh install and try one more time before i contact the hosting company. I did a fresh install but used the database from the old server.