Zen Cart Logo
Forums / Installing on a Linux/Unix Server / English Flag for catalog Admin works fine

English Flag for catalog Admin works fine

Locked

Views: 7,708

Results 21 to 28 of 28
This thread is locked. New replies are disabled.
25 Aug 2006, 8:44 AM
#21
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

English Flag for catalog Admin works fine

If you do a fresh install and do not use your old database yet, do things work properly (without your real data, naturally)?

This server-move guide may be of some help:
http://www.zen-cart.com/wiki/index.php/Server_Admin_-_Switch_Servers

25 Aug 2006, 8:47 AM
#22
visualdeath avatar

visualdeath

New Zenner

Join Date:
Aug 2006
Posts:
14
Plugin Contributions:
0

Re: English Flag for catalog Admin works fine

Ok I did the fresh install and now the admin panel is not working. It has the top bar with the links and such but nothing else shows up even if I make a selection. The catalog will show left boxes, and top but will not show the products or the right boxes

[Fri Aug 25 04:47:57 2006] [error] PHP Fatal error: Call to a member function on a non-object in /home/httpd/vhosts/siliconsolutions.com/subdomains/test/httpdocs/admin/includes/boxes/extras_dhtml.php on line 17
25 Aug 2006, 9:14 AM
#23
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: English Flag for catalog Admin works fine

That suggests again a failed FTP upload of this folder:
/admin/includes/boxes/extra_boxes

or maybe a file-permissions problem preventing the webserver from reading that folder if it exists.

27 Aug 2006, 1:54 AM
#24
visualdeath avatar

visualdeath

New Zenner

Join Date:
Aug 2006
Posts:
14
Plugin Contributions:
0

Re: English Flag for catalog Admin works fine

I upload it will filezilla like you told me to do and it sill has the same problem.

27 Aug 2006, 3:37 AM
#25
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: English Flag for catalog Admin works fine

Are you seeing the "same" error message in the errorlog but with updated date/time?

I'm sad to see that you're having such difficulty getting this to work; however, it seems that something is awry with your server's configuration ... either with respect to security, or in relation to how it treats files uploaded to it. Very bizarre.

27 Aug 2006, 4:10 AM
#26
visualdeath avatar

visualdeath

New Zenner

Join Date:
Aug 2006
Posts:
14
Plugin Contributions:
0

Re: English Flag for catalog Admin works fine

Well I uploaded it with filezilla the first time is what I ment to say.

27 Aug 2006, 4:20 AM
#27
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: English Flag for catalog Admin works fine

Your admin login screen appears to be fine. Of course, I can't log in to test anything there. But the screen is appearing to be functional.

The store area however seems to have some problems with displaying the main content area, stopping after displaying only the bottom of the left set of sideboxes. It would suggest that you have some bad or missing files for your sidebox templates, or for your page templates ... in your case, namely the "includes/templates/classic/templates" and "includes/templates/classic/sideboxes" files ... or perhaps even the /includes/modules/ files.

A clue as to "which" file might come from finding out in Admin->Tools->layout boxes what box is enabled after the "more information" box. On a fresh install, this is the "banners" sidebox. So, /includes/modules/sideboxes/banner_box.php may be bad, or the template for it may be bad ... includes/templates/template_default/sideboxes/tpl_banner_box.php (I mention template_default because it appears you've not customized anything yet, so won't have an override for that file yet).

27 Aug 2006, 6:54 AM
#28
visualdeath avatar

visualdeath

New Zenner

Join Date:
Aug 2006
Posts:
14
Plugin Contributions:
0

Re: English Flag for catalog Admin works fine

OK I have got it working now. Thanks for all your help.