Forums / Setting Up Categories, Products, Attributes / 403 Forbidden error when updating product

403 Forbidden error when updating product

Sticky Locked

Views: 54,499

Results 21 to 29 of 29
This thread is locked. New replies are disabled.
18 Sep 2008, 2:59 PM
#21
thehypo avatar

thehypo

Zen Follower

Join Date:
Jan 2006
Posts:
109
Plugin Contributions:
0

403 Forbidden error when updating product

Verdict came back from tech support... "This was due to a problem with the way Apache works on this server. I've corrected it..."

Yeah, when they admit it's their fault, all of a sudden they are far less specific... I'm going to see if I can get any more information, but whatever "it" was, it's fixed.

18 Sep 2008, 3:38 PM
#22
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: 403 Forbidden error when updating product

It would seem that the problems were due to incorrect paths being used. Probably due to a previous and recent change or software upgrade by your Hoster, since the problems started without any changes by yourself.

Would also seem your Hoster created the problems and presumably, they have now corrected them. If all is well once again then that is good.

The learning is in the doing.

Potent Products

27 Sep 2008, 12:13 PM
#23
tuschris avatar

tuschris

New Zenner

Join Date:
Sep 2008
Posts:
9
Plugin Contributions:
0

Re: 403 Forbidden error when updating product

How do I get to the ".htaccess file?
I am getting this message when I try to add a product.

The webpage cannot be found
HTTP 404
Most likely causes:
There might be a typing error in the address.
If you clicked on a link, it may be out of date.

What you can try:
Retype the address.

 Go back to the previous page. 

 Go to  and look for the information you want.  

 More information 

This error (HTTP 404 Not Found) means that Internet Explorer was able to connect to the website, but the page you wanted was not found. It's possible that the webpage is temporarily unavailable. Alternatively, the website might have changed or removed the webpage.

For more information about HTTP errors, see Help.

31 May 2010, 7:13 PM
#24
scatzc avatar

scatzc

New Zenner

Join Date:
Sep 2009
Posts:
79
Plugin Contributions:
0

Re: 403 Forbidden error when updating product

TheHYPO:

Verdict came back from tech support... "This was due to a problem with the way Apache works on this server. I've corrected it..."

Yeah, when they admit it's their fault, all of a sudden they are far less specific... I'm going to see if I can get any more information, but whatever "it" was, it's fixed.
Same thing here, today. Unfortunately, DrByte's excellent suggestion no longer works so I need to wait for webhost's support to answer the ticket I opened.

But in the webhost support forum, they already admitted that they have been experimenting with some mod_security rules... this is a production server, business account... Unbelievable.

13 Oct 2010, 8:56 AM
#25
dalesvp avatar

dalesvp

New Zenner

Join Date:
Oct 2010
Posts:
9
Plugin Contributions:
0

Re: 403 Forbidden error when updating product

DrByte:

I suspect your server may have a mod_security setting active which is trying to protect against the use of any "reserved words".

Yesterday I began getting the forbidden access message while entering a new product. I suspected a word filter someplace as I've seen this before on a wiki. In posting the same new product as little information as possible was used to get the record started and saved. Then, updating the record, adding in the rest of the information one sentence at a time until the message reappeared - which it did on this sentence:

There are hundreds of selected quotes from the Cayce materials too.

All the sentences before and after the above words were accepted without error. I do not understand why any of these words would trigger or trip a filter. Anyone got any ideas?

13 Oct 2010, 8:59 AM
#26
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: 403 Forbidden error when updating product

The word "SELECT" is commonly used in attempted SQL Injections. Maybe the mod_security rules are flagging that?

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

15 Oct 2010, 8:27 PM
#27
challenger avatar

challenger

New Zenner

Join Date:
Oct 2010
Posts:
1
Plugin Contributions:
0

Re: 403 Forbidden error when updating product

It is very strange but i also have the 403 Forbidden error when updating product, appeared yesterday...
And Dr Byte's solution doesn't seem to work for me :cry:

21 Oct 2010, 8:47 AM
#28
carilivia avatar

carilivia

New Zenner

Join Date:
Dec 2006
Posts:
32
Plugin Contributions:
0

Re: 403 Forbidden error when updating product

I was having this same problem! Sporadically on different websites when I tried to update an ezpage or product listing....it would error out. After trying several things and talking to website hosting support. I figured out that the word SELECT or SELECTION was indeed the culprit! When I deleted those words....it would update correctly when added back in, the error page.

I sent off the problem to support and hopefully it will all get fixed up now!

Many thanks to Dr. Byte....I would have NEVER thought that it was one word that was the problem!

=0)

27 Mar 2012, 4:10 AM
#29
nguyenhungpv avatar

nguyenhungpv

New Zenner

Join Date:
Mar 2012
Posts:
1
Plugin Contributions:
0

Re: 403 Forbidden error when updating product

I tried change it. Now i happy because I have overcome 403 Forbidden error when updating product