Zen Cart Logo
Forums / Installing on a Linux/Unix Server / Updated to latest version, getting the following error

Updated to latest version, getting the following error

Locked

Views: 2,071

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
6 Sep 2006, 12:02 AM
#1
ripper avatar

ripper

Zen Follower

Join Date:
Jul 2005
Posts:
295
Plugin Contributions:
0

Updated to latest version, getting the following error

Fatal error: Cannot instantiate non-existent class: phpbb in /SERVER_INFO_REMOVED/store/includes/autoload_func.php on line 79

I do not have a phpbb forum on this partcular site. This is the first site I attempted to update. I'm afraid to update the rest of them if this is what's going to happen to all of them.

The cart index page comes up blank except for that error. The admin pages work fine.
I have tried enabling phpbb, no change. I even created a phpbb folder and uploaded a phpbb config file to it, no change.

6 Sep 2006, 12:09 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Updated to latest version, getting the following error

You might re-read the release announcement outlining the things to note during an upgrade, or at least the upgrade/whatsnew docs in the /docs folder which mention the fact that the class.phpBB.php file was renamed to lowercase ...

http://www.zen-cart.com/forum/showthread.php?t=45177

Sorry to be blunt ... but there are other important things to note in the same announcement, thus it's well worth the read...

6 Sep 2006, 12:51 AM
#3
ripper avatar

ripper

Zen Follower

Join Date:
Jul 2005
Posts:
295
Plugin Contributions:
0

Re: Updated to latest version, getting the following error

Ok, that did it.

Just a note though, if you rename a link to a file within the software structure, wouldn't it help if you actually renamed the file itself in the download package?

Also, is there going to be an update in the future that doesn't require completely re-doing custom templates? I had read awhile ago that there was a plan in the works for that to no longer be an issue. I do understand the monumental undertaking that might become, so I'm just curious if it's still in the plans or if it's been abandoned.

6 Sep 2006, 1:47 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Updated to latest version, getting the following error

Ripper:

Just a note though, if you rename a link to a file within the software structure, wouldn't it help if you actually renamed the file itself in the download package?Um ... we did.

6 Sep 2006, 5:04 AM
#5
ripper avatar

ripper

Zen Follower

Join Date:
Jul 2005
Posts:
295
Plugin Contributions:
0

Re: Updated to latest version, getting the following error

That's odd, because I uploaded the entire package to my server, in a new folder, then did the SQL update, so I installed it exactly as I got it from your download site. All I did was change the database login info and the folder data in the 2 config files. According to the release notes, I got the latest version of the release.