Zen Cart Logo
Forums / Installing on a Windows Server / Can't install on local IIS server

Can't install on local IIS server

Locked

Views: 4,125

Results 1 to 14 of 14
This thread is locked. New replies are disabled.
6 Sep 2006, 9:34 PM
#1
blitz49 avatar

blitz49

New Zenner

Join Date:
Apr 2005
Posts:
99
Plugin Contributions:
0

Can't install on local IIS server

Need help installing this. I have installed zencart before, on a windows xp test machine using PHP 5.1.4, MYSQL 4.1, and IIS 5. Installation works on 1.3.0.2 but on 1.3.5 i get stuck on trying to write to the database. I get following error "Error encountered while writing /includes/configure.php." I have given permission to everything I can think of, even added everyone as permission and I still get the error. When I manually input data into configure.php it installs, but i get an error when trying to view storefront and admin section. I am out of ideas, wondering if anyone else encounter this problem and have a solution to this. Any help will be appreciated.

Thank you

6 Sep 2006, 9:43 PM
#2
blitz49 avatar

blitz49

New Zenner

Join Date:
Apr 2005
Posts:
99
Plugin Contributions:
0

Re: Can't install on local IIS server

Nevermind I got it to work, I did not edit configure.php correctly, now that I have it works. Finally. But its strange that on the Prerequisites portion of the installation says includes/configure.php is rewriteable, but when it comes to the database setup portion the file could not be written too. Strange never happened before with the older versions, when I setup test shops on this PC.

6 Sep 2006, 10:09 PM
#3
festus avatar

festus

Totally Zenned

Join Date:
Sep 2004
Location:
Near Barbeque
Posts:
1,067
Plugin Contributions:
0

Re: Can't install on local IIS server

Setup Fart! :P

6 Sep 2006, 11:41 PM
#4
blitz49 avatar

blitz49

New Zenner

Join Date:
Apr 2005
Posts:
99
Plugin Contributions:
0

Re: Can't install on local IIS server

Nope I thought I got it to work, but it does not work. Have downloading the file sets again, and I still get the same error about configure.php being unable to write. This time I manually input the data into admin and includes configure.php, and i still get the error of unable to write to configure.php. Pulling my hair out here, ive checked a million times on giving priviliages and Ive check full control for all, and still I get this error.

6 Sep 2006, 11:47 PM
#5
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Can't install on local IIS server

What permissions does "Internet Guest Account" have for these files?

6 Sep 2006, 11:59 PM
#6
blitz49 avatar

blitz49

New Zenner

Join Date:
Apr 2005
Posts:
99
Plugin Contributions:
0

Re: Can't install on local IIS server

I set it all to full control, I even added Everyone with full control. And I am still getting the error. Under Prerequisites it says:

includes/configure.php = Writeable

admin/includes/configure.php = Writeable

On Database Setup I enter all the needed info that will be written to configure.php and press save I get "Error encountered while writing /includes/configure.php."

Its so weird for the cache folder it is able to write to it when I set the permissions, but not configure.php. I even restarted my computer several times and used foxfire and IE to see if thats the problem. Next option is to reinstall IIS.

7 Sep 2006, 12:49 AM
#7
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Can't install on local IIS server

okay ... so it's writable during initial check. good.

but, after you enter all the settings up to the Database Setup screen, and click Save, that's when it actually writes the file.

Then it reads the file back in again ... and compares it to what it was trying to write. If it doesn't find valid data, it tells you it failed.

So, now we need to examine two things:

  1. what are the permissions set to "now" (when you get the "Error encountered while writing" message)
  2. what are the contents of the /includes/configure.php file --- please post the contents here, without the password.
7 Sep 2006, 12:59 AM
#8
blitz49 avatar

blitz49

New Zenner

Join Date:
Apr 2005
Posts:
99
Plugin Contributions:
0

Re: Can't install on local IIS server

DrByte:

So, now we need to examine two things:

  1. what are the permissions set to "now" (when you get the "Error encountered while writing" message)
  2. what are the contents of the /includes/configure.php file --- please post the contents here, without the password.
  1. all the boxs that says allow are checked for Users and Everyone.

  2. Contents are left as default, nothing is being written at this point when I press the save button. I checked the configure.php and the permission are the same allowed full control for Users and Everyone.

7 Sep 2006, 1:22 AM
#9
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Can't install on local IIS server

Puzzling. Definitely a security permissions issue.

"users" and "everyone" are irrelevant. Those don't really matter in this case.
"Internet Guest Account" is the key.
I'm wondering if there's something being inherited that's preventing this from working...

7 Sep 2006, 1:24 AM
#10
blitz49 avatar

blitz49

New Zenner

Join Date:
Apr 2005
Posts:
99
Plugin Contributions:
0

Re: Can't install on local IIS server

Well Last thing to do is reinstall IIS and PHP. I'll let you know how that goes.

7 Sep 2006, 2:46 AM
#12
blitz49 avatar

blitz49

New Zenner

Join Date:
Apr 2005
Posts:
99
Plugin Contributions:
0

Re: Can't install on local IIS server

Well it works works works. After reinstall IIS and PHP it took care of the problem. Thanks for all the help Dr. Byte. Now to test run this baby out.

7 Sep 2006, 2:53 AM
#13
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Can't install on local IIS server

phew :D I was running out of ideas ... okay, I was OUT of ideas :P

7 Sep 2006, 4:08 AM
#14
blitz49 avatar

blitz49

New Zenner

Join Date:
Apr 2005
Posts:
99
Plugin Contributions:
0

Re: Can't install on local IIS server

LOL, If all else fails reinstall.