Forums / General Questions / Problem sending mail in 1.3.5 SMTP sender-address error

Problem sending mail in 1.3.5 SMTP sender-address error

Locked

Views: 2,956

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
8 Sep 2006, 6:45 PM
#1
cartographer avatar

cartographer

New Zenner

Join Date:
Nov 2005
Posts:
4
Plugin Contributions:
0

Problem sending mail in 1.3.5 SMTP sender-address error

Hi,

I am running a Zen Cart store on my local machine and have no problems with sending emails via Tools > Send Email for 1.3.0.x

After upgrading to 1.3.5, I'm not able to send emails via Tools > Send Email again. There are no error messages displayed on sending the email from the admin but when I checked my SMTP server, it seems like there is a "malformed" sender email address.

For example, if the sender email address is configured as "[email protected]" in Configuration > Email Options, and the store name is set as "Test Store" in Configuration > My Store. Then the actual sender email received by the SMTP server is "Test Store [email protected]" which causes the mail server to discard the email.

Wonder if there's something I missed in my configuration? Btw, I've already applied the fix suggested in this forum for the STMP port but the problem still persists.

Thanks.

8 Sep 2006, 7:11 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Problem sending mail in 1.3.5 SMTP sender-address error

What do you have set for Admin->Configuration->Email Options->Emails must send from known domain?

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

8 Sep 2006, 7:23 PM
#3
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Problem sending mail in 1.3.5 SMTP sender-address error

Since you mention it failing only when using the Tools->Send Email feature, you could go back to the v1.3.0.2 version of the /admin/mail.php file if you don't mind losing HTML editing features.

Granted, I can't see anything in the mail infrastructure nor in that script that would cause malformed email addresses for that tool only, esp when comparing vs 1.3.0.2.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

8 Sep 2006, 7:29 PM
#4
cartographer avatar

cartographer

New Zenner

Join Date:
Nov 2005
Posts:
4
Plugin Contributions:
0

Re: Problem sending mail in 1.3.5 SMTP sender-address error

Here's my configuration for an SMTP mail server running on a windows machine.

My Configuration > Email Options settings are as follows:

E-Mail Transport Method = smtp
E-Mail Linefeeds = CRLF
Use MIME HTML When Sending Emails = false
Verify E-Mail Addresses Through DNS = false
Send E-Mails = true
Emails must send from known domain? = false

Strangely, the problem has gone away after I set E-Mail Transport Method from "smtp" to "sendmail" and then back to "smtp" again!

I've re-checked my settings and confirmed that my problem appears only when the E-Mail Transport Method = "sendmail" for an SMTP server.

Sorry for the trouble...

11 Sep 2006, 5:04 PM
#5
patski avatar

patski

Zen Follower

Join Date:
Nov 2004
Location:
Deal, Kent, UK
Posts:
325
Plugin Contributions:
0

Re: Problem sending mail in 1.3.5 SMTP sender-address error

I also have noticed a problem using sendmail with CRLF selected and use Mime HTML set to true.

It sends the email but doesn't include the sender email Ie storename. It also shows the phpmailer text

X-Priority: 3

X-Mailer: PHPMailer [version 1.73] via Zen Cart

MIME-Version: 1.0

Content-Type: multipart/alternative;

boundary="b1_81483d63d1a465e28975acda400fdcb7"

X-Antivirus: AVG for E-mail 7.1.405 [268.12.2/442]

--b1_81483d63d1a465e28975acda400fdcb7

Content-Type: text/plain; charset = "iso-8859-1"

Content-Transfer-Encoding: 8bit

If I change back to LF okay.