Zen Cart Logo
Forums / Installing on a Mac Server / Not Acceptable error with Mac IE 5.2

Not Acceptable error with Mac IE 5.2

Locked

Views: 6,670

Results 1 to 11 of 11
This thread is locked. New replies are disabled.
24 Sep 2006, 1:37 AM
#1
brian_the_brain avatar

brian_the_brain

New Zenner

Join Date:
Jul 2006
Posts:
16
Plugin Contributions:
0

Not Acceptable error with Mac IE 5.2

This is with Zen-Cart 1.3.5. Macintosh Internet Explorer 5.2 will not allow add to cart. An error page presents instead.

an example or the error is

Not Acceptable
An appropriate representation of the requested resource /dragonfly-p-8.html could not be found on this server.


Apache/1.3.37 Server at prints.brianthebrain.com Port 80

My solution is to modify .htaccess with

"SecFilterEngine DynamicOnly"

I don't recall this error with 1.3.0.2. Also the error is associated with Apache mod_security.

24 Sep 2006, 2:50 AM
#2
Kim avatar

Kim

Obaa-san

Join Date:
Jun 2003
Location:
West Coast, North America
Posts:
26,627
Plugin Contributions:
0

Re: Not Acceptable error with Mac IE 5.2

If you turn off the SEO module does it work?

24 Sep 2006, 3:42 AM
#3
brian_the_brain avatar

brian_the_brain

New Zenner

Join Date:
Jul 2006
Posts:
16
Plugin Contributions:
0

Re: Not Acceptable error with Mac IE 5.2

Kim:

If you turn off the SEO module does it work?

No. But, the message changes to

Not Acceptable
An appropriate representation of the requested resource /index.php could not be found on this server.


Apache/1.3.37 Server at prints.brianthebrain.com Port 80

The change is from the name of the product/attribute... to index.php.

25 Sep 2006, 6:36 AM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Not Acceptable error with Mac IE 5.2

This sounds like you have a misconfiguration in your apache settings with respect to rewrite conditions in your .htaccess.

Are these symptoms isolated to the obsolete IE 5.2 ?

25 Sep 2006, 12:36 PM
#5
brian_the_brain avatar

brian_the_brain

New Zenner

Join Date:
Jul 2006
Posts:
16
Plugin Contributions:
0

Re: Not Acceptable error with Mac IE 5.2

DrByte:

This sounds like you have a misconfiguration in your apache settings with respect to rewrite conditions in your .htaccess.

More likely a clash with the Apache mod_security module. The error 406 occurs (with a different message) whether the SEO rewrite is enabled or not. The fix for now is made by overriding in the .htaccess file.

Although, this might be a timing or sequence problem.

Are these symptoms isolated to the obsolete IE 5.2 ?

From my limited testing, so far only IE 5.2 on Mac OS X. Although others have had this error with other versions of IE with other software. I have only seen this error with Zen-Cart.

And, until I can determine how small the audience is that uses IE 5.x, I'll do what I can to support it.

Microsoft will not provide an upgrade for Mac IE. Thus, obsolete or not that is what some people use.

25 Sep 2006, 11:49 PM
#6
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Not Acceptable error with Mac IE 5.2

Brian the Brain:

More likely a clash with the Apache mod_security module. The error 406 occurs (with a different message) whether the SEO rewrite is enabled or not. The fix for now is made by overriding in the .htaccess file.

Yes, mod_security is a bit of a pain depending on how well it is configured. There seem to be loose standards on its implementation.
If there is a specific issue (ie: specific type of GET/POST'ed data being submitted) which is triggering this, it may be possible to code around it.
It really depends on which mod_security setting is tied to the denial, and what the browser is sending at that time.

10 Dec 2006, 6:24 PM
#8
s_mack avatar

s_mack

Totally Zenned

Join Date:
Jun 2005
Location:
Kelowna, BC Canada
Posts:
1,033
Plugin Contributions:
4

Re: Not Acceptable error with Mac IE 5.2

Two of my customers now :( I would have thought it was so rare I'd never see it again, but I just did.

I also hoped it was because I was using 1.27d... but I see it hasn't been fixed.

Yes, their browser is obsolete... but we don't have ANY control over our customers' browsers.

  • Steven
31 May 2007, 8:22 PM
#9
sanguisdesign avatar

sanguisdesign

Inactive

Join Date:
May 2005
Location:
Western MA, USA
Posts:
588
Plugin Contributions:
1

Re: Not Acceptable error with Mac IE 5.2

has any one figured out what causes this? what settings are required to be changed, I have an end user who cant wrap his head around the fact that the .01% of his audience is him.

JOsh?

31 May 2007, 8:58 PM
#10
s_mack avatar

s_mack

Totally Zenned

Join Date:
Jun 2005
Location:
Kelowna, BC Canada
Posts:
1,033
Plugin Contributions:
4

Re: Not Acceptable error with Mac IE 5.2

No, as far as I know its an issue that's being ignored because it doesn't effect anyone. Obviously, it does... but I guess that theory is that time will correct the situation sooner or later.

1 Jun 2007, 1:58 AM
#11
funkey avatar

funkey

New Zenner

Join Date:
Jul 2005
Posts:
85
Plugin Contributions:
0

Re: Not Acceptable error with Mac IE 5.2

IE 5.2 on Mac platforms does have problems with MIME-type handling on occasion, perhaps you're falling into one of those.

I had several users complain when I updated a shop to serve an XHTML 1.1 compliant template, because Mac IE 5.2.3 chokes on it and serves up the error above.

I used the the article at http://juicystudio.com/article/content-negotiation.php to verify the issue & then http://httpd.apache.org/docs/2.2/content-negotiation.html to configure the mod_negotiation module to serve pages to HTTP 1.0 browsers (MacIE, Lynx, etc) as straight HTML.