Zen Cart Logo
Forums / Basic Configuration / Admin login failure

Admin login failure

Locked

Views: 2,757

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
2 Oct 2006, 1:34 AM
#1
databaseman avatar

databaseman

New Zenner

Join Date:
Oct 2006
Posts:
2
Plugin Contributions:
0

Admin login failure

Greetings,

I just installed ZenCart on my Windows PC so that I can work with it for awhile before installing it on a real website. I have my PC set up as a web server, so I can browse to localhost and view everything.

After installation, I browsed to the zen-cart directory and the store came up. And when I browsed to the admin directory, the admin login page came up. But when I enter the (correct) admin ID and password, the browser thinks for a while, then I get a Windows error that tells me that Apache has encountered a problem and has to close.

I've tracked the problem down to the following line in the admin/includes/header.php file:

$lines = @file(NEW_VERSION_CHECKUP_URL);

If I echo some text and exit just prior to this line, I'm fine; if I try to echo some text and exit just after it, the error occurs and the text is not displayed.

I've browsed to the value of NEW_VERSION_CHECKUP_URL (http://ping.zen-cart.com/version_id.txt) directly, and the page is displayed immediately. So why can't the file be read into $lines?

Any help would be greatly appreciated.

Cheers,
Riich

2 Oct 2006, 1:53 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Admin login failure

Your webserver service is apparently unable to connect properly to our version-notifier server.

You can override that in two ways:

1-during installation, on the Admin details screen, you were offered a checkbox in which to disable this automated checking (this is the same as the Admin->Configuration->My Store->Version Check option setting, but you can't access that if you can't login ... hence the option during installation).

2-you can edit the /admin/includes/local/skip_version_check.ini file to turn off the version-checking

2 Oct 2006, 5:27 AM
#3
databaseman avatar

databaseman

New Zenner

Join Date:
Oct 2006
Posts:
2
Plugin Contributions:
0

Re: Admin login failure

DrByte:

2-you can edit the /admin/includes/local/skip_version_check.ini file to turn off the version-checking
Excellent, thank you!

Rich