Zen Cart Logo
Forums / Setting Up Categories, Products, Attributes / Error uploading images via admin - permission denied on Windows host

Error uploading images via admin - permission denied on Windows host

Locked

Views: 6,086

Results 21 to 25 of 25
This thread is locked. New replies are disabled.
5 Oct 2006, 9:20 AM
#21
ronwong avatar

ronwong

Zen Follower

Join Date:
Jan 2006
Posts:
223
Plugin Contributions:
0

Error uploading images via admin - permission denied on Windows host

hi please enlighten me, about this.
What is the problem with my host? What have you seen from the configure files?

should it be something I need to raise with my host? I really did not do anything with the template.

5 Oct 2006, 9:23 AM
#22
ronwong avatar

ronwong

Zen Follower

Join Date:
Jan 2006
Posts:
223
Plugin Contributions:
0

Re: Error uploading images via admin - permission denied on Windows host

could it be my image folder is somehow corrupted? CAn I delete it and recopy by ftp to test this?

5 Oct 2006, 10:00 AM
#23
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Error uploading images via admin - permission denied on Windows host

I don't see anything obvious with your configure.php files.

It seems like PHP is encountering "no results found" when it attempts to read a directory listing of files, especially in your "images" folder.

You will have to work with your host to fix that.

You could try deleting and re-uploading the images folder. I have no idea if that will help or not. Without having access to your host or to advanced error-reportig or debugging services there's little else I can do to help. If it was an apache host, at least there would be an errorlog that would explain more of what was wrong.

6 Oct 2006, 3:41 AM
#24
ronwong avatar

ronwong

Zen Follower

Join Date:
Jan 2006
Posts:
223
Plugin Contributions:
0

Re: Error uploading images via admin - permission denied on Windows host

You know what. I forwarded your comment 'I will be running not walking to another host if I were you' to my host. And they told me they took a look at my hosting and found that /image/ has changed permission and change it back for me. Now all is ok. I dont know, they have an admin, which allow me to click read/write permission but does not work. You are right that its permission related. Till now I actually dont know whay happened, but it works, thanks goodness. Thanks dr byte for all the explaination, at least I looked into the PHP and get some faint understanding of the cart.

6 Oct 2006, 4:13 AM
#25
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Error uploading images via admin - permission denied on Windows host

ronwong:

they took a look at my hosting and found that /image/ has changed permission and change it back for me. Now all is ok. I dont know, they have an admin, which allow me to click read/write permission but does not work.Very typical of IIS/Windows hosting environments.