Zen Cart Logo
Forums / Installing on a Linux/Unix Server / client denied by server configuration - misconfigured host settings

client denied by server configuration - misconfigured host settings

Locked

Views: 35,893

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
4 Oct 2006, 5:22 PM
#1
redgerry avatar

redgerry

New Zenner

Join Date:
Feb 2006
Posts:
2
Plugin Contributions:
0

client denied by server configuration - misconfigured host settings

I've got a fresh install and am having problems.

Internally (intranet) I can get to the site and see it but the error log displays the following:

[Wed Oct 04 17:33:26 2006] [error] [client 192.168.0.110] client denied by server configuration: /srv/www/htdocs/zen_andystyres/includes/templates/nightfall/images/index.php, referer: http://andystyres.redgerry.com/index.php?main_page=

Externally nothing is displayed, only the error message:

[an error occurred while processing this directive] You don't have permission to access the requested directory. There is either no index document or the directory is read-protected. [an error occurred while processing this directive]

Error log:

[Wed Oct 04 18:10:58 2006] [error] [client 86.142.130.150] client denied by server configuration: /srv/www/htdocs/zen_andystyres/
[Wed Oct 04 18:10:58 2006] [error] [client 86.142.130.150] unable to include potential exec "include/top.html" in parsed file /usr/share/apache2/error/HTTP_FORBIDDEN.html.var
[Wed Oct 04 18:10:58 2006] [error] [client 86.142.130.150] unable to include potential exec "include/bottom.html" in parsed file /usr/share/apache2/error/HTTP_FORBIDDEN.html.var

I run some 14 virtual hosts and another zen site:

http://zendemo.redgerry.com/

these all work fine and have no errors but this new one: http://andystyres.redgerry.com just refuses to play!, I run my own Suse Linux server with all the bells and whistles but have hit a wall here and admit to being baffled. All permissions and ownerships have been checked and I've also trawled the apache support forums with no indication of a cause or solution.

http://redgerry.com
Home of RG_Sports

4 Oct 2006, 7:10 PM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: client denied by server configuration - misconfigured host settings

client denied by server configuration: /srv/www/htdocs/zen_andystyres/
You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

You're likely running your apache service as a user called "apache" or "nobody". This user may not have valid permissions to access the /srv/www/htdocs/zen_andystyres folder.

Your http.conf settings for apache may not properly allow access to /srv/www/htdocs

Seems like a combination of Filesystem permissions and Apache configuration settings.

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

5 Oct 2006, 3:57 PM
#3
redgerry avatar

redgerry

New Zenner

Join Date:
Feb 2006
Posts:
2
Plugin Contributions:
0

Re: client denied by server configuration - misconfigured host settings

Ahhhhhhh

When I had created the Virtualhost file I didn't put the .conf at the end... talk about wood for the trees.

Thanks a lot for your pointers!

http://redgerry.com
Home of RG_Sports