Zen Cart Logo
Forums / Bug Reports / [Done v1.3.6] Country Dropdown Bug

[Done v1.3.6] Country Dropdown Bug

Locked

Views: 14,794

Results 21 to 40 of 61
This thread is locked. New replies are disabled.
3 Nov 2006, 3:20 PM
#21
pauls avatar

pauls

Zen Follower

Join Date:
Feb 2006
Location:
UK
Posts:
300
Plugin Contributions:
0

[Done v1.3.6] Country Dropdown Bug

I have the same error, I have updated to 1.3.6 and get the country drop down error loop.

https://wasp.xssl.net/~admin61/index.php?main_page=create_account

Interestingly if I change the template it does work, so what does this mean?

3 Nov 2006, 4:49 PM
#22
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: [Done v1.3.6] Country Dropdown Bug

Pauls:

Interestingly if I change the template it does work, so what does this mean?

That means that you have customized files in your custom template which you haven't upgraded to v1.3.6 code yet.

When upgrading, you do still need to merge upgrades INTO your customized files if you want the benefits offered by the fixes/additions in the new version.

6 Nov 2006, 4:39 AM
#23
heavenlylingerie avatar

heavenlylingerie

New Zenner

Join Date:
Sep 2006
Posts:
22
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

I have the same error - I have rolled back to v 1.3.5 the tpl_create_account file and it does nothing.

Do I have to reinstall all of the modules I had installed in v 1..3.5 - I only upgraded to 1.3.6 2 days ago...

I am loosing alot of business becuase of this error. Please help...

http://www.heavenlylingerie.com.au/store/index.php?main_page=create_account

Amanda

https://www.heavenlylingerie.coma.u

6 Nov 2006, 4:58 AM
#24
jetx avatar

jetx

Zen Follower

Join Date:
Apr 2006
Posts:
425
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

Does it work ok with the Classic template installed?

6 Nov 2006, 5:05 AM
#25
heavenlylingerie avatar

heavenlylingerie

New Zenner

Join Date:
Sep 2006
Posts:
22
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

I had the extra colours templates installed in v 1.3.5 and they were still there after the upgrade. There is no plain classic template - only the colours. I installed a new template made for v 1.3.6 and tried that - didn't work..

I have lost 2 sales today.....:(

thanks

Amanda
https://www.heavenlylingerie.com.au

6 Nov 2006, 5:19 AM
#26
jetx avatar

jetx

Zen Follower

Join Date:
Apr 2006
Posts:
425
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

What is the error your getting?

6 Nov 2006, 5:21 AM
#27
heavenlylingerie avatar

heavenlylingerie

New Zenner

Join Date:
Sep 2006
Posts:
22
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

same as the others - must select a valid country from the pulldown box..

6 Nov 2006, 5:27 AM
#28
jetx avatar

jetx

Zen Follower

Join Date:
Apr 2006
Posts:
425
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

ok, if it's not working using the default template, then you need to upgrade to 1.36 (that rolled back page you said above (tpl_create_account), needs to be replaced.. and any others you rolled back.

Test it in admin by selecting the default template (Classic Contemporary Green), if that works, you then need compare all your custom pages with the 1.36 default pages. Use winmerge.

6 Nov 2006, 5:35 AM
#29
heavenlylingerie avatar

heavenlylingerie

New Zenner

Join Date:
Sep 2006
Posts:
22
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

didn't work - can I reload v 1.3.5 back over the top of 1.3.6?

6 Nov 2006, 5:44 AM
#30
jetx avatar

jetx

Zen Follower

Join Date:
Apr 2006
Posts:
425
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

No the problem is with 1.35. You need to get rid of those 1.35 pages, but keep all your custom pages and go over those one by one. Make sure all your custom pages are in custom folders.. you know the ol your_template thing.

Do a full 1.36 install (in some new directory) just to prove it works. Don't add any custom pages.. should only take a few minutes to see.

14 Nov 2006, 5:42 PM
#31
wizardsandwars avatar

wizardsandwars

Zen Follower

Join Date:
Jan 2004
Location:
Chesterfield, VA
Posts:
72
Plugin Contributions:
1

Re: [Done v1.3.6] Country Dropdown Bug

I thought I'd chime in on this, since I just spent about an hour figuring out what the problem was.

I installed v1.3.6, which worked perfectly. Then I proceeded to create my template, tested it, and it worked perfectly.

Finally, I installed a 'newsletter subscribe' contribution. This has broken the create account process, and I receive the 'must select a country error'. If I switch to classic template, it still works perfectly. The only real difference is the newsletter subscribe contribution.

So, at least in my case, the issue is with that contribution. It doesn't seem to have the updated code in the files it alters for the account creation process.

14 Nov 2006, 10:41 PM
#32
sparrish avatar

sparrish

New Zenner

Join Date:
Sep 2005
Posts:
67
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

This is definitely a problem with the Newsletter Subscribe contribution. I've made an updated version of the offending file ( catalog/includes/modules/YOUR_TEMPLATE/create_account.php ) that is upgraded to work with 1.3.6. It's too big for the forum, so I'll upload a copy shortly. Let me know if anyone runs into any other issues with this, as I am using it on several sites and would like to be aware of any problems. Thanks!

14 Nov 2006, 11:39 PM
#33
sparrish avatar

sparrish

New Zenner

Join Date:
Sep 2005
Posts:
67
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

Tested and works! I've submitted an updated version of the Newsletter Subscription component with the fix added. It is listed as version 2.0.6.

12 Jan 2007, 3:59 AM
#34
cherdons avatar

cherdons

New Zenner

Join Date:
Jan 2007
Posts:
17
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

1.3.6 doesn't fix it.

Upgrading the newsletter thing is not working. The originally installed Newsletter thing was 2.0.6.

Copied the create_account.php file from both installs over, that did not work.

page is http://www.cherdons.com

12 Jan 2007, 5:20 AM
#35
sparrish avatar

sparrish

New Zenner

Join Date:
Sep 2005
Posts:
67
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

Hi cherdons,

Your site doesn't seem to be loading at the moment. Let me know when it is back up and I would be happy to check it out.

12 Jan 2007, 5:22 AM
#36
cherdons avatar

cherdons

New Zenner

Join Date:
Jan 2007
Posts:
17
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

It's loading.... I was just on there.

12 Jan 2007, 5:35 AM
#38
sparrish avatar

sparrish

New Zenner

Join Date:
Sep 2005
Posts:
67
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

Okay, I was able to get in now. Not sure why I couldn't a few minutes ago. In any event, the problem that you are having doesn't appear to be the Country Dropdown bug that the new version of the newsletter subscribe component was intended to fix. When I tried to sign up, I received this error message:

Warning: main(includes/templates/classic/templates/tpl_subscribe_default.php): failed to open stream: No such file or directory in /home/cherdon/public_html/zen-cart-v1.3.0.2-full-fileset/includes/templates/template_default/common/tpl_main_page.php on line 115

Warning: main(includes/templates/classic/templates/tpl_subscribe_default.php): failed to open stream: No such file or directory in /home/cherdon/public_html/zen-cart-v1.3.0.2-full-fileset/includes/templates/template_default/common/tpl_main_page.php on line 115

Fatal error: main(): Failed opening required 'includes/templates/classic/templates/tpl_subscribe_default.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/cherdon/public_html/zen-cart-v1.3.0.2-full-fileset/includes/templates/template_default/common/tpl_main_page.php on line 115

It looks like there might be a hardcoded include statement in there or something that is causing that issue. If it is any consolation, though, I did receive a subscription confirmation.

12 Jan 2007, 5:39 AM
#39
cherdons avatar

cherdons

New Zenner

Join Date:
Jan 2007
Posts:
17
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

I don't get that, and I am refreshing to make sure -- I was also moving the admin folder over again a few minutes ago - wonder if maybe you were trying when I was moving?

sparrish:

Okay, I was able to get in now. Not sure why I couldn't a few minutes ago. In any event, the problem that you are having doesn't appear to be the Country Dropdown bug that the new version of the newsletter subscribe component was intended to fix. When I tried to sign up, I received this error message:

Warning: main(includes/templates/classic/templates/tpl_subscribe_default.php): failed to open stream: No such file or directory in /home/cherdon/public_html/zen-cart-v1.3.0.2-full-fileset/includes/templates/template_default/common/tpl_main_page.php on line 115

Warning: main(includes/templates/classic/templates/tpl_subscribe_default.php): failed to open stream: No such file or directory in /home/cherdon/public_html/zen-cart-v1.3.0.2-full-fileset/includes/templates/template_default/common/tpl_main_page.php on line 115

Fatal error: main(): Failed opening required 'includes/templates/classic/templates/tpl_subscribe_default.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/cherdon/public_html/zen-cart-v1.3.0.2-full-fileset/includes/templates/template_default/common/tpl_main_page.php on line 115

>  
> It looks like there might be a hardcoded include statement in there or something that is causing that issue. If it is any consolation, though, I did receive a subscription confirmation.
12 Jan 2007, 6:09 AM
#40
sparrish avatar

sparrish

New Zenner

Join Date:
Sep 2005
Posts:
67
Plugin Contributions:
0

Re: [Done v1.3.6] Country Dropdown Bug

I see it now. I would double-check that you changed YOUR_TEMPLATE in the /includes/modules directory to "classic", or that you have overwritten your /includes/modules/create_account.php file with the one from the updated version of the Newsletter Subscribe contribution (v2.0.6).