Zen Cart Logo
Forums / All Other Contributions/Addons / SEO ultimage url SQL error

SEO ultimage url SQL error

Locked

Views: 2,174

Results 1 to 13 of 13
This thread is locked. New replies are disabled.
30 Oct 2006, 8:43 PM
#1
jeanmichel avatar

jeanmichel

New Zenner

Join Date:
Oct 2006
Posts:
43
Plugin Contributions:
0

SEO ultimage url SQL error

Hi, i need help with this one.

i'v installed the SEO module v.1.3.5 and then i'm now stuck on this error page.

1054 Unknown column 'c.parent_id' in 'on clause'
in:
[SELECT c.categories_id as id, c.parent_id, cd.categories_name as cName,
 cd2.categories_name as pName FROM devi_categories c, devi_categories_description cd
 LEFT JOIN devi_categories_description cd2 ON c.parent_id=cd2.categories_id AND 
cd2.language_id='1' WHERE c.categories_id=cd.categories_id AND 
cd.language_id='1']

Seems like it is looking for the c.parent_id column in the database.
So i went there to look for it, in the categories table and it is there. (Actually there is a "parent_id" column)

So i need some assistance here.

i'd wish to give more infos but i guess that's all i can say.

Thanx for helping me out.

30 Oct 2006, 10:23 PM
#2
jeanmichel avatar

jeanmichel

New Zenner

Join Date:
Oct 2006
Posts:
43
Plugin Contributions:
0

Re: SEO ultimage url SQL error

so, seems like there is a problem with the cache but i still cant get it to work. My site is unaccessible.

Someone an idea on how to fix it ?

2 Nov 2006, 6:41 AM
#4
samad64 avatar

samad64

Totally Zenned

Join Date:
May 2006
Location:
Texas
Posts:
554
Plugin Contributions:
2

Re: SEO ultimage url SQL error

if its related to cache.. simply going to Admin > Configuration > SEO URLs and resetting the cache should fix it

2 Nov 2006, 7:01 AM
#5
jeanmichel avatar

jeanmichel

New Zenner

Join Date:
Oct 2006
Posts:
43
Plugin Contributions:
0

Re: SEO ultimage url SQL error

nope.

I read the whole thread from 1 to 34 and nothing about it.

I'm not a sql monk so i dont know, for the moment, what's wrong with the piece of code generated in my error message.

I'm striving to find out.

And related to getyourgames, no, resetting the cache hasnt changed anything about my problem and the same error message is generated.

thanks guys, i'm still looking...

2 Nov 2006, 7:09 AM
#6
samad64 avatar

samad64

Totally Zenned

Join Date:
May 2006
Location:
Texas
Posts:
554
Plugin Contributions:
2

Re: SEO ultimage url SQL error

ah.. this seems to be a mysql 5 issue. found a similar one just browsing the web.. maybe someone with better mysql knowledge can help you fix it

http://forums.alwayswebhosting.com/showthread.php?p=8379
^ note thats for osc

2 Nov 2006, 7:12 AM
#7
jeanmichel avatar

jeanmichel

New Zenner

Join Date:
Oct 2006
Posts:
43
Plugin Contributions:
0

Re: SEO ultimage url SQL error

the problem is fixed :D

Actually, the problem is not fix but a hack has been found in this post to overcome it:

"I had the same problem. I found a workaround by configuring the SEO URLs in the admin page: Configuration / SEO URLs:
Add category parent to beginning of URLs -> set to false.

It seems like a bug,..."

And its a bug. Disabled the Add category parent to beginning of URLs and the error message gone away!

thanks doc!

2 Nov 2006, 7:19 AM
#8
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: SEO ultimage url SQL error

Agreed -- appears to be MySQL5-related.

Just taking a quick stab without testing:

/includes/classes/sel.url.php
around line 912:FROM ".TABLE_CATEGORIES." c, ".TABLE_CATEGORIES_DESCRIPTION." cd LEFT JOIN ".TABLE_CATEGORIES_DESCRIPTION." cd2 Try changing that to:```
FROM ".TABLE_CATEGORIES_DESCRIPTION." cd,
".TABLE_CATEGORIES." c
LEFT JOIN ".TABLE_CATEGORIES_DESCRIPTION." cd2

2 Nov 2006, 7:31 AM
#9
jeanmichel avatar

jeanmichel

New Zenner

Join Date:
Oct 2006
Posts:
43
Plugin Contributions:
0

Re: SEO ultimage url SQL error

mmm.

Looks like it doesnt help much. I've also read the post on the PHP/MYSQL forum, and i thought it would be it.

Maybe trying another combination of changes?

na, i dont know mysql enough to know what i'm doing.

but still, the workaround works fine. even though i'd prefer having the category parent to beginning of URLs.

thanks much anyway, let me know if you find something!

;)

2 Nov 2006, 7:32 AM
#10
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: SEO ultimage url SQL error

It may or may not matter ... but I'm curious .. which version of MySQL are you using?

2 Nov 2006, 6:32 PM
#11
jeanmichel avatar

jeanmichel

New Zenner

Join Date:
Oct 2006
Posts:
43
Plugin Contributions:
0

Re: SEO ultimage url SQL error

I am using mysql 5.0.24a-standard log. Precisely.

Actually, i have another mysql error message generated when i try to upload the sql patch (from the admin panel) for that goggle sitemap mod, this time. Here it is:

Code:

1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'true', 'false'),')' at line 1 in: [INSERT INTO devi_configuration values ('', 'Compress XML File', 'GOOGLE_SITEMAP_COMPRESS', 'false', 'Compress Google XML Sitemap file', @t1, 3, NULL, NOW(), NULL, 'zen_cfg_select_option(array('true', 'false'),');] If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.

Maybe there's a way to relate those 2 errors,who knows?

Thanks

2 Nov 2006, 9:47 PM
#12
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: SEO ultimage url SQL error

Those are unrelated.

Generally speaking, if there are a lot of \ marks in the SQL you paste into the SQLPatch window, you'll end up with failures. Sometimes loading it from a file works better. Sometimes you have to use phpMyAdmin instead, and manually add your table-prefix to each tablename.

2 Nov 2006, 10:36 PM
#13
jeanmichel avatar

jeanmichel

New Zenner

Join Date:
Oct 2006
Posts:
43
Plugin Contributions:
0

Re: SEO ultimage url SQL error

Thanks for the tip but the SEO module package came with an .sql patch written exclusively to upload it via the admin panel.

No need to copy and paste, just have to upload the .sql file.

And those .sql files arent looking the same as the simple syntaxed CREATE TABLE or INSERT or other mysql statements. Those files have some coding in the heading part that i didnt know of.