Zen Cart Logo
Forums / Upgrading from 1.3.x to 1.3.9 / What the heck does this mean?

What the heck does this mean?

Locked

Views: 4,257

Results 1 to 11 of 11
This thread is locked. New replies are disabled.
16 Nov 2006, 3:25 AM
#1
twirlerzmom avatar

twirlerzmom

New Zenner

Join Date:
Nov 2005
Posts:
60
Plugin Contributions:
0

What the heck does this mean?

I upgraded my store from 1.3.5 to 1.3.6. I tested everything within my test store first and everything worked correctly-no errors whatsoever. I then copied my original store to a new folder, named it "original store", then copied all my files in my test store over to the live store folder. I noticed that each time I tried to upload the includes folder about 5 mins in it would stop saying an error occured and timed out. I then went and uploaded each file within the includes folder one by one to make sure all the files made it over. Now when I click on the link to my store I get this error:

1146 Table 'astudioj_zc1.TABLE_METATAGS_CATEGORIES_DESCRIPTION' doesn't exist
in:
[select * from TABLE_METATAGS_CATEGORIES_DESCRIPTION mcd where mcd.categories_id = '0' and mcd.language_id = '1']

What does this mean and how do I fix it?

Oh and this is what my error log says for tonight:

[Wed Nov 15 20:46:30 2006] [error] [client 207.46.98.89] File does not exist: /home/astudioj/public_html/404.shtml
[Wed Nov 15 20:46:30 2006] [error] [client 207.46.98.89] File does not exist: /home/astudioj/public_html/robots.txt
[Wed Nov 15 19:07:31 2006] [error] [client 74.6.74.213] File does not exist: /home/astudioj/public_html/404.shtml
[Wed Nov 15 19:07:31 2006] [error] [client 74.6.74.213] File does not exist: /home/astudioj/public_html/robots.txt

16 Nov 2006, 3:44 AM
#2
twirlerzmom avatar

twirlerzmom

New Zenner

Join Date:
Nov 2005
Posts:
60
Plugin Contributions:
0

Re: What the heck does this mean?

After further digging around I did figure out that the db (zc1) is in fact missing TABLE_METATAGS_CATEGORIES_DESCRIPTION and my 2 other db's I have installed are not missing this. Ok, so that narrowed my problem down......except, I am not referencing zc1 in my config files anyway. I'm referencing the db called "store". And the db "store" has this file. What did I do wrong?

16 Nov 2006, 3:46 AM
#3
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: What the heck does this mean?

Check your files:
/includes/configure.php
/admin/includes/configure.php

On the server ...

Make sure both are using the same prefix, server, database, username and password ...

NOTE: do NOT post that information here when you find it ... :smile:

16 Nov 2006, 3:50 AM
#4
twirlerzmom avatar

twirlerzmom

New Zenner

Join Date:
Nov 2005
Posts:
60
Plugin Contributions:
0

Re: What the heck does this mean?

I just realized I have 2 directories on this server, one called public_html and another called www. I'm reloading everything over to www right now. I wonder if perhaps I put the files in the wrong directory? I'll let you know if I make it better or worse;)

16 Nov 2006, 4:44 AM
#5
twirlerzmom avatar

twirlerzmom

New Zenner

Join Date:
Nov 2005
Posts:
60
Plugin Contributions:
0

Re: What the heck does this mean?

I don't know what's wrong. My config files didn't match so I corrected that and it did make the error go away except then I got a nice html error page saying "having problems connecting to the database, try again in a little while".

My new store seems to work fine however so I think I'm just going to forget about it and just relink to the "new_store" since that works. But could someone just visit via this link to make sure it does indeed work and it's not a case of working for me because it's still in my cache? I'd appreciate it.

Thanks,
http://www.astudiojdesign.com/new_store/

16 Nov 2006, 5:50 AM
#6
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: What the heck does this mean?

I created an account ...

Ordered something ...

Completed checkout ...

Got email ...

Saw order in My Account ...

But ... no secure pages?! :eek:

16 Nov 2006, 1:29 PM
#7
twirlerzmom avatar

twirlerzmom

New Zenner

Join Date:
Nov 2005
Posts:
60
Plugin Contributions:
0

Re: What the heck does this mean?

It's all done through Site Ground hosting and Paypal. Do I need to set up extra security? I've never had an issue before.

16 Nov 2006, 3:33 PM
#8
ajeh avatar

ajeh

Oba-san

Join Date:
Sep 2003
Location:
Ohio
Posts:
62,757
Plugin Contributions:
1

Re: What the heck does this mean?

Customers feel more comfortable any time there is a page where information is collected such as Create Account, Login, etc. etc. to be on a secure page ...

It is up to you whether or not you want your customers to feel secure and to provide that extra level of security to your site for safety sake ...

16 Nov 2006, 3:45 PM
#9
twirlerzmom avatar

twirlerzmom

New Zenner

Join Date:
Nov 2005
Posts:
60
Plugin Contributions:
0

Re: What the heck does this mean?

Ok, so do I have to invest in an SSL to provide this type of security then?

16 Nov 2006, 7:19 PM
#10
website_rob avatar

website_rob

Inactive

Join Date:
Oct 2006
Location:
Alberta, Canada
Posts:
4,572
Plugin Contributions:
0

Re: What the heck does this mean?

Yes, you would.

Getting a Dedicated SSL Cert is definitely the way to go because it means you do not share it with anyone and your Domain name is shown in the Cert. Would cost about $50 USD per year and you can get one from GoDaddy, if you Hoster charges more. Also, most Hosters install Certs free of charge. You can talk to your Hoster about details as they need to provide you with certain information, called a CSR, before you can purchase a Cert.

16 Nov 2006, 10:06 PM
#11
ripper avatar

ripper

Zen Follower

Join Date:
Jul 2005
Posts:
295
Plugin Contributions:
0

Re: What the heck does this mean?

twirlerzmom:

I just realized I have 2 directories on this server, one called public_html and another called www. I'm reloading everything over to www right now. I wonder if perhaps I put the files in the wrong directory? I'll let you know if I make it better or worse;)
the www folder is usually just a virtual copy of the public_html folder. If yours is different, there may be a problem on your server.