Zen Cart Logo
Forums / Installing on a Windows Server / Can not switch from localhost to public IP

Can not switch from localhost to public IP

Locked

Views: 2,479

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
17 Nov 2006, 4:01 PM
#1
lixin avatar

lixin

New Zenner

Join Date:
Nov 2006
Posts:
2
Plugin Contributions:
0

Can not switch from localhost to public IP

I installed Zen Cart 1.3.6. It works fine when I intalled it as localhost. My server has a public IP address. If I switch the localhost to public IP address, the index.php page flashes for a second and then I got the page not found error.

Here is what I did:

  1. Install as localhost for the HTTP, HTTPS and MySQL database. Tested it.
  2. Modify the configure.php to replace the "localhost" with the public IP for the following
    define('HTTP_SERVER', 'http:/localhost');
    define('HTTPS_SERVER', 'https://localhost');

I saw the first page flashes and then got the "page not found" error.
Then I tried to install the ZenCart using the public IP, I got the same error.

I suspect this has something to do the session. Because if I remove the php files that used the "$_SESSION" variables from the sandbox folder, I can see the page banner.

Please advise.

Thanks a lot,

17 Nov 2006, 4:08 PM
#2
pixxi avatar

pixxi

Totally Zenned

Join Date:
Jan 2004
Location:
UK
Posts:
1,065
Plugin Contributions:
1

Re: Can not switch from localhost to public IP

Have you changed both the shop and admin configure.php files to reflect the new IP?

includes/configure.php

and

admin/includes/configure.php

17 Nov 2006, 4:09 PM
#3
lixin avatar

lixin

New Zenner

Join Date:
Nov 2006
Posts:
2
Plugin Contributions:
0

Re: Can not switch from localhost to public IP

Yes, I did.