Zen Cart Logo
Forums / Installing on a Windows Server / backup database issue with multiple IIS accounts

backup database issue with multiple IIS accounts

Locked

Views: 1,918

Results 1 to 5 of 5
This thread is locked. New replies are disabled.
24 Nov 2006, 10:37 AM
#1
danielp avatar

danielp

New Zenner

Join Date:
Nov 2006
Posts:
6
Plugin Contributions:
0

backup database issue with multiple IIS accounts

Hi,

First off… let me say what a fantastic product you have developed. I originally messed around with osC for about 3 weeks and although I found it looks slightly better I found it was buggy as F***. I then switched to ZC and installed first go without any glitches. You have also more support for music related shops (which is great considering we are a well known record shop starting to venture into the world of online sales)


To the problem at hand...

Our hosting provider has a control panel that allows only 1 db per account... they told me that as a workaround I could make another account and have the database for ZC running from that account.

Everything seems to be working fine apart from when I try to make a backup of the database.

The error msg I get is basically saying it can’t write to X directory (which is a path to the account ZC is installed from not the path to the account the DB is running from) if this makes sense.


Is there any way I can change the path just for the database backup to point to the account which is running our database???

Thanks

D.

3 Dec 2006, 10:00 AM
#2
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: backup database issue with multiple IIS accounts

  1. "how" are you performing this backup?
  2. is the folder it's trying to write into set with read/write permissions for your "Internet Guest Account" ?

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

4 Dec 2006, 3:08 PM
#3
danielp avatar

danielp

New Zenner

Join Date:
Nov 2006
Posts:
6
Plugin Contributions:
0

Re: backup database issue with multiple IIS accounts

Hi DrByte,

Thanks for the reply.

I am using the backup Mysql option from the backup mysql module.

I have checked the directory in question and have tried giving read/ write access but nothing.

Here's the error msg I get when trying to run a backup. I am using a windows server. How would I go about altering permissions on cmd.exe to allow Special Access to the Internet Guest Account to read/execute.?

The backup failed because there was an error starting the backup program (mysqldump or mysqldump.exe).
If running on Windows 2003 server, you may need to alter permissions on cmd.exe to allow Special Access to the Internet Guest Account to read/execute.
You should talk to your webhost about why exec() commands are failing when attempting to run the mysqldump binary/program.

Thx

D.

4 Dec 2006, 6:20 PM
#4
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: backup database issue with multiple IIS accounts

It's been ages since I did that on cmd.exe ... but I suspect it's the same as for marking any other file read/write ...

  • right-click the file
  • go to Security properties
  • find Internet Guest Account
  • grant it Execute permissions

... or maybe hit the MS KB for additional ideas... ?

.
Zen Cart - putting the dream of business ownership within reach of anyone!
Donate to: DrByte directly or to the Zen Cart team as a whole

Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

5 Dec 2006, 12:17 AM
#5
danielp avatar

danielp

New Zenner

Join Date:
Nov 2006
Posts:
6
Plugin Contributions:
0

Re: backup database issue with multiple IIS accounts

thanks m8, will have a look...

D.