Forums / General Questions / server upgrade PHP4 to PHP5

server upgrade PHP4 to PHP5

Locked

Views: 1,557

Results 1 to 3 of 3
This thread is locked. New replies are disabled.
25 Nov 2006, 11:59 AM
#1
nielz avatar

nielz

New Zenner

Join Date:
Apr 2005
Posts:
8
Plugin Contributions:
0

server upgrade PHP4 to PHP5

My host just upgraded the server from PHP4 to PHP5 and everything works perfectly... except de checkout, the template page doens't get loaded/

So there's the entire site, without content where the checkout_shipping_default.php would be going.

Any stuff I should check out?

25 Nov 2006, 12:39 PM
#2
nielz avatar

nielz

New Zenner

Join Date:
Apr 2005
Posts:
8
Plugin Contributions:
0

Re: server upgrade PHP4 to PHP5

Can remove this, problem solved.

PHP 5 is a little less forgiving, little customization error.

Thanx though!

25 Nov 2006, 3:56 PM
#3
swguy avatar

swguy

Administrator

Join Date:
Feb 2006
Location:
Tampa Bay, Florida
Posts:
10,718
Plugin Contributions:
56

Re: server upgrade PHP4 to PHP5

If you can get access to your server's logfile, you can find problems like this quickly. Usually you'll see something like

[client 127.0.0.1] PHP Fatal error: main() [<a href='function.require'>function.require</a>]: Failed opening required
'' (include_path='.:/usr/share/pear') in
/var/www/html/higher_1.3.6/includes/templates/custom/templates/tpl_about_us_default.php
on line 23, referer: http://localhost/higher_1.3.6/index.php

which tells you to go to l. 23 in tpl_about_us_default.php.

Good luck,
Scott

That Software Guy. My Store: Zen Cart Support
Available for hire - See my ad in Services
Plugin Moderator, Documentation Curator, Chief Cook and Bottle-Washer.
Do you benefit from Zen Cart? Then please support the project.