Zen Cart Logo
Forums / General Questions / Could not receive Password Forgotten Email

Could not receive Password Forgotten Email

Views: 14,276

Results 1 to 20 of 31
4 Jan 2007, 1:27 AM
#1
syseeker avatar

syseeker

New Zenner

Join Date:
Nov 2006
Posts:
11
Plugin Contributions:
0

Could not receive Password Forgotten Email

Hi,

I have problem with sending email to clients. For debugging purpose, the email archive is enabled and I have confirmed that all emails sent are archived. According to http://www.zen-cart.com/wiki/index.php/Troubleshoot_-_Email_Problems , it is said that If it's in the archive, it was handed off to the mailserver. Once the email leaves Zen Cart™, it's at the mercy of your mailserver.

So can I confirm that the problem does not happened due to ZenCart configuration, but resides in my mail hosting site?:wacko:

This is the settings done at Admin -> Configuration -> Email Options
E-Mail Transport Method : smtpauth
Email Address (Displayed to Contact you) : [email protected]
Email Address (sent From) : [email protected]
SMTP Email Account Mailbox: [email protected]
SMTP Email Account Password : MY_ADMIN_PWD
SMTP Email Mail Host: mail.MYDOMAIN.COM
SMTP Email Mail Server Port: 25

Also for debugging purpose , I have turned on " define('EMAIL_SYSTEM_DEBUG','on'); ". The email content is shown correctly with password given, however, I did receive a warning as shown below, which I guess has no harm but just to raise out its existence.

Warning: Cannot modify header information - headers already sent by (output started at MYDIR/includes/functions/functions_email.php:360) in MYDIR/includes/functions/functions_general.php on line **41

Any clue??
**

4 Jan 2007, 7:24 AM
#2
syseeker avatar

syseeker

New Zenner

Join Date:
Nov 2006
Posts:
11
Plugin Contributions:
0

Re: Could not receive Password Forgotten Email

Before making these changes, I could actually receive new admin password previously. The email is successfully sent from ADMIN GMAIL to the same ADMIN GMAIL addr. The Email Options settings is default as shown below:

E-Mail Transport Method : sendmail
Email Address (Displayed to Contact you) : [email protected]
Email Address (sent From) : [email protected]
SMTP Email Account Mailbox: NOT SET
SMTP Email Account Password : NOT SET
SMTP Email Mail Host: NOT SET
SMTP Email Mail Server Port: NOT SET

But this settings does not work for Password Forgotten Email, and thus I change to settings in #1, which STILL doesn't work. :(

4 Jan 2007, 10:55 AM
#3
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Could not receive Password Forgotten Email

  1. Using gmail for your SMTP server is not fully supported in Zen Cart.
  2. If you are using Zen Cart v1.3.6 or higher, try using the "PHP" method for "Email Transport".
4 Jan 2007, 11:35 AM
#4
syseeker avatar

syseeker

New Zenner

Join Date:
Nov 2006
Posts:
11
Plugin Contributions:
0

Re: Could not receive Password Forgotten Email

Hi DrByte,

  1. I have changed to a specified mail domain, instead of gmail.
  2. I am using Zencart 1.3.5. Does this version has email settings-related problems?

Now, the hosting company has confirmed that settings at #1 is correct. :( But I just couldn't get the password forgotten email sent into my mailbox (a testing yahoo acc). Is it possible due to smtpauth agent problem? buffer? spooling issue...?? I am not familiar with phpMailer nor SMTP configuration...

4 Jan 2007, 11:43 AM
#5
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Could not receive Password Forgotten Email

syseeker:

  1. I am using Zencart 1.3.5. Does this version has email settings-related problems?

It has some SMTP problems, yes.
Also, the PHP option was added to 1.3.6 for greater versatility with more hosts.
v1.3.7 had a few more enhancements for efficiency.

Might be wise to install a 1.3.7 site and test the emails. Then consider whether to upgrade or not.

4 Jan 2007, 12:10 PM
#6
syseeker avatar

syseeker

New Zenner

Join Date:
Nov 2006
Posts:
11
Plugin Contributions:
0

Re: Could not receive Password Forgotten Email

Oh... thanks for the rescue..... :wink2:

9 Mar 2009, 5:55 PM
#7
groel avatar

groel

New Zenner

Join Date:
Dec 2008
Posts:
6
Plugin Contributions:
0

Re: Could not receive Password Forgotten Email

I'm using 1.3.8a, and don't receive emails (specific domain) of forgotten passwords. I've tried php, smtp and smtpauth for the email transport method, but none work. The site in question is https://www.vermontdesignsunlimited.com.

Any thoughts?

Thanks!

Greg

14 Oct 2009, 11:35 PM
#8
way10c avatar

way10c

New Zenner

Join Date:
Sep 2009
Posts:
14
Plugin Contributions:
0

Re: Could not receive Password Forgotten Email

I can't get emails sent to a yahoo.com account to reset password. I get a bounce back message that says:

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

XXXXX[at]yahoo.com
Mail sent by user nobody being discarded due to sender restrictions in
WHM->Tweak Settings

Can this be fixed w/ a setting in the Zen Cart admin or is it a web host problem.

Thanks.

--Allen

15 Oct 2009, 4:59 PM
#9
drbyte avatar

drbyte

Sensei

Join Date:
Jan 2004
Posts:
63,513
Plugin Contributions:
176

Re: Could not receive Password Forgotten Email

way10c:

Mail sent by user nobody being discarded due to sender restrictions in
WHM->Tweak Settings

That's a hosting config problem.

5 Nov 2009, 6:21 PM
#10
yesac13 avatar

yesac13

New Zenner

Join Date:
Aug 2006
Posts:
17
Plugin Contributions:
0

Re: Could not receive Password Forgotten Email

Any leads on this? I'm not getting my password reset emails.

If it is a hosting config problem, could anybody tell me what to start looking at. My hosting company, so far, has been unable to fix this problem.

I have no other email problems, just that customers who forgot their emails never gets their emails with the new password...

18 Nov 2009, 9:19 PM
#11
guyrcook avatar

guyrcook

New Zenner

Join Date:
Nov 2009
Location:
Washington State USA
Posts:
1
Plugin Contributions:
0

Re: Could not receive Password Forgotten Email

Yesac13:

Any leads on this? I'm not getting my password reset emails.

If it is a hosting config problem, could anybody tell me what to start looking at. My hosting company, so far, has been unable to fix this problem.

I have no other email problems, just that customers who forgot their emails never gets their emails with the new password...

Using 1.3.8a the latest version and don't receive password reset emails either. If this is a hosting config problem please be more specific, so that it can be fixed.

GC

19 Nov 2009, 1:59 PM
#12
bobthemolder avatar

bobthemolder

Zen Follower

Join Date:
Nov 2008
Posts:
164
Plugin Contributions:
0

Re: Could not receive Password Forgotten Email

Getting the same problem here on my new ZenCart installations.

10 Jan 2010, 6:39 PM
#13
pgonline avatar

pgonline

New Zenner

Join Date:
Dec 2009
Posts:
26
Plugin Contributions:
0

Re: Could not receive Password Forgotten Email

I'm having the same problem... all email notices work except for password resets.

After an email address is entered the site notifies the customer that an email has been sent with a new password. but nothing actually arrives.

Any help would be greatly appreciated.

Thanks

22 Jan 2010, 7:41 AM
#14
rachalmers avatar

rachalmers

New Zenner

Join Date:
Mar 2008
Posts:
55
Plugin Contributions:
0

Re: Could not receive Password Forgotten Email

Ok, this is really bad.

Zen Cart v1.3.8a/v1.3.8

I have tried PHP. it won't send the email. dies with errors

I've tried with sendmail, as shown below. It tells me it works, but I never see the email.

*Module: direct_email

To: Robert Chalmers [[email protected]]
From: Skin Care Australia [[email protected]]
Sent: 2010-01-22 00:34:51
Subject: test from zencart

Message Excerpt:

yes, well.......*

I've tried with SMTP

ERROR: Failed sending email to: "Robert Chalmers" with subject: "test from zencart" The following From address failed: [email protected]

and it fails no matter what address I use in the From field.

...
now, sendmail-f appears to work as well as sendmail.
Success: E-mail #2 has been resent to [email protected]

SMTPAUTH fails.
ERROR: Failed sending email to: "Robert Chalmers" with subject: "test from zencart" The following From address failed: [email protected]

QMAIL appears to work - and really quickly too.
Success: E-mail #2 has been resent to [email protected]

Summary:
sendmail takes forever to process the email. I mean like about 5 minutes. appears to work. but I get no email

sendmail-f the same.

qmail appears to send the mail, and processes it very quickly. milliseconds, like it should.

Nothing else even looks like sending mail, see errors above.

To date, I have not received one single email from the system. !!!!

Now as this whole thing relies on email to do business - this critical part of the system should be rock solid.

I'm on a standard hosting server, alldomains.com on a linux server. Everything else I run has no problems with email. moodle, and a number of others.

now this is really ODD. ODD I say. I have another ecommerce site, with zen-cart installed, on the same hosting server, and it uses PHP ---- and works with NO ERRORS - except of course it wont send the lost password. However - all other email works fine ???

go figgure

I don't understand why this one is failing....

So any authoritative assistance would be really help full...

thanks guys.

22 Jan 2010, 7:54 AM
#15
rachalmers avatar

rachalmers

New Zenner

Join Date:
Mar 2008
Posts:
55
Plugin Contributions:
0

Re: Could not receive Password Forgotten Email

Ok, it seems that mail from the ADMIN is failing.

I tried on my live site, where I sell audio-books etc, on the radio station site, http://www.quantum-radio.net/audio_zen/

went into Admin, and Tools, send email - and guess what.

Email Error: Could not instantiate mail function. Please check Admin->Configuration->Email Options->Email Transport.

Now this site works for customers - although I haven't had a password needing to be resent yet.

But - as Admin, PHP doesn't work to send email, giving the error above. Apparently - as a customer, it works for them.

what's up doc.

22 Jan 2010, 11:28 AM
#16
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Could not receive Password Forgotten Email

Regarding zen-cart and email.

I don't profess to have all, or even any of the answers, but I do know several important facts that are relevant and worth keeping in mind.

Firstly, not all ISP's use the same mail program(s), and those that do invariably have thier own settings and configurations in regards to what is, or isn't allowed.

This is why zen-cart offers so many different email options. There is almost certainly at least one setting/option avaialble that will work with any given ISP. Some systems may even support several different methods.

The trick is figuring out what your particular ISP supports and allows.

rachalmers:

I have tried PHP. it won't send the email. dies with errors

This suggests that your ISP dissallows mail sent via this method.

rachalmers:

I've tried with sendmail, as shown below. It tells me it works, but I never see the email.

Give it a few days and the mail will probably be returned to you as being undeliverable.

rachalmers:


To: Robert Chalmers [[email protected]]
From: Skin Care Australia [[email protected]]

Is [email protected] a valid email address on the server hosting your zencart? If not, this email will probably fail because the system will reject at as not being sent by an authorised sender.

rachalmers:

I've tried with SMTP

This one is probably the least likely to work on a linux based system. Very few ISP's allow for this type of access, if it does work it often indicates that the server has been setup in such a way that it is vulnerable to abuse because very few (if any) checks and balances are in place.

rachalmers:

and it fails no matter what address I use in the From field.

Have you tried using [email protected] in the 'from' field?
If anything is going to work it will be this.

rachalmers:

now, sendmail-f appears to work as well as sendmail.
Success: E-mail #2 has been resent to [email protected]

The 'success' here simply means that the sendmail program has accepted the mail. It doesn't suggest that the mail has actually left the server. It is possibly sitting in an outgoing mail spool (for any number of reasons).

rachalmers:

SMTPAUTH fails.
ERROR: Failed sending email to: "Robert Chalmers" with subject: "test from zencart" The following From address failed: [email protected]

SMTPAUTH will only work if your server requires SMTP authorization. It is similar to SMTP in functionality, in that the mail is sent direct (rather than via sendmail) , but to avoid the abuse that is possible with regular SMTP this method requires authentication, which means you must define a valid username, password, host and port in the zencart settings. SMTPAUTH is generally only needed/required if you are using your ISP's servers as a relay. I would suggest that since zencart and the mailserver it uses are in the same domain this method probably isn't widely used. It would probably be one of the last methods that I'd be trying.

rachalmers:

QMAIL appears to work - and really quickly too.
Success: E-mail #2 has been resent to [email protected]

This is where things get a liitle 'blurred' (in my opinion). Sendmail and Qmail both serve the same purpose, and generally speaking only one or the other will be used by your ISP.
The fact that BOTH appear to work with your ISP would imply a 'symbolic link' is being used, so when the mail is sent to sendmail it is actually going to Qmail (or vice verci). It would be wise to verify with your ISP which of these mail agents are actually being used and select the appropriate one. If set correctly it usually won't make a difference, but if your ISP haapens to have both programs avaialble and only one of them configured it is easy for mail to end up in a 'black hole'.

rachalmers:

Summary:
sendmail takes forever to process the email. I mean like about 5 minutes. appears to work. but I get no email

sendmail-f the same.

qmail appears to send the mail, and processes it very quickly. milliseconds, like it should.

I find this a bit disconcerting, because as stated above, sendmail and qmail are different programs that perform the same purpose. If both appear to work (and work correctly) it is (usually) by virtue of a symbolic link. The fact that you are getting different results implies both programs are installed. This will result in an administration nightmare, and I'd go as far to say that only one of them has actually be configured. Check with your host to see which one they are actually using.

rachalmers:

I'm on a standard hosting server,

Yes, but which 'standard' (The nice thing about standards is that there are so many to choose from) <grin>

rachalmers:

alldomains.com on a linux server. Everything else I run has no problems with email. moodle, and a number of others.

Wow. Moodle eh? That took me a bit by surprise. I guess you have something to do with the education system? I always though I'd be the only person here that's even heard of moodle (as popular as it is).

rachalmers:

now this is really ODD. ODD I say. I have another ecommerce site, with zen-cart installed, on the same hosting server, and it uses PHP ---- and works with NO ERRORS - except of course it wont send the lost password. However - all other email works fine ???

go figgure

This may (even probably) has something to do with the 'from' addresses being used? Some systems are pretty strict in this regard and will only accept/send emails from 'known' addresses.

rachalmers:

I don't understand why this one is failing....
So any authoritative assistance would be really help full...

thanks guys.

I'm not going to be as bold to say I'm an authority in this regard, and I certainly can't say why yours is failing, but I can say that due to the sheer number of spammers and would-be abusers 'out there', most systems tend to get locked down pretty tight these days and it can sometimes take a bit of juggling and experimenting to find what works and what doesn't. There is no single answer or method that will work for everyone.

I do have a couple of suggestions though.

  1. Try to get your webhost involved. They will have log files that will let them know exactly what is going on.

  2. If your host gives you cPanel for administration purposes have a look for the 'Mail troubleshooting' or the 'Email Delivery Route' module(s).
    Enter a few email addresses, eg *[email protected] *It may provide a few clues as to what is going on (especially if the test mails are to one of your own aliases on the same server).

Anyway, as I said at the start, I've no real answers or solutions for you, I'm just imparting a few things that I know that may or may not be helpful.

Cheers
Rod

22 Jan 2010, 1:04 PM
#17
rachalmers avatar

rachalmers

New Zenner

Join Date:
Mar 2008
Posts:
55
Plugin Contributions:
0

Re: Could not receive Password Forgotten Email

Hi Rod,
thanks for the breakdown. However - tried all the above.
I've been working with coding for donkeys years now - and have countless other packages all running fine on the server. Some quite complex like Moodle, some as simple as instant downloads for audiobooks, and a couple of ecommerce sites. any number of mailers, like news letter subscriptions etc etc.

phpinfo tells me that the linux server is running sendmail. In addition to this, the webmail side, that I don't use, uses qmail.

all those email addresses you see are valid and belong to my domains, hosted on this same server.

Well. Only recently taken up zen-cart - and what do you know. the core of the product - the email system - is a real dog.
I've wandered across the forums, and the internet looking for answers, and as usual .... nada. although there are many many people having email problems. So I'm not alone.

All of the above options I tried, were to see just what would work and what wouldn't. As it turns out - nothing works. In that I still haven't received even one email from the system. Oh sorry. My son tried a purchase on the audiobook site I ran up, and he got a text message back as an Order Confirmation. That's the only email I've ever seen from both systems. I thought the audiobooks one was working but it's not after all - only that order confirmation.
So of all the software I have installed - only zen-cart wont deal with email properly. So I can say with confidence that it's not the ISP/Hosting service or server. It's not anything else but zen-cart as far as I can see.

the email-archive addon tells me that email has been sent from the various tests - but there's no sign of it. So I need to go deeper it seems.

so it looks like I'm going to have to delve into the code and try and see what is happening. what a pain. A real pain.

Thanks for your thoughts on the subject Rod. All input is very welcome in case I miss something - as I'm sure I will :-)

cheers
Robert

22 Jan 2010, 2:18 PM
#18
rodg avatar

rodg

Deceased

Join Date:
Jan 2007
Location:
Australia
Posts:
6,263
Plugin Contributions:
4

Re: Could not receive Password Forgotten Email

rachalmers:

Well. Only recently taken up zen-cart - and what do you know. the core of the product - the email system - is a real dog.
I've wandered across the forums, and the internet looking for answers, and as usual .... nada. although there are many many people having email problems. So I'm not alone.

I have no doubts that you are not alone, and I do apologise if I told you many things you already knew. Hopefully I didn't appear to be condescending?

rachalmers:

All of the above options I tried, were to see just what would work and what wouldn't.

Yes, it WAS pretty obvious that you had tried many things to see what did and didn't work.

rachalmers:

As it turns out - nothing works. In that I still haven't received even one email from the system. Oh sorry. My son tried a purchase on the audiobook site I ran up, and he got a text message back as an Order Confirmation. That's the only email I've ever seen from both systems. I thought the audiobooks one was working but it's not after all - only that order confirmation.

I'm sure that this is as puzzleing to you as it is to me. As you know, computers are so pedantic they either work or they don't work. To have something partly work (or work sometimes) is really extremely unusual, and there is always a cause for it. It make me wonder what is different between the order confirmation that you did receive and all the mails that you aren't recieving.

rachalmers:

So of all the software I have installed - only zen-cart wont deal with email properly. So I can say with confidence that it's not the ISP/Hosting service or server. It's not anything else but zen-cart as far as I can see.

I'd really like to agree with you on this, but there are many of us that don't appear to be having any problems with emails, so even though it clearly has something to do with zen-cart, the actual problem is a bit more subtle than that, and it would suggest that it has something to do with a configuration setting OR some sort of compatibilty issue with some hosts only.

rachalmers:

the email-archive addon tells me that email has been sent from the various tests - but there's no sign of it. So I need to go deeper it seems.

so it looks like I'm going to have to delve into the code and try and see what is happening. what a pain. A real pain.

I still reckon that getting your ISP involved (assuming you don't have access to the mail log files) would be the easiest next step. At least their findings may give a clue as to where you should be looking.

rachalmers:

Thanks for your thoughts on the subject Rod. All input is very welcome in case I miss something - as I'm sure I will :-)

Well, we do all miss things at times - so tossing considered ideas and thoughts around is often all it takes.

I'm pretty much out of ideas. I am convinced that the log files will hold the key to the problem (but not necesarily the solution ).

Cheers
Rod

22 Jan 2010, 8:15 PM
#19
rachalmers avatar

rachalmers

New Zenner

Join Date:
Mar 2008
Posts:
55
Plugin Contributions:
0

Re: Could not receive Password Forgotten Email

I just checked the Moodle install. It uses PHP for mail, and is working fine? Has done for over a year and over a thousand students.

PHP in zen doesn't work, returning an 'insubstantiate' error message.

hmmm

22 Jan 2010, 10:47 PM
#20
rachalmers avatar

rachalmers

New Zenner

Join Date:
Mar 2008
Posts:
55
Plugin Contributions:
0

Re: Could not receive Password Forgotten Email

and I see that in the osCommerce forums, the same problems are being talked about.
I'm suspecting that it's a problem in the zen mail handling interface.
The fact that some work and some don't is probably a factor of poorly configured host/server mail handlers that let anything through, rather than correctly configured zen installations.

as I said, any number of other packages on my system work fine. Zen doesn't.

When I find a solution to this, I'll post it for all to see.